LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2004, 06:29 PM   #1
S2001LTD
LQ Newbie
 
Registered: Aug 2004
Posts: 4

Rep: Reputation: 0
Unhappy how do i input chinese text ??????????


I am running linux 9 i need help like in widnows it is easy to set up the ime but how do i do it in linux is there a program or something within linux plz help me i really need to input chinsese text

thanks
S2001LTD
 
Old 08-03-2004, 06:32 PM   #2
Charalambos
Member
 
Registered: Aug 2004
Location: Switzerland
Distribution: debian
Posts: 149

Rep: Reputation: 15
now what distribution is linux 9 exactly?
 
Old 08-03-2004, 06:42 PM   #3
S2001LTD
LQ Newbie
 
Registered: Aug 2004
Posts: 4

Original Poster
Rep: Reputation: 0
all i know it is red hat linux 9 total new at this
 
Old 08-03-2004, 06:53 PM   #4
Charalambos
Member
 
Registered: Aug 2004
Location: Switzerland
Distribution: debian
Posts: 149

Rep: Reputation: 15
uuhh, i'm not used to red hat, but there should be some configuration panel somewhere where you can change the mapping of the keyboard.
If you're under x (~graphical desktop environment) you should find something like "System Settings" or somesuch under the Main Menu.
 
Old 08-03-2004, 06:55 PM   #5
Charalambos
Member
 
Registered: Aug 2004
Location: Switzerland
Distribution: debian
Posts: 149

Rep: Reputation: 15
I just found this in red hats documentation. That should do the trick.

Quote:
If you wish to change your keyboard type after you have installed your Red Hat Linux system, become root and type either /usr/sbin/kbdconfig or setup at the root prompt.
 
Old 08-03-2004, 07:20 PM   #6
S2001LTD
LQ Newbie
 
Registered: Aug 2004
Posts: 4

Original Poster
Rep: Reputation: 0
freewnn is started but now how input it is there a command or something i am still not able to write it so plz help me out some more thanks
 
Old 08-05-2004, 06:12 PM   #7
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
how do I input chinese text?????

Hi,

When you installed Red Hat 9 did you select Simplified and/or Traditional Chinese as additional languages? If you did then the install process would have installed all the necessary files and applications for you to be able to read write etc. in Chinese.

Assuming that you did select Chinese, and also assuming that you want to use a GUI desktop interface such as KDE or GNOME, then when you are at the login screen and you type in your username and password, you should be able to easily select Chinese as your language of choice for your current session by clicking on the Language button. Very nice & easy, and when you are logged in you can run at a terminal window command line :

$ chinput & oowriter

this will start the chinput XIM server and then by pressing CTRL + SPACE you can toggle between Chinese and English input. (Toggle CTRL + SHIFT to choose different input methods such as Pinyin, Cangjie, Cantonese etc).

If you didn't selected Chinese as an additional language when you installed Red Hat, then you can a) install again (probably the easiest way for a relative beginner to Linux) or b) do it the "fun" way by installing all the Chinese font files, the zh_CN and zh_TW locale files, IME applications such as xcin and chinput and kde-i18n packages. All the required files are on the distribution CDs.

Hope this helps, if not, ask again and we'll help you get it up and running. BTW, if you type "chinese input" in the search field in LQ Forums you will see many posts, questions & answers on this topic, and if you can spare the time to read through them it will help you a lot.

jdw

ps to charalambos, JTLYK languages like Chinese, Japanese & Korean use multibyte character sets, and thus do not use the normal keyboard mappings, but require IME servers to map series of keyboard strokes to characters...cheers!
 
Old 09-21-2004, 06:56 AM   #8
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 427

Rep: Reputation: 30
Hello,

I am just newbie in Linux and I want to read Chinese in Linux platform.

I took a look in thread
http://www.linuxquestions.org/questi...t=read+chinese

I think I did not choose Chinese when install Red Hat 9 in the very begining, I have installed xcin with apt-get. So how to set chinese user to have access with the libxcin file?

Thank you for the help.
 
Old 09-21-2004, 06:04 PM   #9
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
how do I input chinese text?????

Hi,

You will need to make sure that you have the Chinese locale files installed, as well as some Chinese font files and if you are using KDE the kde-i18n files for Chinese.

My advice though, it is easier to just back up any files you may want to save and just reinstall RH9 and select Traditional and Simplified Chinese when asked to (not as your install language (about the first screen you come to) but the screen where it asks you for additional languages. Then when you log into your GUI system it gives you the option of choosing a language for that session, you can select Chinese from the list.

Otherwise you will have to find the relevant rpm packages for the locales, fonts etc. on your distro CDs, they are all there, once all these are installed you should be able to get it all going.

have fun!

jdw
 
Old 09-21-2004, 11:55 PM   #10
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 427

Rep: Reputation: 30
What I want is just read a file with Chinese characters inside in the console windows.

I have reinstall the RedHat9 and choose serveral languages. I can read the selected languages in browser.

But I still can not read file with Chinese characters inside. Please figure out how to do it for me. Do I need to export something in users?

"when you log into your GUI system it gives you the option of choosing a language for that session, you can select Chinese from the list."

[root@localhost day5]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
 
Old 09-22-2004, 12:08 AM   #11
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
how do I input chinese text?????

hi,

ok, I'm assuming you are logged in a Desktop environment such as Gnome or KDE and want to use a console window like "Konsole" or "xterm", here's what you can do :-

in the console window, at the command line (of course!), type the following commands :-

$ export LANG=zh_CN.UTF-8
$ export LC_ALL=zh_CN .UTF-8
$ export LC_CTYPE=zh_CN.UTF-8
$ export XMODIFIERS=@im=xcin // or chinput, fcitx etc.

you can change the above to zh_TW.UTF-8 if you need Traditional Chinese.

what the above does is change the locale FOR THAT CONSOLE SESSION to Chinese, which allows the console window program to process and display Chinese characters, which are very different to Latin characters of course.

The XMODIFIERS line tells bash to use xcin as the input method software...so if you just want to read Chinese you don't really need to put this...

good luck...

jdw
 
Old 09-22-2004, 08:24 PM   #12
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 427

Rep: Reputation: 30
Thank you so much JDW, it really helpD@can now read Chinese and also input Chinese. I just reinstall the RH9 and select the languages in the begining of the installation.

Now I@@@A@ס@@@@@@@Ѣ @@A@@B@@@@ @@@, it pop out suddely.
 
Old 09-22-2004, 08:27 PM   #13
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 427

Rep: Reputation: 30
The Chinese input tools even affect the display of the last post. I can not help the pop out of the Chinese input box, that for selection of different input methods.

How can I@@@AH

@B@@@@ס^
 
Old 09-22-2004, 08:35 PM   #14
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
to close the input box, i.e. toggle between Chinese and English, press CTRL + SPACE. To toggle the different kinds of input methods, press CTRL + SHIFT...
 
Old 09-22-2004, 08:49 PM   #15
fhleung
Member
 
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 427

Rep: Reputation: 30
Talking

Thank you once again JDW
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese input djib Debian 20 06-16-2008 02:41 AM
Chinese input denning Slackware 16 02-24-2005 01:39 AM
Chinese input Cyberian Fedora 2 02-15-2005 07:32 AM
Chinese Input Problem chinaundead Mandriva 16 11-26-2004 10:44 AM
Chinese Input In Mdk 9.1 awtoc123 Linux - General 24 10-27-2003 07:50 AM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration