LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2010, 09:05 AM   #1
Random1980
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Rep: Reputation: 0
How do I get Firefox 3.6.12 to start up with Xandros desktop icon rather than 3.0.1?


I've used this approach to install Firefox 3.0.1 on my stock EEE PC, which has worked very well. I've since downloaded and installed version 3.6.12 for Linux, and I can start it up through the terminal with the command
~/firefox/firefox
However, I can't start up 3.6.12 using the desktop icon; instead, it reverts back to version 3.0.1. How can I get the desktop icon to start 3.6.12?
 
Old 12-04-2010, 09:15 AM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Hi there,

usually, that desktop icon is more than merely an icon - it's a launcher of some sort (in reality it is just a file) which you'd need to edit (with a text editor, or right-click -> properties) so that it launches your choice of application. The launcher will have some sort of "target" attribute, or "path to application" attribute, which you would set to be the path to your new Firefox.

Or, do you have any kind of right-click context menu, if you right click the desktop, whereby you can create a NEW launcher icon?

Also, there's a section at the very bottom of the page you linked, called:
Code:
“How do I get a Firefox 3 icon in the Quick Launch taskbar, like/instead of Firefox 2?”
Have you tried what's suggested there? Or is that instruction specific to the menu button, rather than the desktop icon?

I don't use Xandros, and I do not believe a whole whack of other LQ members do either, so we do not get frequent questions about that OS; please be patient with us and hopefully we can work together to get your icons sorted out.

Last edited by GrapefruiTgirl; 12-04-2010 at 09:21 AM.
 
Old 12-04-2010, 09:20 AM   #3
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Hey, check this article too (Xanrdos Wiki): http://geekconnection.pbworks.com/w/...ll-About-Icons
 
Old 12-04-2010, 01:48 PM   #4
Random1980
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the response. I have tried that approach, with some success. First, by right-clicking on a blank part of my "full desktop" mode panel, I don't have the options "Add to panel" or "Special buttons", but I can do something similar through the following steps:
1. Right Click on empty area of panel, select 'Create New' and then 'Link to Application'
2. Under the 'General' tab, enter "Firefox"
3. Under the 'Applications' tab, browse to enter "/home/user/firefox/firefox" in the 'Command' field
When I go back to "Safe Mode", the desktop icon still opens version 3.0.1. I'll keep trying things...
 
Old 12-04-2010, 02:06 PM   #5
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
Didn't Xandros stop supporting their OS in 2006?
 
Old 12-04-2010, 02:30 PM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by Random1980 View Post
...
When I go back to "Safe Mode", the desktop icon still opens version 3.0.1. I'll keep trying things...
Just a thought - maybe safemode runs as a different user and/or with a different $PATH setting, and the path to the application is different as a result? Maybe try creating a second icon while in safemode, and see if it works the same or differently as the first one?

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No firefox icon on desktop,(idesk) cola Linux - General 3 12-28-2009 02:11 AM
Firefox via the Desktop and Start menu icon on Suse 10.1 fofire Linux - Desktop 4 08-14-2006 02:44 AM
How to make desktop icon for FireFox? adds2one Linux - Newbie 4 08-30-2005 09:35 PM
Firefox Startup icon for desktop Will2Pwr Red Hat 1 02-12-2005 08:05 PM
Firefox 1.0 desktop icon allanl Linux - Software 4 11-11-2004 07:48 PM


All times are GMT -5. The time now is 09:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration