LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2010, 08:59 PM   #1
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Rep: Reputation: 30
How do I format a second HDD


I'm running Ubuntu 9.10 Main. I installed a second backup HDD to my system which is formatted in NTFS. Ubuntu sees it OK, but I'd like to format it in ext 3 or 4 as well.

Gparted does see it but only gives me formats like win98,beOS, and sun as a default format. If I try to unmount it I get: "Unable to unmount location. Daemon is inhibited." If I select load into terminal it shows: "/media/14G Western Digital HD$". Is there a way to format it within the command line? Thanks.
 
Old 08-03-2010, 09:13 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch
Posts: 1,599

Rep: Reputation: 97
Hya,

fdisk, mkfs will be your friend.

Happy Penguins!
 
Old 08-03-2010, 09:17 PM   #3
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Original Poster
Rep: Reputation: 30
I was able to format it with ext 4, but when I try changing the permissions (say's I don't have it), with sudo chmod 777 I get "chmod: missing operand after `777'". How do I fix this?
 
Old 08-03-2010, 09:18 PM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
chmod requires arguments - check the man page for proper syntax.
 
Old 08-03-2010, 09:49 PM   #5
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Original Poster
Rep: Reputation: 30
I did. Didn't find the answer. Anyone know it?
 
Old 08-03-2010, 09:54 PM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Here's an example:
Code:
sasha@reactor: touch BLARG
sasha@reactor: chmod 777
chmod: missing operand after `777'
Try `chmod --help' for more information.
sasha@reactor: chmod 777 BLARG
sasha@reactor:
Did you specify what to chmod?
 
Old 08-03-2010, 11:50 PM   #7
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Original Poster
Rep: Reputation: 30
"BLARG"? I don't know what an operand is. I just want to make my backup HDD accessible. Right now it just says I don't have permission to copy files to it. Why does this have to be so complicated?

Last edited by jacatone; 08-03-2010 at 11:54 PM.
 
Old 08-04-2010, 12:12 AM   #8
krasl
Member
 
Registered: Nov 2005
Distribution: Fedora 4
Posts: 40

Rep: Reputation: 15
Using chmod: you first specify the permissions you wish to set. In this case, 777 (readable, writable, executable by everyone).
After that, you specify the file or directory to which these permissions are to be applied.

For example, if you have mounted your hard drive as /mnt/hd2, you could change permission to that drive by:
sudo chmod 777 /mnt/hd2

If there are files on the drive, you could recursively change all their permissions to 777 simultaneously by:
sudo chmod -R 777 /mnt/hd2

NOTE: it sounds like something isn't right if you have formatted the drive as ext4 but are not able to access it. Did you mount it after creating the filesystem?
sudo mount -t ext4 /dev/[device name here] /mnt/[directory to mount into]
replace [device name here] with the device name for this hard drive (you can get a list of devices with 'sudo fdisk -l'
replace [directory to mount into] with the directory you want to attach the drive to. (create this directory first!)

BTW: an 'operand' is just a bit of information which is fed into a command. "An input value or parameter."
 
Old 08-04-2010, 01:39 PM   #9
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Original Poster
Rep: Reputation: 30
It auto mounts. When I right click to "Open in Terminal", it shows as "jacatone@Dell /media/c5f7e03b-2c9c-4c76-abb1-a51ed7e05a14 $". So, what operand would I use to make it accessible? BTW, it has a Lost and Found file in it already. Thanks.
 
Old 08-04-2010, 02:30 PM   #10
tealio
LQ Newbie
 
Registered: Aug 2010
Location: Atlanta, GA
Distribution: Ubuntu 10.04
Posts: 23

Rep: Reputation: 18
Try
Code:
sudo chown -R yourusername:yourusername /path/to/mount/point
 
Old 08-04-2010, 07:11 PM   #11
jacatone
Member
 
Registered: Mar 2004
Posts: 280

Original Poster
Rep: Reputation: 30
Thanks tealio, that did it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't format a second hdd Quads Linux - Newbie 13 09-27-2008 09:38 AM
Format a HDD georgiozoze Linux - Newbie 3 12-21-2006 04:05 AM
format hdd jorasmi Slackware 4 03-09-2005 05:25 AM
How to format & mount 2nd hdd after FedCor1 has been installed on 1st hdd? clay394 Fedora 1 05-18-2004 02:50 PM
Format HDD bytebrowser Linux - Hardware 1 07-02-2003 07:33 AM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration