LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2002, 04:35 AM   #1
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Rep: Reputation: 0
Angry How do i fix this?


I have a sound related issue. I have an IBM thinkpad 390E, 333mhz, 4.8 gig HD, 64 megs of RAM, and it is running RedHat 7.2. Everything is running great and autodected like my internet, etc.. but when I stick in a CD, or click on an MP3... it acts like it is playing, but I get no sound. I have tried to fool around with the sound settings in control panel with no luck. The Kernel I am using is KDE. Any suggestions? I would really like to get the sound to work! Thanks.

- gLITch
 
Old 08-07-2002, 05:20 AM   #2
JamesF1
Member
 
Registered: Nov 2001
Location: Spain
Distribution: Mandrake 9.1
Posts: 48

Rep: Reputation: 15
Have you tried sndcfg (or sndconfig - I can't remember which one is correct)?
 
Old 08-07-2002, 05:26 AM   #3
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
No i have not. I will try this. I am not sure if this is related to my problem.. but when I logon to KDE... I get this message.
"Sound server informational message:"

Error while initializing the sound driver:
device /dev/dsp can't be opened (Device or resource busy)

The sound server will continue, using the null output device.

??? hmmm..... any thoughts?

- gLITch
 
Old 08-07-2002, 05:26 AM   #4
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
Also i could not get sndconfig to work.... are you sure thats the right command?

Last edited by glitch; 08-07-2002 at 05:30 AM.
 
Old 08-07-2002, 05:52 AM   #5
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
KDE is your desktop environment,not your kernel.
To ID the kernel,type:
uname -r
lynch
 
Old 08-07-2002, 05:57 AM   #6
JamesF1
Member
 
Registered: Nov 2001
Location: Spain
Distribution: Mandrake 9.1
Posts: 48

Rep: Reputation: 15
Hmmm. Perhaps it's not autodetecting the soundcard. I'm not very familiar with Redhat's autodetection program. What type of soundcard is it?

(By the way the KDE isn't a kernel - it's just a xwindows manager).
 
Old 08-07-2002, 01:58 PM   #7
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
ok try this:
get to a console;
then type su
and type the password.
then type setup
if it doesnt findit then type whereis setup to find the correct path.
when the setup screen appears, it will give you a lot of options to configure your system, including sound.
 
Old 08-07-2002, 02:01 PM   #8
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Sound configuration is under
/sbin/sndconfig
 
Old 08-07-2002, 03:42 PM   #9
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
Yup, and the setup tool in RedHat uses the sndconfig if im not mistaken.
 
Old 08-07-2002, 04:33 PM   #10
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
And sndconfig must be run as the root user.

su -

<password>

sndconfig
 
Old 08-07-2002, 04:57 PM   #11
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
I found sndconfig, but am unable to open it. Even under root? Am i typing in the wrong command to open it? =/

Also just typing in "setup" in the shell did not open anything.
 
Old 08-07-2002, 05:32 PM   #12
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Go to a terminal and type su.When your prompted for a password,type in the root password and hit enter.
Then type /sbin/sndconfig
 
Old 08-08-2002, 04:42 AM   #13
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
I have run soundcng... and it detected my card.... then it proceeded to make a 'test" noise... to see if i hear it. I can't... and if i turn the volume up on my laptop... it makes a high pitch screetch sound. I know sound works, because... i just had Windows on here. I'm kind of lost now..... any other thoughts?
 
Old 08-08-2002, 05:29 AM   #14
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
You probably need to find the mixer to turn up the sound.Open a terminal and type kmix.you dont need to be root for that.
lynch
 
Old 08-08-2002, 05:33 AM   #15
glitch
LQ Newbie
 
Registered: Aug 2002
Location: Washington State, USA
Distribution: Red Hat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
I think I know what is wrong!!! but am not sure how to fix it! The sound card DOES work, but... at the same time.. apparently the mic. that is built into my laptop is on... so I am hearing the mic... and the sound at the same time. Which explains the high squeak sound i get when i turn the volume up (feedback). I figured this out when i put my headset on... and was able to hear the computer fan and myself typing. ;-) The question is........

Where is the mic settings in KDE and how can I turn it off?!! Any feedback greatly appreciated!

- gLITch
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
all attempts to fix the problem failed... can someone help me fix partition space? foreverdita Linux - Enterprise 2 05-11-2005 10:02 AM
reiserfsck --fix-fixable -> --fix-fixable ignored - why? BrianK Linux - Software 1 01-07-2005 09:45 PM
What does this fix? cuco76 Fedora 4 05-23-2004 03:15 PM
How can i fix this jester_69 Linux - Networking 1 09-11-2002 02:32 AM
is it possible or how do i fix this Jasper33 General 3 03-12-2001 07:32 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration