LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2009, 03:02 PM   #1
Ujjain
Member
 
Registered: Mar 2009
Posts: 33

Rep: Reputation: 15
How do I fix my dependencies in yum upgrade?


Code:
[root@server01 ~]# yum upgrade
Setting up Upgrade Process
Setting up repositories
epel                      100% |=========================| 2.1 kB    00:00
rpmforge                  100% |=========================| 1.1 kB    00:00
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nss_ldap.i386 0:253-5.el4_7.1 set to be updated
---> Package bind-libs.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package krb5-devel.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package libpng.i386 2:1.2.7-3.el4_7.2 set to be updated
---> Package kernel.i686 0:2.6.9-78.0.17.EL set to be installed
---> Package perl-Filter.i386 0:1.34-1.el5.rf set to be updated
---> Package syslinux.i386 0:3.75-1.el5.rf set to be updated
---> Package krb5-libs.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package audit.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package glibc.i686 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package audit-libs.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package lftp.i386 0:3.7.11-1.el5.rf set to be updated
---> Package kernel-smp.i686 0:2.6.9-78.0.17.EL set to be installed
---> Package proftpd.i386 0:1.3.2-1.el5.rf set to be updated
---> Package nscd.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package glibc-common.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package cadaver.i386 0:0.22.5-1.el5.rf set to be updated
---> Package glibc-devel.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package rsync.i386 0:3.0.5-1.el5.rf set to be updated
---> Package bind-utils.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package udev.i386 0:039-10.22.el4_7.1 set to be updated
---> Package bind.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package epel-release.noarch 0:5-3 set to be updated
---> Package krb5-workstation.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package mtr.i386 2:0.75-1.el5.rf set to be updated
---> Package glibc-headers.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package lha.i386 0:1.14i-19.2.2.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: lha
--> Processing Dependency: libssl.so.6 for package: cadaver
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: perl-Filter
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: proftpd
--> Processing Dependency: rtld(GNU_HASH) for package: rsync
--> Processing Dependency: perl(Compress::Zlib) for package: perl-Filter
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: lftp
--> Processing Dependency: libssl.so.6 for package: lftp
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mtr
--> Processing Dependency: rtld(GNU_HASH) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: syslinux
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: rsync
--> Processing Dependency: libssl.so.6 for package: proftpd
--> Processing Dependency: libreadline.so.5 for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: lftp
--> Processing Dependency: libcrypto.so.6 for package: lftp
--> Processing Dependency: perl(Digest::SHA1) for package: syslinux
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: proftpd
--> Processing Dependency: libreadline.so.5 for package: lftp
--> Processing Dependency: rtld(GNU_HASH) for package: proftpd
--> Processing Dependency: perl(String::CRC32) for package: lftp
--> Processing Dependency: perl(Crypt::PasswdMD5) for package: syslinux
--> Processing Dependency: libcrypto.so.6 for package: proftpd
--> Processing Dependency: libcrypto.so.6 for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: mtr
--> Processing Dependency: libneon.so.25 for package: cadaver
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Crypt-PasswdMD5.noarch 0:1.3-2.el5 set to be updated
---> Package perl-Digest-SHA1.i386 0:2.11-1.el5.rf set to be updated
---> Package perl-Compress-Zlib.i386 0:1.42-1.el5.rf set to be updated
---> Package perl-String-CRC32.i386 0:1.4-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: lha
--> Processing Dependency: libssl.so.6 for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: perl-Compress-Zlib
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: perl-Filter
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: proftpd
--> Processing Dependency: rtld(GNU_HASH) for package: rsync
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: lftp
--> Processing Dependency: libneon.so.25 for package: cadaver
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mtr
--> Processing Dependency: libcrypto.so.6 for package: lftp
--> Processing Dependency: rtld(GNU_HASH) for package: syslinux
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: rsync
--> Processing Dependency: libssl.so.6 for package: proftpd
--> Processing Dependency: libssl.so.6 for package: lftp
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Crypt-PasswdMD5
--> Processing Dependency: rtld(GNU_HASH) for package: lftp
--> Processing Dependency: rtld(GNU_HASH) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: perl-String-CRC32
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: perl-Compress-Zlib
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: proftpd
--> Processing Dependency: libreadline.so.5 for package: lftp
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: perl-String-CRC32
--> Processing Dependency: rtld(GNU_HASH) for package: perl-Digest-SHA1
--> Processing Dependency: rtld(GNU_HASH) for package: mtr
--> Processing Dependency: libcrypto.so.6 for package: proftpd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: perl-Digest-SHA1
--> Processing Dependency: libcrypto.so.6 for package: cadaver
--> Processing Dependency: libreadline.so.5 for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: proftpd
--> Finished Dependency Resolution
Error: Missing Dependency: rtld(GNU_HASH) is needed by package lha
Error: Missing Dependency: libssl.so.6 is needed by package cadaver
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-Filter
Error: Missing Dependency: libpam.so.0(LIBPAM_1.0) is needed by package proftpd
Error: Missing Dependency: rtld(GNU_HASH) is needed by package rsync
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package lftp
Error: Missing Dependency: libssl.so.6 is needed by package lftp
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package mtr
Error: Missing Dependency: rtld(GNU_HASH) is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package syslinux
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package rsync
Error: Missing Dependency: libssl.so.6 is needed by package proftpd
Error: Missing Dependency: libreadline.so.5 is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package lftp
Error: Missing Dependency: libcrypto.so.6 is needed by package lftp
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package proftpd
Error: Missing Dependency: libreadline.so.5 is needed by package lftp
Error: Missing Dependency: rtld(GNU_HASH) is needed by package proftpd
Error: Missing Dependency: libcrypto.so.6 is needed by package proftpd
Error: Missing Dependency: libcrypto.so.6 is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package mtr
Error: Missing Dependency: libneon.so.25 is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-Compress-Zlib
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-Crypt-PasswdMD5
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-String-CRC32
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package perl-Compress-Zlib
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package perl-String-CRC32
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-Digest-SHA1
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package perl-Digest-SHA1
You have new mail in /var/spool/mail/root
[root@server01 ~]# yum upgrade --exclude=*perl* --exclude=*ftp*
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nss_ldap.i386 0:253-5.el4_7.1 set to be updated
---> Package bind-libs.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package krb5-devel.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package libpng.i386 2:1.2.7-3.el4_7.2 set to be updated
---> Package kernel.i686 0:2.6.9-78.0.17.EL set to be installed
---> Package krb5-workstation.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package syslinux.i386 0:3.75-1.el5.rf set to be updated
---> Package krb5-libs.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package audit.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package glibc.i686 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package audit-libs.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package kernel-smp.i686 0:2.6.9-78.0.17.EL set to be installed
---> Package nscd.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package glibc-common.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package cadaver.i386 0:0.22.5-1.el5.rf set to be updated
---> Package glibc-devel.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package rsync.i386 0:3.0.5-1.el5.rf set to be updated
---> Package bind-utils.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package udev.i386 0:039-10.22.el4_7.1 set to be updated
---> Package bind.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package epel-release.noarch 0:5-3 set to be updated
---> Package mtr.i386 2:0.75-1.el5.rf set to be updated
---> Package glibc-headers.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package lha.i386 0:1.14i-19.2.2.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: lha
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mtr
--> Processing Dependency: rtld(GNU_HASH) for package: rsync
--> Processing Dependency: libssl.so.6 for package: cadaver
--> Processing Dependency: perl(Crypt::PasswdMD5) for package: syslinux
--> Processing Dependency: rtld(GNU_HASH) for package: mtr
--> Processing Dependency: perl(Digest::SHA1) for package: syslinux
--> Processing Dependency: libcrypto.so.6 for package: cadaver
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: cadaver
--> Processing Dependency: rtld(GNU_HASH) for package: syslinux
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: rsync
--> Processing Dependency: libneon.so.25 for package: cadaver
--> Processing Dependency: libreadline.so.5 for package: cadaver
--> Finished Dependency Resolution
Error: Missing Dependency: rtld(GNU_HASH) is needed by package lha
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package mtr
Error: Missing Dependency: rtld(GNU_HASH) is needed by package rsync
Error: Missing Dependency: libssl.so.6 is needed by package cadaver
Error: Missing Dependency: perl(Crypt::PasswdMD5) is needed by package syslinux
Error: Missing Dependency: rtld(GNU_HASH) is needed by package mtr
Error: Missing Dependency: perl(Digest::SHA1) is needed by package syslinux
Error: Missing Dependency: libcrypto.so.6 is needed by package cadaver
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package cadaver
Error: Missing Dependency: rtld(GNU_HASH) is needed by package syslinux
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package rsync
Error: Missing Dependency: libneon.so.25 is needed by package cadaver
Error: Missing Dependency: libreadline.so.5 is needed by package cadaver
You have new mail in /var/spool/mail/root
As you can see excluding "yum upgrade --exclude=*perl* --exclude=*ftp*" did not help very much.
 
Old 04-24-2009, 03:14 PM   #2
kentyler
Member
 
Registered: Dec 2008
Location: Cleveland Ohio
Distribution: CentOS
Posts: 235

Rep: Reputation: 36
Try to update the software that has issues one package at a time then do a global update, there are only a few troubled packages there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum not able to to completely upgrade the system, how to fix ? harry2006 Linux - Software 4 10-17-2008 06:58 AM
Dependencies and YUM n9066r Linux - Newbie 4 12-17-2007 11:51 PM
reinstall to fix dependencies? ekdya Debian 1 10-17-2005 09:50 AM
how do fix dependencies? Alexander.s Linux - General 3 04-20-2005 05:29 PM
apt doesn't fix all dependencies :(? darkleaf Debian 4 07-25-2004 05:08 AM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration