LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-20-2011, 06:28 AM   #1
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
how do i fix grub2


Hello guys, recently installed debian, however the resolution wasn't correct. I attempted to repair this after some googleing, which involved editing grub. I tried and in the process i set the timeout to 1. Stupid me, now it won't boot, and i can't even access grub2 because it times out. I tried holding my finger on down but it didn't work. What do you guys suggest, i can access the the partition from a live cd, but how would i go about fixing the issue?
 
Old 08-20-2011, 08:18 AM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,166

Rep: Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342
Even if you have the timeout set to 1, it should boot the default entry unless you changed that too.
Take a look at the Ubuntu site for Grub2 documentation, Section 8 to make that change at command line during boot:

https://help.ubuntu.com/community/Grub2#Command Line and Rescue Mode

Holding down the shift key or repeatedly hitting the Esc key should get a menu. See link above for more info.

If that doesn't work, post back and someone will explain how to access form Live CD.
 
Old 08-20-2011, 07:06 PM   #3
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Original Poster
Rep: Reputation: 166Reputation: 166
yeah it boots the default entry, debian, but debian isn't booting because of the resolution fix i put into grub which obviously isn't working. If the bootloader is installed on /, can i update-grub on that partition, from another partition or live cd? or if that's not possible, can i edit the grub.cfg file to change the timeout. The first option is ideal, as i can simply delete the lines i placed, however, if that's not possible, i was thinking the second option, so maybe i can access single user mode, so then perhaps i can go in through the command line to edit the /etc/default/grub
 
Old 08-20-2011, 07:15 PM   #4
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Original Poster
Rep: Reputation: 166Reputation: 166
look guys i know it's probably not the best solution, but since it was a new installation anyways, i'm just going to reinstall. thanks anyways
 
Old 08-20-2011, 10:29 PM   #5
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,166

Rep: Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342Reputation: 1342
Section 12 of the link I posted above explains how to reinstall Grub from the CD. Quite a bit simpler than reinstalling the system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GRUB2 after a minor update of GRUB2 /boot prefix no longer needed?? wikapuki Linux - Software 1 10-24-2010 02:39 PM
grub2 psmurthy Linux - Newbie 2 03-16-2010 11:20 AM
grub2 mbvo Slackware 7 11-12-2009 06:06 AM
FIX---Fedora install hangs---To fix this---- jmckinzie Fedora - Installation 0 12-20-2005 12:08 AM
all attempts to fix the problem failed... can someone help me fix partition space? foreverdita Linux - Enterprise 2 05-11-2005 09:02 AM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration