LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-12-2004, 07:40 PM   #1
BliZZrdLiZZrd
LQ Newbie
 
Registered: Mar 2004
Location: Riverside
Distribution: Debian Woody 3.0r2
Posts: 1

Rep: Reputation: 0
Exclamation How do I exit Gnome desktop manager?


"I am new to linux. I recently installed Debian 3.0r2 woody on to my existing computer and was doing fine until, I restarted the system. after rebooting I select linux from the Lilo manager and instead of going to the command line login I get popped into the Gnome Desktop Manager I have spoken with several people about how I might be able to exit but nothing has been successful. I do not want this as it will not allow me to log in as root, and I have not found any way to just exit and get back to command line."
 
Old 03-12-2004, 07:45 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
so are you saying you just want your machine to boot up to text mode by default ?
that is what i gather by what your saying ....
if that is the case, then all you have to do is edit the /etc/inittab file
you will change the line that reads :
id:5:initdefault:
to read :
id:3:initdefault:

5 = graphical bootup
3 = command line bootup
 
Old 03-12-2004, 07:46 PM   #3
DaddyBad
Member
 
Registered: Jan 2004
Location: New Haven
Distribution: rh9, fc2
Posts: 35

Rep: Reputation: 15
It sounds like you're in runlevel 5. You'll have to edit /etc/inittab and set
your run level to 3. I'm using redhat 9. This is what I had to do...

find this line in /etc/inittab, only it will say 5 instead of 3. Change it to 3
and reboot.

id:3:initdefault:

You may also have to use chkconfig to get some of your services set up
and running in runlevel 3. the man pages will tell you how.

scott
 
Old 03-12-2004, 07:47 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
Re: How do I exit Gnome desktop manager?

Quote:
Originally posted by BliZZrdLiZZrd
I have spoken with several people about how I might be able to exit but nothing has been successful.
well, what did you try already? that would be helpful to know so people don't waste their time recommending the same things.

one thing you can try if you haven't already is editing the runlevel in your /etc/inittab file. usually i think it should be 3 to boot to prompt, but in my debian system, i had to change it to runlevel 2. you might try both if one doesn't work.

afaik, and the last time i used it, i also seem to remember that the gnome display manager has an option to exit to the command prompt. ? i'm pretty sure it has that, so check it out again carefully.
 
Old 03-13-2004, 08:30 AM   #5
ScottSmith
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian - Sid
Posts: 23

Rep: Reputation: 1
If you want to be able to login as root from gdm, you will need configure gdm. At the login screen, click on 'System' then click 'Configure' and enter roots password. Click the tab title 'Security' then check 'Allow root to login with GDM'. Root will now be able to login.

If you want to start at the command line after a reboot, you will need to remove the S99gdm link from /etc/rc2.d. That will stop gdm from starting after a reboot. If at a later time you want to start gdm again, you can issue /etc/init.d/gdm start from the command line. Don't forget you call also do CTRL-ALT-F[1-6] to get to a console, and CTRL-ALT-F7 to get back to your gnome session.

Scott
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie: no shutdown or root login in gnome desktop manager mhelal Linux - Newbie 3 03-21-2005 08:29 AM
Gnome Desktop Manager logon problem l_pinter Linux - Newbie 5 01-12-2004 04:39 PM
Graphical file manager for non KDE/Gnome desktop Hex29A Linux - Software 8 01-05-2004 11:28 AM
setting gnome as desktop manager dzt Slackware 2 10-28-2003 12:17 AM
How to exit Window Manager keirobyn Linux - Software 4 01-16-2002 10:03 PM


All times are GMT -5. The time now is 05:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration