LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2003, 07:44 PM   #1
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Rep: Reputation: 15
Question How do I edit /etc/modules.conf file?


I just got my lucent winmodem to work with Mandrake 9.2 but i can't get the modem to be detected when i boot up. i can get it to work through the console but would like to be able to just use kppp to dial out and connect. i was told that adding a command to the /etc/modules.conf file would load the module for my modem at start up but i get a

"The file could not be saved. Please check if you have write permission."

error every time i try. how do i set permissions for this?
also, is modprobe lt_serial the command i would want to put in there and is so would i just enter it as is?

any input would be greatly appreciated!
 
Old 11-11-2003, 07:45 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
sorry reread this and it seemed short. were you root when you tried editing it?
you'll have to edit it as root.

Last edited by Peacedog; 11-11-2003 at 07:48 PM.
 
Old 11-11-2003, 07:50 PM   #3
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
i know how to log on as root in the console but havn't not found anyway to log on as root in the konqueror browser (which is how i'm accessing the file). do i have to access the file through the console then to edit it and if so how would i do that?
 
Old 11-11-2003, 08:08 PM   #4
leukozyt
LQ Newbie
 
Registered: Nov 2003
Distribution: Debian 3.0
Posts: 15

Rep: Reputation: 0
Hi


1.
open console

2.
log in as root
Code:
$ su
3.
edit modules.conf
i use for this editor ( you can use any else)
Code:
$ editor /etc/modules.conf

may the source be with you !

MfG
Loukzyt

Last edited by leukozyt; 11-11-2003 at 08:10 PM.
 
Old 11-11-2003, 08:11 PM   #5
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
thanks for the info! i'll give it a try after dinner.....me poor brains need a rest for now.
 
Old 11-11-2003, 08:17 PM   #6
leukozyt
LQ Newbie
 
Registered: Nov 2003
Distribution: Debian 3.0
Posts: 15

Rep: Reputation: 0
dinner !?!
at germany we have now 2:20 am
i have to go sleep, bye

Last edited by leukozyt; 11-11-2003 at 08:19 PM.
 
Old 11-11-2003, 08:19 PM   #7
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
thx leukozyt, i had the same problem a few months ago and have been trying to find the thread that helped me. so i could help GrapeApe. my linux box is down right now for some upgrade and i couldn't log into to it to get the info. thx again.
 
Old 11-11-2003, 08:22 PM   #8
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
thanks to both of ya....i've been bangin' my head against the wall all day!
 
Old 11-11-2003, 08:26 PM   #9
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
i found it

K
Configuration
KDE Control Centre
System
Login Manager
Aministrator mode butoon - type root password
Users tab
Uncheck the cross next to Root user, in "hidden users"
appy

Log out
Log in

youll see an icon for root.

taken from

http://www.linuxquestions.org/questi...ing+in+as+root

root is hidden(for good reason) from the kde login. you'll also see a message if you login to the user interface about the seriousness of this action.
good luck.
 
Old 11-12-2003, 02:16 AM   #10
GrapeApe
Member
 
Registered: Nov 2003
Distribution: Mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
thanks peacedog...i was able to get in through the console but i imagine that will come in handy in the future....i still havn't solved my original problem but at least i learned something new.

Last edited by GrapeApe; 11-12-2003 at 02:23 AM.
 
Old 11-13-2003, 08:54 PM   #11
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
Quote:
Originally posted by leukozyt
dinner !?!
at germany we have now 2:20 am
i have to go sleep, bye
nur in Deustchland....
...verrückt Deustchen...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
edit a .conf file master Linux - General 7 10-13-2005 06:49 PM
/etc/modules.conf can not edit aus9 Mandriva 1 12-06-2004 07:14 AM
How to edit /etc/modules.conf file? Mateo1041 Linux - Newbie 4 11-19-2004 01:18 PM
How to edit grub.conf file? hnash53 Linux - Software 1 12-12-2003 01:33 AM
Edit modules.conf for sound, RH 8.0 gurre Linux - Hardware 4 12-29-2002 07:09 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration