LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-27-2008, 10:02 PM   #1
msuffern
LQ Newbie
 
Registered: Aug 2008
Location: Winston-Salem, NC
Posts: 14

Rep: Reputation: 0
How do I disable touchpad tap in Fedora 10?


This is my first experience with Linux. I installed Fedora 10 last night and am very pleased with the OS, except I cannot find settings for the laptop's touchpad. It's an IBM/Lenovo T41. Any ideas/leads? Thanks!
 
Old 11-27-2008, 10:20 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Take a look at TouchFreeze.

TouchFreeze 0.1 [LWN.net]
http://lwn.net/Articles/240454/
 
Old 11-27-2008, 10:44 PM   #3
msuffern
LQ Newbie
 
Registered: Aug 2008
Location: Winston-Salem, NC
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for the link. That looks like what I need (except that I don't want touchpad input disabled only while typing, but the "tap" functionality disabled all the time), but I don't know what to do with the file folder once downloaded? I'm an extreme newbie but learning all I can about this OS. Thanks again!
 
Old 11-28-2008, 11:54 AM   #4
kamauo
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
Greetings Sisters and Brothers;

I am running fedora 10 on Dell Studio 1735 and would love to disable the touchpad. I tried all the tricks with ksynaptics and xorg.conf but no luck. I even crashed the system trying.

Fedora does not seem to be compatible with xorg.conf.

Is there a way to get rid of this touchpad. If I could I would take it out of the laptop and throw it away.

Your kind help is greatly appreciated.

One Love, Kamau

railswarrior@gmail.com
 
Old 11-28-2008, 12:28 PM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
My touchpad uses the synaptics driver.
This is the relevant bit in my /etc/X11/xorg.conf
Code:
Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
    Option         "MaxTapTime" "0"
EndSection
The red lines have disabled horizontal scrolling and tap-to-click.

So edit your xorg.conf (as root, or you cannot save the changes and make a backup first!) and add Option "MaxTapTime" "0"

You need to restart X for the change to happen (Just logout, then back in to do this)
 
Old 12-07-2008, 04:59 PM   #6
kamauo
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
disable touchpad dell 1735 fedora 10

Quote:
Originally Posted by tredegar View Post
My touchpad uses the synaptics driver.
This is the relevant bit in my /etc/X11/xorg.conf
Code:
Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
    Option         "MaxTapTime" "0"
EndSection
The red lines have disabled horizontal scrolling and tap-to-click.

So edit your xorg.conf (as root, or you cannot save the changes and make a backup first!) and add Option "MaxTapTime" "0"

You need to restart X for the change to happen (Just logout, then back in to do this)

Unfortunately this did not work because even when I completely disable SELinux to computer hangs just before the login screen and stayed there all night.

Is there any one who knows how to get rid of this touchpad? It is so obnoxiously annoying that I have to tape a cd over it so that it is out of my way.

Your kind help and cooperation is greatly appreciated.

One Love, Kamau
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux 2.6 touchpad double-tap-and-hold etc a.malich Linux - Laptop and Netbook 1 01-06-2007 09:47 PM
laptop touchpad - how to disable 'tap to click'?? Adrian Baker Linux - Laptop and Netbook 2 01-17-2006 06:15 PM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 09:57 PM
Make touchpad tap register as click drigz Linux - Software 8 10-15-2004 01:22 PM
Tap not working in touchpad in fedora core 2 peevee Linux - Laptop and Netbook 8 10-10-2004 08:44 AM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration