LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how do i change the graphical res. from command line? (http://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-change-the-graphical-res-from-command-line-129176/)

justin9 12-26-2003 11:05 PM

how do i change the graphical res. from command line?
 
I am having a problem with RedHat 9 and my monitor. I was running redhat and I decided to lower my resolution because it was just a little hard to see, so I lowered it from 1280 x 1024 to 1027 x 768 i believe, and then i logged out to try the new resolution. then I got the crazy garbled screen that you get when you set your resolution too high.
So now im really stuck, and I dont know how i can change the res without being in graphical mode. thanks for your time!

wapcaplet 12-26-2003 11:37 PM

The resolutions used by X are defined in /etc/X11/XF86Config-4. As root, open that file in a text editor (like vi, nano, jed). Towards the bottom is a section showing lists of different resolutions; remove the ones that are causing problems.

whansard 12-27-2003 03:26 AM

you should be able to get out to a text screen by hitting
control-alt-f2

nexx_au 12-27-2003 08:10 AM

Here's a tip:

When in graphical mode, you can change your resolution 'on the fly' by pressing Ctrl & Alt & Numpad + / -

Otherwise you can edit your XF86Config file as mentioned in the first reply.

justin9 12-27-2003 11:46 AM

Thanks for your help everyone. I got it to work by changing the XF86Config file, but ill keep in mind the on the fly resolution changing.

davidas 03-27-2004 02:59 AM

What should I edit to have Enlightenment start up in my preferred resolution? (eg. 1024x768) ?

Thanks !

XF86Config(Screen section) as follows :


Section "Screen"

# Don't specify DefaultColorDepth unless you know what you're
# doing. It will override the driver's preferences which can
# cause the X server not to run if the host doesn't support the
# depth.
Identifier "Screen 1"
Device "VMware SVGA"
Monitor "vmware"
DefaultDepth 24
SubSection "Display"

# VGA mode: better left untouched
Depth 4
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

whansard 03-27-2004 04:16 AM

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

to

Modes "1024x768" "1280x1024" "1280x960" "1152x864" "800x600" "640x480"

i think.

you may have to do

Modes "1024x768" "800x600" "640x480"

but i doubt it.


All times are GMT -5. The time now is 04:30 AM.