LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-19-2006, 03:51 PM   #1
TaaDow
LQ Newbie
 
Registered: Aug 2004
Posts: 24

Rep: Reputation: 15
how do i boot into init 3 instead of init 5?


I need to boot into text mode (to access the terminal)
i messed up my xorg.conf and X won't load properly and just hangs but i have my xorg.conf backed up and can just replace the bad one if i could find a way into the terminal....how do i do this?
 
Old 01-19-2006, 03:56 PM   #2
damicatz
Member
 
Registered: May 2004
Distribution: FreeBSD 7, Debian "Squeeze", OpenBSD 4.5
Posts: 167

Rep: Reputation: 30
It depends on a number of factors such as what distribution of Linux you are using. Most distros have a file in /etc called inittab that contains the default run level. However, since you are not able to boot, you are probably looking for a solution that can be used at boot time.

What boot loader are you using? LILO or GRUB?
 
Old 01-19-2006, 03:57 PM   #3
TaaDow
LQ Newbie
 
Registered: Aug 2004
Posts: 24

Original Poster
Rep: Reputation: 15
I'm using SuSE 10.0/GRUB
 
Old 01-19-2006, 04:00 PM   #4
chemichael
Member
 
Registered: Aug 2005
Location: Tucson, Arizona
Distribution: PCLinuxOS
Posts: 128

Rep: Reputation: 15
Can you just let it hang and do crtl-alt-f2 or f6 just to get to a virtual terminal and login as root then cd to your Xorg.conf Dir and edit the file using a editor like joe or something?
Or if you made a back up file (which is the default of most editors) you can just do the Virtual terminal thing and delete the new Xorg.conf file you made.
"rm -d xorg.conf"
Hope that helped alittle
 
Old 01-19-2006, 04:01 PM   #5
damicatz
Member
 
Registered: May 2004
Distribution: FreeBSD 7, Debian "Squeeze", OpenBSD 4.5
Posts: 167

Rep: Reputation: 30
When you boot into grub, select whatever option you use normally to boot. Instead of pressing enter, press e. Find the line that contains the name of your kernel, it should say kernel and then a path and press e again. Insert the word single after root=/dev/whatever and press enter. Then push b to boot. This will boot your installation in what is known as single user mode, with no GUI.

You may have a password on your bootloader. I am not familar with how SuSE works in terms of it's boot loader setup. If this is the case, I believe you will have to press p and enter your password before you can follow the above instructions.
 
Old 01-19-2006, 06:13 PM   #6
wpn146
Member
 
Registered: Jan 2005
Distribution: Solaris, Linux Fedora Core 6
Posts: 170

Rep: Reputation: 30
Quote:
Originally Posted by damicatz
When you boot into grub, select whatever option you use normally to boot. Instead of pressing enter, press e. Find the line that contains the name of your kernel, it should say kernel and then a path and press e again. Insert the word single after root=/dev/whatever and press enter. Then push b to boot. This will boot your installation in what is known as single user mode, with no GUI.

You may have a password on your bootloader. I am not familar with how SuSE works in terms of it's boot loader setup. If this is the case, I believe you will have to press p and enter your password before you can follow the above instructions.
If you find yourself needing single user mode a lot, I believe you can add a new stanza to your boot.conf file with your "single" (my FC4 accepts a "1" here) already edited into the line. Then to go single user, just select it from the menu.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic No init found. Try passing init..... Adrian Baker Mandriva 2 02-28-2005 12:47 PM
Redhat linux9.0:System hangs,if gives init 3 or init 4 Sailaja Reddy Linux - Newbie 4 09-16-2004 04:19 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-19-2004 12:10 AM
error: No init found. Try passing the init= option to the Kernel neylitalo Linux - Laptop and Netbook 3 01-22-2004 10:34 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 11:18 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration