LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2014, 08:06 AM   #1
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Rep: Reputation: Disabled
Unhappy How come my network-card is recognized, but there is no connection to my network?


I am new to linux and have recently installed OpenSuse 13.1. I could not install Ubuntu or LinuxMint 16, so OpenSuse was my only alternative (still don't know why). I am using an old server of my former company (AMD-Athlon 64 3000+, 1,5 GBMemory, 2X150GB HD). It has a Tyan motherboard, with built-in network-connnection. I have an PCI-card Broadcom netxtreme bcm5721 gigabit ethernet pci express and recently bought a USD Ethernet-Adaptor. When i connect the USB-adapter, it works, but when i put the cable in the PCI-card or the onboard network-connection there is no connection, allthough they are recognized and "up". As i said i a m a newbee, but can anyone help me?

Last edited by Cupido28; 02-20-2014 at 08:08 AM. Reason: addition
 
Old 02-20-2014, 08:47 AM   #2
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Identify the chips...

First use the command "lspci" as "su" to verify what chips are used in the two connection devices(eithernet controller), then use the internet to search for more about how or if they are supported in linux. Broadcom has a linux driver for theirs. Otherwise, scrounge a used pci internet card from some discarded PC tower and try again.

http://www.broadcom.com/support/ethe...eme_server.php

ftp://ftp.supermicro.com/CDR-APLUS_1...ux.htm#install

If you don't have to pay lots of money for it, more RAM might help with your linux experience. The RAM that is installed is probably ECC, but try to find the documentation for the motherboard to see if it will take non-EEC. Lack of RAM was probably the reason you couldn’t install Ubuntu or Mint. If 13.1 is slow with the existing RAM, you can install it again with a light weight desktop.

http://l3net.wordpress.com/2013/12/1...opensuse-13-1/

Last edited by thorkelljarl; 02-20-2014 at 09:33 AM.
 
Old 02-20-2014, 09:59 AM   #3
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Revised advice...

The firmware for the Broadcom chip should be in your linux kernel. Try to load it with the terminal command "modprobe". Try(as "su")

modprobe -r tg3
modprobe -r broadcom
modprobe broadcom
modprobe tg3

Then use the command "lsmod" to see if the module is loaded.

Last edited by thorkelljarl; 02-20-2014 at 10:01 AM.
 
Old 02-20-2014, 10:12 AM   #4
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by thorkelljarl View Post
Revised advice...

The firmware for the Broadcom chip should be in your linux kernel. Try to load it with the terminal command "modprobe". Try(as "su")

modprobe -r tg3
modprobe -r broadcom
modprobe broadcom
modprobe tg3

Then use the command "lsmod" to see if the module is loaded.
Dear Thorkelljarl,

Thank you for both replies. I have tried the modprob-advice. When i do lsmod, all i get is the reply "usage lsmod", also when i try to do lsmod tg3. I am probably doing something wrong, but since i am a newbie, i have no idea.

I have no access to internet from the linux PC. This is due to the fact that even when i use the working network-adapter and choose Firefox, it throws me out back to the login-screen (also to do with RAM??) Which command should i use for downloading the drive from an url?

Thanks
 
Old 02-20-2014, 10:21 AM   #5
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
added reply

When i use the command lspci, it recognizes the pci-card, and it is running. but when i put a cable in, it still says "not connected". The cable is not the problem, because that works with another networkadaptor.

Maybe this is helpfull information??
 
Old 02-20-2014, 10:54 AM   #6
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
You are about to learn a little linux...

As I found on the Internet, you shouldn’t have to deal with downloading the driver.

Try the command "lsmod" in a terminal again and look for the mention of broadcom or tg3 on the resulting list. If you have loaded the module correctly, it should be there. That within quotation marks is what you are to type, nothing else. Post back with what you find.

Even with the driver for the pci card installed, you may have to do more work to establish a connection.

If you get frustrated, you can try installing Mint Xfce with the hope that Mint will do all of this automatically.

Last edited by thorkelljarl; 02-20-2014 at 11:55 AM.
 
Old 02-20-2014, 11:52 AM   #7
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Tutor...

http://linux.101hacks.com/unix/lsmod/
 
Old 02-20-2014, 02:56 PM   #8
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
follwing advice

I have done as you have told me. This time i used the terminal-shell within KDE and this time i got a different reply.

What i then did was the modprobe sequence again for broadcom (tg3 was listed).

After that i did "lsmod" and below is the result:

module: tg3
Size: 164363
used by: 0

for modprobe broadcom the result is:

Fatal: error inserting broadcom (/lib/modules/3.11.10-7-desktop/kernel/drivers/net/phy/broadcom.ko): operation not permitted

I assumed operation not permitted was due to permissions, so i tried again as root (trying to learn), and now after lsmod the result was:

Module: broadcom
Size: 13002
used by: 0

I also can see from the list (too long to post), the following:

Module: libphy
used by :tg3,broadcom
Module: ptp
use by: tg3
module: ppscore
used by: ptp
 
Old 02-20-2014, 04:52 PM   #9
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Looks good...

You can now try to configure the connection by opening YaST and going to Network settings. You will either find under Global Options that you are using NetworkManager or ifup. If the first, configure the connection by opening the Overview tab, selecting the Broadcom device and adding it. If using NetworkManager, there should be an applet present on the desktop panel(lower right of screen), and clicking it will bring up links to add the Broadcom card.

The commands are shell commands. There are are several varieties of shells, and yours would be the bash shell, opened in a terminal. The KDE terminal is Konsole, and root privileges are available as "su" with your root password.

http://linuxcommand.org/lc3_learning_the_shell.php
 
Old 02-20-2014, 05:38 PM   #10
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
We are getting there

Yes, after changing the method to Networkmanager (it was on ifup), i can find 3 connections. So allready a big improvement. thanks.

However all 3 connections i can see, all indicate no cable connected. (And it is in and cable was working on other network-adapter (USB))

What is the next step?

Some IP-mistake?
 
Old 02-20-2014, 05:58 PM   #11
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Did you right click...

You have to enable the wired connection and add the device that is to connect. There should be an edit or add option when you open the menu in the NetworkManager applet. Poke around, you might be almost there.

If you have trouble with the applet, use ifup. NetworkManager is mostly useful when moving from one internet connection to another on the fly, as in the case of a laptop.
 
Old 02-20-2014, 06:12 PM   #12
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,787

Rep: Reputation: 211Reputation: 211Reputation: 211
Almost there...

You need to enable a wired connection and then tell NetworkManager what and when to connect. Look at Network Settings under Configure Desktop after opening the Kicker applications menu. It should also be possible using the applet, but I don't use the KDE applet so can't describe the user interface(GUI). There is documentation.

http://activedoc.opensuse.org/book/o...networkmanager

This is the whole guide and very useful at that.

http://activedoc.opensuse.org/book/opensuse-reference


By the way, do you know what kind of connection you should made? DHCP-?

http://en.wikipedia.org/wiki/Dynamic...ation_Protocol

Last edited by thorkelljarl; 02-20-2014 at 06:37 PM.
 
Old 02-22-2014, 08:20 AM   #13
Cupido28
LQ Newbie
 
Registered: Feb 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
Cool working!!

Thank you torkelljar it is working!!

I wanted to start your other advice today, started up my computer and apparently that was enough, because i have the network connection. So again, thank you!

I have however a question to learn what i have been doing. Modprobe is that a command to see which modules are running? What is a module in Linux?

I now have the problem, that when i use Firefox, it starts but then immediately i have to log in again. So i was thinking that maybe there is a problem with the system-requirements and by using modprob i can see which modules (whatever that is) are running which are necessary for firefox. The same thing happens when i use Konqueror and i choose a site produced by the search-engine. Any idea?

Cupido28
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 6 64Bit - Network Problem - Network Card Not Recognized? red.hive Linux - Networking 7 10-20-2012 04:23 PM
No network connection; network card recognized only as eth1 Squall90 Slackware 2 05-22-2010 07:33 AM
network card not recognized cnanu SUSE / openSUSE 10 09-04-2008 01:09 AM
Not recognized network connection danizobin Linux - Networking 3 05-09-2006 12:25 PM
Network card not recognized niac Linux - Networking 7 10-24-2002 08:16 AM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration