LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-27-2010, 03:57 PM   #1
UNIXSOLDIER187
LQ Newbie
 
Registered: Dec 2010
Posts: 18

Rep: Reputation: 0
How come i can't get sound thru hdmi only audio jack?




I have a 1080p video card installed via PCIe and can't seem to get sound to work on my big screen tv unless i use a audio jack and stereo.
 
Old 12-27-2010, 05:42 PM   #2
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 3,912

Rep: Reputation: 599Reputation: 599Reputation: 599Reputation: 599Reputation: 599Reputation: 599
similar to this:
linuxquestions.org/questions/linux-hardware-18/unable-to-play-hdmi-sound-thru-speakers-851464/

please post the output of lspci and aplay -l .

try doing an alsamixer and unmute all the spdif's.

Last edited by schneidz; 12-28-2010 at 10:45 AM.
 
Old 12-27-2010, 10:28 PM   #3
UNIXSOLDIER187
LQ Newbie
 
Registered: Dec 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Talking

ok I am a MCP but how do you shut that off in Linux? TERMINAL?

IF SO COULD YOU GUIDE ME THRU IT PLEASE

Last edited by Tinkster; 12-28-2010 at 11:06 AM. Reason: swearing removed
 
Old 12-27-2010, 10:37 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,504
Blog Entries: 2

Rep: Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018
Open a terminal (you will find it under Acessories in your Mint Menus, I think) and type the commands
Code:
lspci
and
Code:
aplay -l
each followed by the Enter-key into it. Then post the output of the commands here, at best between code-tags.
Does your sound work in Windows?
And do you use the proprietary or the open source drivers in Linux?

By the way, no need to shout.

Last edited by TobiSGD; 12-27-2010 at 10:39 PM.
 
Old 12-27-2010, 10:57 PM   #5
UNIXSOLDIER187
LQ Newbie
 
Registered: Dec 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Thumbs up

_______________________________________
( You'll wish that you had done some of )
( the hard things when they were easier )
( to do. )
---------------------------------------
o
o \_\_ _/_/
o \__/
(oo)\_______
(__)\ )\/\
||----w |
|| ||
jake@LCCR ~ $ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]
01:00.1 Audio device: ATI Technologies Inc RV710/730
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
jake@LCCR ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
jake@LCCR ~ $
 
Old 12-27-2010, 11:01 PM   #6
UNIXSOLDIER187
LQ Newbie
 
Registered: Dec 2010
Posts: 18

Original Poster
Rep: Reputation: 0
how do i download different drivers other than the ones for linux? my asus video card drivers won't run in linux should i try whine lmao???????????
 
Old 12-27-2010, 11:31 PM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,504
Blog Entries: 2

Rep: Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018
No, you should run Linux driver, either the ones that come by default or the ones you get using your driver manager.
 
Old 12-28-2010, 10:49 AM   #8
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 3,912

Rep: Reputation: 599Reputation: 599Reputation: 599Reputation: 599Reputation: 599Reputation: 599
i edited my post above. can you please run alsamixer and unmute the spdif's.
also (if you are using gnome) try playing around with the sound preferences by rite-clik'ing the speaker icon ?
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI audio not working maheshsub00 Ubuntu 1 02-10-2010 03:43 PM
HDMI Audio with 12.2 Woodsman Slackware 27 09-04-2009 10:53 PM
Audio through HDMI Cable? Jeff91 Linux - Hardware 7 06-26-2009 09:44 AM
No sound through Headphone jack, Intel audio (ALC663). blmaros Linux - Laptop and Netbook 1 06-10-2009 08:01 PM
Low sound from speakers/ No sound from headphone jack with Intel ICH8 Family Audio troydclayton Linux - Hardware 2 03-28-2008 10:18 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration