LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2004, 11:05 PM   #1
jroussel
LQ Newbie
 
Registered: Mar 2004
Location: South Texas
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
Question How can I use foreign languages on Gentoo?


I am new to Linux, and some of my friends at work recently introduced me to Gentoo. I really like it, but I am faced with a small problem that none of my friends have had any experience with.

I am an American man who communicates in the English Language. My wife, on the other hand, is Korean and she communicates primarily in the Korean Language.

I need to be able to configure Gentoo (Gnome) in such a way that when I log on everything is in English, and when my wife logs on most everything is in English but she needs to be able to go to web sites and read Korean language. She also needs to be able to toggle between keyboard input methods of both English and Korean characters.

Could someone please help me? I have already added "cjk" to the USE flags in make.conf. Beyond that, I'm not really sure what modules to emerge and what other config files to edit.

Thank you very much!
 
Old 03-28-2004, 03:07 AM   #2
profjohn
Member
 
Registered: Mar 2004
Location: Jinhua, People's Republic of China
Distribution: MDK, RH, KNPX
Posts: 161

Rep: Reputation: 30
Cool

Glad to tell you that this will be no problem at all for you to do. Gnome supports Korean. Just set your wife up with her own login and username, specifying Korean as the default langauge. Open Office supports Korean, too, so you can setup Oo.org for her to use, too.
 
Old 03-30-2004, 09:49 PM   #3
jroussel
LQ Newbie
 
Registered: Mar 2004
Location: South Texas
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
Sure,

There has got to be something more than just that, because that didn't seem to solve the problem.

Does anyone else have an idea?

thanks
 
Old 03-31-2004, 12:36 AM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
What about checking here ???

regards

John
 
Old 04-01-2004, 03:57 PM   #5
jroussel
LQ Newbie
 
Registered: Mar 2004
Location: South Texas
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
Gee, thanks, bigjohn...

I would have never thought of looking at the Gentoo web site.

I am getting the feeling that no one really knows anything in this forum. Any idiot can point someone to the Gentoo web site, but do you really know how to do what I asked above?
 
Old 04-04-2004, 10:06 AM   #6
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
I can probably work it out, but as you feel that sarcasm is the best reply, to what is often an overlooked resource, sorry, in this case I don't feel inclined too.

Try google!

regards

John
 
Old 04-04-2004, 09:21 PM   #7
jroussel
LQ Newbie
 
Registered: Mar 2004
Location: South Texas
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
I'm sorry if I offended you, but I thought you were being sarcastic by pointing me to the Gentoo web site.

I'm sorry for the misunderstanding.

If you can help me out, I would really appreciate it.

thanks
 
Old 04-04-2004, 10:56 PM   #8
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try setting the language variables (LANG, LC_ALL) to ko_KR through bash_profile, you'll need a non unicode Korean font.
As for the input method you should be able to find something in /usr/portage/app-i18n
 
Old 04-05-2004, 04:26 PM   #9
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
jroussel,

When posting here, I make a point of not being sarcastic. It's hard enough to follow the "context" of a typed/printed reply, even if my punctuation was perfect (it isn't), it's still virtually impossible to convey.

Of course, I should also apologise for my curt reply.


So to your problem, I can't boot my gentoo install at the moment - I managed to screw it up when I started meddling with mandrake 10 community.

Now having looked at available packages under mandrake to try and get some info there seem to be lots, though these are "mandrakised rpm's" so not much use for a gentoo system.

I had a look in the gentoo forum's and at a glance found this thread which relate's to Japanese, but mentions some stuff, and link's that could point you in the right direction. And there's this one as well.

I've got an idea that you would have to work out how to get the korean language support for the system, and probably for specific applications as well. I notice that there's Korean support for open office listed amongst the OOo lang options.

There's also this link but you would have to get your wife to translate it. There was a couple of other links at the linux documentation project (I searched language+Korean), but like the first one, they're written in Korean.

Not knowing whether there would be any other names that might describe Korean language font's etc mean's that that's about all I can suggest from here, it's easy for us "occidental's" to just lump all the oriental languages together, but that's not always helpful to the speakers of the various tongues.

If you check out the links and see if they seem to be telling you what you need to know.

We may be able to work out something from there.

regards

John
 
Old 05-10-2004, 01:05 PM   #10
chykim
LQ Newbie
 
Registered: May 2004
Location: Belgium
Distribution: gentoo
Posts: 1

Rep: Reputation: 0
Hi jroussel,
Have you solved your problem?
Displaying korean in your linux box is not difficult.
All you have to do is to download korean fonts and to edit XF86Config.
Say, emerge baekmuk, and then add font path to XF86Config.
If your wife is not happy with baekmuk font, you can copy widows font from your windows XP to somewhere in linux font directory. In this case we need to create fonts.scale and fonts.dir file( the filenams may be not corret).
Concerning input of korean, it's not trivial. I didn't make it yet. However, if you still need to solve it , I may can post some clue later.

Regards.

Kim

Last edited by chykim; 05-10-2004 at 01:07 PM.
 
Old 05-10-2004, 02:21 PM   #11
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
jroussel, unfortunately you got angry when pointed to the Gentoo web site, but had you scanned the page linked to, you would have found the link to the Gentoo Linux Localization Guide, which is designed to answer questions about how to set up Gentoo to display or be used in other languages.

It's quite easy to give your wife a desktop that is completely in Korean, from the keyboard map, to the menus, to the default language of OpenOffice.org. I am an American who now lives in Holland, so my native language is English (US), but I am trying to learn specific OS commands and menu items in Dutch (they don't teach you that kind of thing in "Dutch as a 2nd Language" school), so sometimes I want to set my desktop language to Dutch. And since I live here, I have to write documents in Dutch (like my CV, for example)-- and while I don't so much need a spell checker in English, I definitely need one in Dutch. Keyboard is the same, though, so I don't know much about keyboard maps.

Instructions for how to generate the Korean locale (if it is not existent on your system), how to change the keyboard map, and even how to change the default language of OpenOffice.org are in the document linked above. The document also includes instructions for how to emerge the correct language files for the KDE desktop environment (GNOME will take its settings from the language you choose in the Display Manager login screen, so you do not have to download and install any special files to display GNOME in another language). However, I generally use GDM (the GNOME display manager), so I don't know if KDM and XDM actually allow you to change language at the time of login. I'm sure there's a way to do it if they don't, but since I have not needed to find another way, I don't know what it is, offhand.

I know it's late, but hope it helps anyway.
 
Old 03-01-2005, 04:09 AM   #12
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
Hi,

I have a similar problem (concerning which I have already posted at the gentoo forums (here), albeit with no answer as of yet). For some reason the relevant locales won't get emerged when I emerge a package. I have an old gentoo installation which will install files to /usr/share/locale/sv/LC_MESSAGES, and thus enabling me to run gimp, nano, and whatnot in both English and Swedish. The new installation, however, will not do that, and I really have no clue as of why. The settings are AFAIK the same. It's really driving me crazy now...

Has anyone had this problem, or any ideas on how to solve it?
 
Old 03-01-2005, 06:38 AM   #13
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
The behaviour of locale creation has changed "recently", probably your 'old' Gentoo profile is exhibiting the old behaviour than the 'new' one.

From the Gentoo Weekly Newsletter of 8 November 2004 http://lwn.net/Articles/110055/ :

Quote:
7. Tips and Tricks
==================

Specifying only needed locales
------------------------------

The locales a user can choose from are built by the glibc. Usually all
available locales starting from aa_DJ (Afar locale for Djibouti) over
en_US (English locale for the USA) to zu_ZA.utf8 (Zulu locale for South
Africa) will be installed. Unless you're working at the UN and administer
a central server for all member states, it is difficult to conceive why
you would need a system where all of these locales are installed. This
week's tip was written with all those of you in mind who'd like to save 90
percent of the space occupied by locales in their system, by limiting the
number of installed locales to the bare minimum.

Ever since sys-libs/glibc-2.3.4.20040619-r2 has been in Portage, a
USE-flag called userlocales was provided to make sure only those locales
mentioned in /etc/locales.build are to be built and installed. As a
side-effect, this also leads to a much faster emerge of glibc, obviously.
Instructions for enabling the locales you want follow in the article; the user is also referred to the Gentoo Localization Guide.

Have you possibly activated userlocales in /etc/make.conf or /etc/portage/package.use, and yet not specified Swedish in /etc/locales.build? Have you possibly set LC_ALL in /etc/env.d/02locale or ~/.bashrc?

Variable name Explanation
LC_ALL Define all locale settings at once. This is the top level setting for locales which will override any other setting.
LC_COLLATE Define alphabetical ordering of strings. This affects eg. output of sorted dir listing.
LC_CTYPE Define the character handling properties for the system. This determines which characters are seen as part of alphabet, numeric and so on. This also determines the character set used, if applicable.
LC_MESSAGES Programs' localizations for applications that use message based localization scheme (majority of Gnu programs, see next chapters for closer information which do, and how to get the programs, that don't, to work).
LC_MONETARY Defines currency units and formatting of currency type numeric values.
LC_NUMERIC Defines formatting of numeric values which aren't monetary. Affects things such as thousand separator and decimal separator.
LC_TIME Defines formatting of dates and times.
LC_PAPER Defines default paper size.
LANG Defines all locale settings at once. This setting can be overridden by individual LC_* settings above or even by LC_ALL.

The only reason I can think of that locales (translations) aren't being built is that you haven't said they should be (assuming translations exist for the program, which in this case they obviously do).

Hope this helps.
 
Old 03-01-2005, 01:54 PM   #14
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
Thanks alot for the reply, I really appreciate it.

Quote:
The only reason I can think of that locales (translations) aren't being built is that you haven't said they should be (assuming translations exist for the program, which in this case they obviously do).
Yes, for some reason the locales are not build and unless this is some serious bug (which I find hard to believe since it's practically impossible to find anyone else having this problem), I must somehow fail to tell the system to build the locales.

I should have written this in my original post, but yes, I have added the following lines

Code:
en_US/ISO-8859-15
en_US.UTF-8/UTF-8
sv_SE/ISO-8859-15
sv_SE.UTF-8/UTF-8
in /etc/locales.build

and locale -a, accordingly, gives me the following output

Code:
C
en_US
en_US.iso885915
en_US.utf8
POSIX
sv_SE
sv_SE.iso885915
sv_SE.utf8
...so all that seems OK. Furthermore I do have the -nls use-flag enabled.
The old gentoo installation has glibc-2.3.4.20041102,
the new gentoo installation has glibc-2.3.4.20050125,
so they both should be working according the same /etc/locales.build-principle. One difference, though, that I haven't mentioned (which I don't really think has anything to do with it), is that the new gentoo-installation has nptl enabled. However, I just noticed a difference which in fact confuses me even more: the old installation has glibc installed without the -userlocales use-flag, whereas the new installation has the enabled. /usr/portage/profile/use.desc says nothing about what this useflag does...

Any other ideas?

Edit: I just emerged glibc without the userlocales use-flag, allowing it to generate all locales... the situation is still the same...

Last edited by Nightfrost; 03-01-2005 at 03:37 PM.
 
Old 03-02-2005, 03:46 AM   #15
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
All the problems seem to have been caused by a malformarion in one of the variables.

I had
Code:
LINGUAS="us,sv"
in /etc/make.conf, but it should be
Code:
LINGUAS="us sv"
*Phew*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Foreign languages support in Wine zWaR Linux - Software 1 06-29-2005 10:18 AM
Possible to display foreign languages? vincebs Linux - General 4 01-16-2005 12:33 AM
Foreign languages floppywhopper LQ Suggestions & Feedback 24 01-07-2005 07:48 AM
How to view foreign languages? JunZ Linux - Newbie 1 05-31-2004 08:49 AM
viewing text in foreign languages h/w Linux - General 8 04-14-2004 10:49 PM


All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration