LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-22-2004, 06:47 PM   #1
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Rep: Reputation: 15
how can I toggle different keyboard layouts?


Hi

I want to toggle different keyboard types on my Fedora Core 2 with
some simple keyboard shortcuts. But I can't find out how.
It's too much to do System settings -> keyboard -> (password) ->
change keyboard, every time I want to change to different languages.

KDE seems to have such a function (I use Gnome, but I
don't mind use KDE in stead if it's something Gnome cannot) but under
Kcontrol -> Regional accessibility -> keyboard layout
there is no keyboard layout to choose. (of course, I checked 'Enable
Keyboard layout')

I have naturally installed FC2 with all the languages I want to use.

Can anyone help me?
 
Old 08-22-2004, 08:48 PM   #2
Boby
Member
 
Registered: Feb 2004
Location: Sighisoara/Cluj-Napoca (Romania)
Distribution: CentOS 4, Fedora Core 6
Posts: 781

Rep: Reputation: 31
Hello!

I'm heaving the same problem with keyboard layout in FC2 There are other posts in this forum about that and I posted this problem too...the best option for me [that I found here] was to use this command: "setxkbmap us" or "setxkbmap de" or "setxkbmap it". Maybe someone else can help more.

Boby
 
Old 08-22-2004, 08:51 PM   #3
citrus
Member
 
Registered: Dec 2003
Location: California
Distribution: Kubuntu 6.1
Posts: 548

Rep: Reputation: 30
you could prolly make some kinda bash script and the run either one for whatever keyboard layout you need


not sure tho
 
Old 08-23-2004, 08:46 AM   #4
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
Hi Boby

That with setxkbmap... is definitely better than clicking 4 times + password!
Thanks!

Still, it would be great if anyone knows how to change layouts by
simple keyboard shortcuts. Hard to believe that all FC2 users using
more than 1 language are doing all the clickings or setxkbmap...
 
Old 08-23-2004, 09:20 AM   #5
valencequark
Member
 
Registered: Aug 2004
Location: greater dc metro area
Distribution: various, mostly fedora
Posts: 79

Rep: Reputation: 16
if you can get the keymap textfiles, you can use xmodmap to toggle between diff't keyboard layouts.

assuming that you have a qwerty keyboard and that you want to go back to it at some point:

xmodmap -pke > qwerty

this pipes the output of xmodmap into a text file called 'qwerty'
now, download the keymaps for whatever you wish to use (for example, a dvorak layout).

assuming this is in a file called 'dvorak', then you type:

xmodmap dvorak

now you have a dvorak keyboard.

cheers,
--vq
 
Old 08-24-2004, 03:06 PM   #6
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
Hi valencequark

Thanks for your advise! but if i understand it correctly, it makes only another type of keyboard available, isn't it?

Maybe I didn't make it clear, but I have already all the keyboard types I want in my pc and I can change it, if i want.
I wanted to ask how I can toggle between those keyboard types by simple keyboard shortcuts,
without entering system settings...

I'm a newbie, (have installed FC2 4days ago and this is my first linux working) so if i misunderstand
something, my apology.

Anyone with any ideas??

kentri9
 
Old 09-04-2004, 11:46 AM   #7
fid def
LQ Newbie
 
Registered: Aug 2004
Location: canada
Posts: 22

Rep: Reputation: 15
Angry switching K/board layouts

I'm in the same boat, my wife is a qwerty touch typist and I use Dvorak, in Win. XP I hit control /shift and the kb changes. That's what we need in Linux, surely there must be a way?
 
Old 09-05-2004, 06:24 AM   #8
Not now, John!
Member
 
Registered: Jul 2004
Distribution: LFS 5.1
Posts: 161

Rep: Reputation: 30
Here's extract from my xorg.conf:
Code:
    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105"
    Option "XkbLayout"   "si,sr"
    Option "XkbOptions"  "grp:alt_shift_toggle,grp_led:scroll"
so, when I press Alt+Shift, my keybord changes to Serbian layout (Slovenian is default). Scroll Lock lights up as an indicator.
 
Old 09-05-2004, 10:52 AM   #9
fid def
LQ Newbie
 
Registered: Aug 2004
Location: canada
Posts: 22

Rep: Reputation: 15
Wink

Thanks n n, J, Now we are getting somewhere, all we need now is the entries for Dvorak and US english.
You guys are really something, is there anything you don't know?
 
Old 09-05-2004, 02:33 PM   #10
Not now, John!
Member
 
Registered: Jul 2004
Distribution: LFS 5.1
Posts: 161

Rep: Reputation: 30
Look in /usr/X11R6/lib/X11/xkb/symbols directory. There should be rules for dvorak and en_US keymaps. I have those two files.
If you use Xorg then you should put the following in your xorg.conf file:
Code:
    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105" # or pc102 or whichever you have
    Option "XkbLayout"   "en_US,dvorak" # or dvorak,en_US
    Option "XkbOptions"  "grp:alt_shift_toggle,grp_led:scroll"
If you use Xfree86 consult other people on the forum to help you with differences.
 
Old 09-06-2004, 08:24 AM   #11
fid def
LQ Newbie
 
Registered: Aug 2004
Location: canada
Posts: 22

Rep: Reputation: 15
THanks again.
 
Old 09-06-2004, 09:50 AM   #12
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
There is a keyboard switcher applet for GNOME, iirc. Can you use that?
 
Old 09-11-2004, 05:27 PM   #13
Boby
Member
 
Registered: Feb 2004
Location: Sighisoara/Cluj-Napoca (Romania)
Distribution: CentOS 4, Fedora Core 6
Posts: 781

Rep: Reputation: 31
Could this problem be caused by the kernel options? I just compiled a new kernel on my box and enabled there some language support...now I can add keyboard layots in control center

Boby
 
Old 10-08-2004, 06:52 AM   #14
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 704

Rep: Reputation: 30
Gnome 2.6
I opened "keyboard preferences" and in the "layouts" tab i added Greek, after English us. Then in the panel i added utility-->keyboard indicator. A box appeared with the indication us. When i clicked on it, it changed to Grc (probably Greek), but when i tried to write anything it changed back to English and instead of Greek i wrote English. When i opened "keyboard preferences" and i pressed the button "up", Greek moved up, but exactly the opposite happened. When i changed the indicator and tried to write English, the indicator changed back to Greek and i wrote Greek instead of English. What can i do?

Last edited by kpachopoulos; 10-08-2004 at 07:09 AM.
 
Old 10-09-2004, 04:46 PM   #15
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
Thank you! this really helped!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
switching between keyboard layouts trawler Linux - Software 1 10-22-2005 06:51 AM
Incompatible Keyboard Layouts???? fangorn AIX 7 06-02-2005 07:57 AM
keyboard layouts misulo Fedora 0 08-17-2004 01:29 PM
vanished keyboard layouts Castor Slackware 2 08-01-2004 05:58 PM
Switching between keyboard layouts ??? GloVe Linux - General 1 10-13-2003 10:26 AM


All times are GMT -5. The time now is 04:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration