LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2015, 12:17 PM   #1
tahirgaddi
LQ Newbie
 
Registered: Mar 2015
Posts: 2

Rep: Reputation: Disabled
how can i solve Open Gl problem


after writing the command
glxinfo | grep OpenGL
the results are
can any one help me
Xlib: extension "GLX" missing on display ":0"

Last edited by tahirgaddi; 03-03-2015 at 12:20 PM.
 
Old 03-03-2015, 12:42 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,995

Rep: Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327Reputation: 4327
Quote:
Originally Posted by tahirgaddi View Post
after writing the command
glxinfo | grep OpenGL
the results are
can any one help me
Xlib: extension "GLX" missing on display ":0"
Please read the "Question Guidelines" link in my posting signature. We will be happy to help, but we need DETAILS before we can attempt to. Things like version/distro of Linux, what kind of hardware, graphics card, etc.
 
Old 03-03-2015, 12:51 PM   #3
cepheus11
Member
 
Registered: Nov 2010
Location: Germany
Distribution: Gentoo
Posts: 280

Rep: Reputation: 88
Post more of the "glxinfo" output:

Code:
glxinfo|head -n 25
And your Xorg log:

Code:
cat /var/log/Xorg.0.log
And your hardware:

Code:
lspci
And - what distribution do you use?
 
Old 03-03-2015, 12:53 PM   #4
helios98
Member
 
Registered: Dec 2014
Distribution: Lubuntu on Chromebook c300
Posts: 46

Rep: Reputation: Disabled
Quote:
Originally Posted by tahirgaddi View Post
after writing the command
glxinfo | grep OpenGL
the results are
can any one help me
Xlib: extension "GLX" missing on display ":0"
in Linux there are two kind of graphic drivers 2d and 3d acceleration. but what TB0ne said we need more details on your hardware, distro, and etc
 
Old 03-03-2015, 02:13 PM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,081
Blog Entries: 1

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
You need a video driver and opengl installed.

$ sudo apt-get install libgl1-mesa-glx mesa-utils xserver-xorg-video-all

(for debian jessie)

And probably some other packages to get things up to par. The mesa-utils package provides the glxinfo binary. The libgl1-mesa-glx provides the libGL.so library. And the other the video drivers for many cards. There are proprietary drivers to, which will likely replace libGL and other kernel module type stuff. Otherwise look for DRI support in /var/log/Xorg.0.log. And for the video driver that is being used in the same log file. Using lsmod while X is running can also clue in on what is being used. In use modules will have a number other than 0 in the 3rd column. Beyond that we need more information on the hardware in use.

$ lspci -nn | grep -i vga
 
Old 03-10-2015, 03:16 AM   #6
tahirgaddi
LQ Newbie
 
Registered: Mar 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
system information

I am using linux opensus 12.2
IBM processor, system X3200 M2
server X
4gb ram
Nvidia graphic processing unit


when i run this command on my system

glxinfo | grep OpenGl
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".



glxinfo|head -n 25

output

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
name of display: :0










when i access my system from other pc linux os
so results are

info | grep OpenGL
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 1.4 (2.1 Mesa 7.10.2)
OpenGL extensions:

glxinfo|head -n 25
name of display: localhost:10.0
display: localhost:10 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_MESA_copy_sub_buffer, GLX_INTEL_swap_event
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float,
GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap
GLX version: 1.3
GLX extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_ARB_get_proc_address
OpenGL vendor string: Mesa Project














cat /var/log/Xorg.0.log
[ 42.956]
X.Org X Server 1.12.3
Release Date: 2012-07-09
[ 42.956] X Protocol Version 11, Revision 0
[ 42.956] Build Operating System: openSUSE SUSE LINUX
[ 42.956] Current Operating System: Linux mcg01 3.4.63-2.44-desktop #1 SMP PREEMPT Wed Oct 2 11:18:32 UTC 2013 (d91a619) x86_64
[ 42.957] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.4.63-2.44-desktop root=UUID=7b1de2e9-e4dc-4f0c-86d9-d9f698b6e547 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
[ 42.957] Build Date: 19 December 2013 01:41:37PM
[ 42.957]
[ 42.957] Current version of pixman: 0.24.4
[ 42.957] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 42.957] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 42.957] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 10 12:42:05 2015
[ 42.957] (==) Using config file: "/etc/X11/xorg.conf.install"
[ 42.957] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 42.957] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 42.966] (==) ServerLayout "Layout"
[ 42.966] (**) |-->Screen "vboxvideo" (0)
[ 42.966] (**) | |-->Monitor "<default monitor>"
[ 42.966] (**) | |-->Device "vboxvideo"
[ 42.966] (==) No monitor specified for screen "vboxvideo".
Using a default monitor configuration.
[ 42.966] (**) |-->Screen "vmware" (1)
[ 42.966] (**) | |-->Monitor "<default monitor>"
[ 42.966] (**) | |-->Device "vmware"
[ 42.966] (==) No monitor specified for screen "vmware".
Using a default monitor configuration.
[ 42.966] (**) |-->Screen "cirrus" (2)
[ 42.966] (**) | |-->Monitor "<default monitor>"
[ 42.966] (**) | |-->Device "cirrus"
[ 42.966] (==) No monitor specified for screen "cirrus".
Using a default monitor configuration.
[ 42.966] (**) |-->Screen "fbdev" (3)
[ 42.966] (**) | |-->Monitor "<default monitor>"
[ 42.967] (**) | |-->Device "fbdev"
[ 42.967] (==) No monitor specified for screen "fbdev".
Using a default monitor configuration.
[ 42.967] (**) |-->Screen "vesa" (4)
[ 42.967] (**) | |-->Monitor "<default monitor>"
[ 42.967] (**) | |-->Device "vesa"
[ 42.967] (==) No monitor specified for screen "vesa".
Using a default monitor configuration.
[ 42.967] (==) Automatically adding devices
[ 42.967] (==) Automatically enabling devices
[ 43.088] (WW) The directory "/usr/share/fonts/URW/" does not exist.
[ 43.088] Entry deleted from font path.
[ 43.102] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[ 43.102] Entry deleted from font path.
[ 43.115] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
[ 43.115] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
[ 43.115] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 43.115] (II) Loader magic: 0x7ccae0
[ 43.115] (II) Module ABI versions:
[ 43.115] X.Org ANSI C Emulation: 0.4
[ 43.115] X.Org Video Driver: 12.0
[ 43.115] X.Org XInput driver : 16.0
[ 43.115] X.Org Server Extension : 6.0
[ 43.116] (--) PCI:*(0:4:1:0) 10de:0185:1b13:0000 rev 193, Mem @ 0xe8000000/16777216, 0xd8000000/134217728, BIOS @ 0x????????/131072
[ 43.116] (--) PCI: (0:4:3:0) 1002:515e:1014:0325 rev 2, Mem @ 0xe0000000/134217728, 0xe9000000/65536, I/O @ 0x00003400/256, BIOS @ 0x????????/131072
[ 43.116] (II) Open ACPI successful (/var/run/acpid.socket)
[ 43.116] (II) "extmod" will be loaded by default.
[ 43.116] (II) "dbe" will be loaded by default.
[ 43.116] (II) "glx" will be loaded by default.
[ 43.116] (II) "record" will be loaded by default.
[ 43.117] (II) "dri" will be loaded by default.
[ 43.117] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[ 43.117] (II) LoadModule: "dri2"
[ 43.126] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 43.126] (II) Module dri2: vendor="X.Org Foundation"
[ 43.126] compiled for 1.12.3, module version = 1.2.0
[ 43.126] ABI class: X.Org Server Extension, version 6.0
[ 43.126] (II) Loading extension DRI2
[ 43.126] (II) LoadModule: "glamoregl"
[ 43.127] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[ 43.135] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
[ 43.135] (II) UnloadModule: "glamoregl"
[ 43.135] (II) Unloading glamoregl
[ 43.135] (EE) Failed to load module "glamoregl" (loader failed, 7)
[ 43.135] (II) LoadModule: "extmod"
[ 43.136] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 43.136] (II) Module extmod: vendor="X.Org Foundation"
[ 43.136] compiled for 1.12.3, module version = 1.0.0
[ 43.136] Module class: X.Org Server Extension
[ 43.136] ABI class: X.Org Server Extension, version 6.0
[ 43.136] (II) Loading extension MIT-SCREEN-SAVER
[ 43.136] (II) Loading extension XFree86-VidModeExtension
[ 43.136] (II) Loading extension XFree86-DGA
[ 43.136] (II) Loading extension DPMS
[ 43.136] (II) Loading extension XVideo
[ 43.136] (II) Loading extension XVideo-MotionCompensation
[ 43.136] (II) Loading extension X-Resource
[ 43.136] (II) LoadModule: "dbe"
[ 43.136] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 43.136] (II) Module dbe: vendor="X.Org Foundation"
[ 43.136] compiled for 1.12.3, module version = 1.0.0
[ 43.136] Module class: X.Org Server Extension
[ 43.136] ABI class: X.Org Server Extension, version 6.0
[ 43.136] (II) Loading extension DOUBLE-BUFFER
[ 43.136] (II) LoadModule: "glx"
[ 43.136] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
[ 43.139] (II) Module glx: vendor="NVIDIA Corporation"
[ 43.139] compiled for 4.0.2, module version = 1.0.0
[ 43.139] Module class: X.Org Server Extension
[ 43.139] (II) NVIDIA GLX Module 96.43.23 Sat Sep 1 03:47:03 PDT 2012
[ 43.139] (II) Loading extension GLX
[ 43.139] (II) LoadModule: "record"
[ 43.139] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 43.139] (II) Module record: vendor="X.Org Foundation"
[ 43.139] compiled for 1.12.3, module version = 1.13.0
[ 43.139] Module class: X.Org Server Extension
[ 43.139] ABI class: X.Org Server Extension, version 6.0
[ 43.139] (II) Loading extension RECORD
[ 43.139] (II) LoadModule: "dri"
[ 43.139] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 43.140] (II) Module dri: vendor="X.Org Foundation"
[ 43.140] compiled for 1.12.3, module version = 1.0.0
[ 43.140] ABI class: X.Org Server Extension, version 6.0
[ 43.140] (II) Loading extension XFree86-DRI
[ 43.140] (II) LoadModule: "vboxvideo"
[ 43.140] (WW) Warning, couldn't open module vboxvideo
[ 43.140] (II) UnloadModule: "vboxvideo"
[ 43.140] (II) Unloading vboxvideo
[ 43.140] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[ 43.140] (II) LoadModule: "vmware"
[ 43.141] (II) Loading /usr/lib64/xorg/modules/drivers/vmware_drv.so
[ 43.323] (II) Module vmware: vendor="X.Org Foundation"
[ 43.323] compiled for 1.12.3, module version = 12.0.2
[ 43.323] Module class: X.Org Video Driver
[ 43.323] ABI class: X.Org Video Driver, version 12.0
[ 43.323] (II) LoadModule: "cirrus"
[ 43.323] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_drv.so
[ 43.335] (II) Module cirrus: vendor="X.Org Foundation"
[ 43.439] compiled for 1.12.3, module version = 1.4.0
[ 43.439] Module class: X.Org Video Driver
[ 43.439] ABI class: X.Org Video Driver, version 12.0
[ 43.439] (II) LoadModule: "fbdev"
[ 43.439] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 43.439] (II) Module fbdev: vendor="X.Org Foundation"
[ 43.439] compiled for 1.12.3, module version = 0.4.2
[ 43.439] ABI class: X.Org Video Driver, version 12.0
[ 43.439] (II) LoadModule: "vesa"
[ 43.439] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 43.439] (II) Module vesa: vendor="X.Org Foundation"
[ 43.439] compiled for 1.12.3, module version = 2.3.1
[ 43.439] Module class: X.Org Video Driver
[ 43.439] ABI class: X.Org Video Driver, version 12.0
[ 43.439] (II) vmware: driver for VMware SVGA: vmware0405, vmware0710
[ 43.440] (II) CIRRUS: driver for Cirrus chipsets: CLGD5430, CLGD5434-4, CLGD5434-8,
CLGD5436, CLGD5446, CLGD5480, CL-GD5462, CL-GD5464, CL-GD5464BD,
CL-GD5465, CL-GD7548, CL-GD7555, CL-GD7556
[ 43.440] (II) FBDEV: driver for framebuffer: fbdev
[ 43.440] (II) VESA: driver for VESA chipsets: vesa
[ 43.440] (++) using VT number 7

[ 43.449] (WW) Falling back to old probe method for cirrus
[ 43.449] (II) Loading sub module "fbdevhw"
[ 43.449] (II) LoadModule: "fbdevhw"
[ 43.450] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 43.450] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 43.450] compiled for 1.12.3, module version = 0.0.2
[ 43.450] ABI class: X.Org Video Driver, version 12.0
[ 43.450] (**) FBDEV(0): claimed PCI slot 4@0:1:0
[ 43.450] (II) FBDEV(0): using default device
[ 43.450] (WW) Falling back to old probe method for vesa
[ 43.450] (II) FBDEV(0): Creating default Display subsection in Screen section
"fbdev" for depth/fbbpp 24/32
[ 43.450] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[ 43.450] (==) FBDEV(0): RGB weight 888
[ 43.450] (==) FBDEV(0): Default visual is TrueColor
[ 43.450] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 43.450] (II) FBDEV(0): hardware: VESA VGA (video memory: 3072kB)
[ 43.450] (II) FBDEV(0): checking modes against framebuffer device...
[ 43.450] (II) FBDEV(0): checking modes against monitor...
[ 43.450] (--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
[ 43.450] (**) FBDEV(0): Built-in mode "current": 78.7 MHz, 59.9 kHz, 75.7 Hz
[ 43.450] (II) FBDEV(0): Modeline "current"x0.0 78.65 1024 1056 1184 1312 768 772 776 792 -hsync -vsync -csync (59.9 kHz b)
[ 43.450] (==) FBDEV(0): DPI set to (96, 96)
[ 43.450] (II) Loading sub module "fb"
[ 43.450] (II) LoadModule: "fb"
[ 43.450] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 43.450] (II) Module fb: vendor="X.Org Foundation"
[ 43.450] compiled for 1.12.3, module version = 1.0.0
[ 43.450] ABI class: X.Org ANSI C Emulation, version 0.4
[ 43.450] (**) FBDEV(0): using shadow framebuffer
[ 43.451] (II) Loading sub module "shadow"
[ 43.451] (II) LoadModule: "shadow"
[ 43.451] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 43.486] (II) Module shadow: vendor="X.Org Foundation"
[ 43.486] compiled for 1.12.3, module version = 1.1.0
[ 43.486] ABI class: X.Org ANSI C Emulation, version 0.4
[ 43.486] (II) UnloadModule: "vmware"
[ 43.486] (II) Unloading vmware
[ 43.486] (II) UnloadModule: "cirrus"
[ 43.486] (II) Unloading cirrus
[ 43.486] (II) UnloadModule: "vesa"
[ 43.486] (II) Unloading vesa
[ 43.486] (==) Depth 24 pixmap format is 32 bpp
[ 43.486] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 43.487] (==) FBDEV(0): Backing store disabled
[ 43.487] (==) FBDEV(0): DPMS enabled
[ 43.487] (==) RandR enabled
[ 43.487] (II) Initializing built-in extension Generic Event Extension
[ 43.487] (II) Initializing built-in extension SHAPE
[ 43.487] (II) Initializing built-in extension MIT-SHM
[ 43.487] (II) Initializing built-in extension XInputExtension
[ 43.487] (II) Initializing built-in extension XTEST
[ 43.487] (II) Initializing built-in extension BIG-REQUESTS
[ 43.487] (II) Initializing built-in extension SYNC
[ 43.487] (II) Initializing built-in extension XKEYBOARD
[ 43.487] (II) Initializing built-in extension XC-MISC
[ 43.487] (II) Initializing built-in extension SECURITY
[ 43.487] (II) Initializing built-in extension XINERAMA
[ 43.487] (II) Initializing built-in extension XFIXES
[ 43.487] (II) Initializing built-in extension RENDER
[ 43.487] (II) Initializing built-in extension RANDR
[ 43.487] (II) Initializing built-in extension COMPOSITE
[ 43.487] (II) Initializing built-in extension DAMAGE
[ 43.489] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[ 43.765] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[ 43.765] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 43.765] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 43.766] (**) Power Button: Applying InputClass "LocalKeyboard"
[ 43.766] (II) LoadModule: "evdev"
[ 43.766] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 43.798] (II) Module evdev: vendor="X.Org Foundation"
[ 43.798] compiled for 1.12.3, module version = 2.7.3
[ 43.798] Module class: X.Org XInput Driver
[ 43.798] ABI class: X.Org XInput driver, version 16.0
[ 43.798] (II) Using input driver 'evdev' for 'Power Button'
[ 43.798] (**) Power Button: always reports core events
[ 43.798] (**) evdev: Power Button: Device: "/dev/input/event5"
[ 43.798] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 43.798] (--) evdev: Power Button: Found keys
[ 43.798] (II) evdev: Power Button: Configuring as keyboard
[ 43.798] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event5"
[ 43.798] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 43.798] (**) Option "xkb_rules" "evdev"
[ 43.798] (**) Option "xkb_model" "evdev"
[ 43.798] (**) Option "xkb_layout" "us"
[ 43.827] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[ 43.827] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 43.827] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 43.827] (**) Power Button: Applying InputClass "LocalKeyboard"
[ 43.827] (II) Using input driver 'evdev' for 'Power Button'
[ 43.827] (**) Power Button: always reports core events
[ 43.827] (**) evdev: Power Button: Device: "/dev/input/event4"
[ 43.827] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 43.827] (--) evdev: Power Button: Found keys
[ 43.827] (II) evdev: Power Button: Configuring as keyboard
[ 43.827] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/PNP0C0C:00/input/input4/event4"
[ 43.827] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 43.827] (**) Option "xkb_rules" "evdev"
[ 43.827] (**) Option "xkb_model" "evdev"
[ 43.827] (**) Option "xkb_layout" "us"
[ 43.827] (II) config/udev: Adding input device USB Keyboard (/dev/input/event0)
[ 43.827] (**) USB Keyboard: Applying InputClass "evdev keyboard catchall"
[ 43.827] (**) USB Keyboard: Applying InputClass "evdev keyboard catchall"
[ 43.828] (**) USB Keyboard: Applying InputClass "LocalKeyboard"
[ 43.828] (II) Using input driver 'evdev' for ' USB Keyboard'
[ 43.828] (**) USB Keyboard: always reports core events
[ 43.828] (**) evdev: USB Keyboard: Device: "/dev/input/event0"
[ 43.828] (--) evdev: USB Keyboard: Vendor 0x9da Product 0x260
[ 43.828] (--) evdev: USB Keyboard: Found keys
[ 43.828] (II) evdev: USB Keyboard: Configuring as keyboard
[ 43.828] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.0/input/input0/event0"
[ 43.828] (II) XINPUT: Adding extended input device " USB Keyboard" (type: KEYBOARD, id 8)
[ 43.828] (**) Option "xkb_rules" "evdev"
[ 43.828] (**) Option "xkb_model" "evdev"
[ 43.828] (**) Option "xkb_layout" "us"
[ 43.828] (II) config/udev: Adding input device USB Keyboard (/dev/input/event1)
[ 43.828] (**) USB Keyboard: Applying InputClass "evdev keyboard catchall"
[ 43.828] (**) USB Keyboard: Applying InputClass "evdev keyboard catchall"
[ 43.828] (**) USB Keyboard: Applying InputClass "LocalKeyboard"
[ 43.828] (II) Using input driver 'evdev' for ' USB Keyboard'
[ 43.828] (**) USB Keyboard: always reports core events
[ 43.828] (**) evdev: USB Keyboard: Device: "/dev/input/event1"
[ 43.828] (--) evdev: USB Keyboard: Vendor 0x9da Product 0x260
[ 43.828] (--) evdev: USB Keyboard: Found keys
[ 43.828] (II) evdev: USB Keyboard: Configuring as keyboard
[ 43.828] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.1/input/input1/event1"
[ 43.828] (II) XINPUT: Adding extended input device " USB Keyboard" (type: KEYBOARD, id 9)
[ 43.828] (**) Option "xkb_rules" "evdev"
[ 43.828] (**) Option "xkb_model" "evdev"
[ 43.828] (**) Option "xkb_layout" "us"
[ 43.829] (II) config/udev: Adding input device A4Tech USB Mouse (/dev/input/event2)
[ 43.829] (**) A4Tech USB Mouse: Applying InputClass "evdev pointer catchall"
[ 43.829] (**) A4Tech USB Mouse: Applying InputClass "evdev pointer catchall"
[ 43.829] (II) Using input driver 'evdev' for 'A4Tech USB Mouse'
[ 43.829] (**) A4Tech USB Mouse: always reports core events
[ 43.829] (**) evdev: A4Tech USB Mouse: Device: "/dev/input/event2"
[ 43.829] (--) evdev: A4Tech USB Mouse: Vendor 0x9da Product 0xc10a
[ 43.829] (--) evdev: A4Tech USB Mouse: Found 12 mouse buttons
[ 43.829] (--) evdev: A4Tech USB Mouse: Found scroll wheel(s)
[ 43.829] (--) evdev: A4Tech USB Mouse: Found relative axes
[ 43.829] (--) evdev: A4Tech USB Mouse: Found x and y relative axes
[ 43.829] (--) evdev: A4Tech USB Mouse: Found absolute axes
[ 43.829] (II) evdev: A4Tech USB Mouse: Forcing absolute x/y axes to exist.
[ 43.829] (II) evdev: A4Tech USB Mouse: Configuring as mouse
[ 43.829] (II) evdev: A4Tech USB Mouse: Adding scrollwheel support
[ 43.829] (**) evdev: A4Tech USB Mouse: YAxisMapping: buttons 4 and 5
[ 43.829] (**) evdev: A4Tech USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 43.829] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-2/6-2:1.0/input/input2/event2"
[ 43.829] (II) XINPUT: Adding extended input device "A4Tech USB Mouse" (type: MOUSE, id 10)
[ 43.829] (II) evdev: A4Tech USB Mouse: initialized for relative axes.
[ 43.829] (WW) evdev: A4Tech USB Mouse: ignoring absolute axes.
[ 43.829] (**) A4Tech USB Mouse: (accel) keeping acceleration scheme 1
[ 43.829] (**) A4Tech USB Mouse: (accel) acceleration profile 0
[ 43.829] (**) A4Tech USB Mouse: (accel) acceleration factor: 2.000
[ 43.829] (**) A4Tech USB Mouse: (accel) acceleration threshold: 4
[ 43.829] (II) config/udev: Adding input device A4Tech USB Mouse (/dev/input/mouse0)
[ 43.829] (II) No input driver specified, ignoring this device.
[ 43.829] (II) This device may have been added with another device file.
[ 43.830] (II) config/udev: Adding input device PC Speaker (/dev/input/event3)
[ 43.830] (II) No input driver specified, ignoring this device.
[ 43.830] (II) This device may have been added with another device file.
[ 43.833] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 68.517] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 68.517] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 68.520] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)

cat /var/log/Xorg.0.log
 
Old 03-11-2015, 01:28 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,081
Blog Entries: 1

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
[ 43.489] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Would imply that the nvidia driver isn't installed or fully / properly installed. If your distro has upgraded kernels, you will likely need to re-install the proprietary driver so it can regenerate a kernel module for your current kernel. Which is most likely the culprit if it "formerly" worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Open Solaris and Open Suse 10.2 on same disk problem devn Solaris / OpenSolaris 3 10-05-2007 03:31 AM
open gl problem zexter Linux - Software 3 11-05-2004 07:02 AM
open gl problem doralsoral Linux - Software 2 01-11-2004 09:53 AM
Open GL problem doralsoral Linux - Software 2 12-15-2003 06:33 AM
Open With... Problem Daggelicious Linux - Software 4 07-01-2003 11:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration