LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-21-2003, 09:29 PM   #1
nairnie
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: RedHat 9, Slackware 9.1, Debian
Posts: 28

Rep: Reputation: 15
How can i run in just the CLI?


Sorry in advance for the stupid question.

I have just managed to congigure my Red Hat 9 box as a gateway/firewall/dhcp/samba server. As it is doing all this stuff, and is a fairly old machine i just want to leave it running without a GUI loaded. Is it possible to drop out of Gnome to a pure CLI while still staying logged in? I have had a google and a search through the forum but can't find any mention of a command to do this.

Thanks,

nairnie
 
Old 11-21-2003, 09:34 PM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try get into any of the virtual consoles(ctrl + alt + F1-6)
then type
telinit 3
 
Old 11-21-2003, 09:35 PM   #3
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
oh and also make sure these services are configured to run in runlevel 3
 
Old 11-21-2003, 09:37 PM   #4
Glock Shooter
Member
 
Registered: Jan 2002
Location: Riverside, CA
Distribution: Slackware Convert!!
Posts: 210

Rep: Reputation: 30
edit /etc/initab and change the default runlevel to 3. This will bring you to a prompt when you login, now you are are at a console. startx will start x, logging out will take you back to the console, still logged in.
 
Old 11-21-2003, 09:41 PM   #5
nairnie
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: RedHat 9, Slackware 9.1, Debian
Posts: 28

Original Poster
Rep: Reputation: 15
Cheers all. Will give that a crack now.
 
Old 11-21-2003, 10:06 PM   #6
nairnie
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: RedHat 9, Slackware 9.1, Debian
Posts: 28

Original Poster
Rep: Reputation: 15
Whoopsie!!!!

Think i must have changed the wrong thing in initab as when i tried to reboot it just stoped before loading the services and checking for hardware and said something about a runlevel 9???

Anyone got anyideas what happened there?
 
Old 11-22-2003, 02:07 AM   #7
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
On the grub splash screen, with your kernel selected press e, and add a space and '3' to the kernel parameter, this way it will ignore inittab and boot into runlevel 3, then you can fix inittab.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is CLI in or out? C.B. Linux - General 15 06-27-2005 03:57 AM
need some CLI help Lleb_KCir Linux - General 8 05-15-2004 11:24 PM
CLI only monkfish Linux - Newbie 3 08-15-2003 05:13 PM
More CLI! NSKL Linux - General 3 12-02-2002 09:52 PM
CLI Ruth Linux - General 2 03-20-2001 06:24 PM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration