LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-28-2005, 01:55 AM   #1
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Rep: Reputation: 15
How can I re-set up default language for my system?


I set up Chinese as default language as system language when first installation.Now I want change to English.How to do that.Thanks
 
Old 06-28-2005, 02:44 AM   #2
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
If you have a graphical login, then when it asks for username and password, at the bottom you will get the option of changing the language. Choose english and it should work.
 
Old 06-28-2005, 03:07 AM   #3
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
Thank you very much.But I want shell's returned message is also English.Now my shell returned message are somethings neither in English nor Chinese ,nor any kind of language.
 
Old 06-28-2005, 03:11 AM   #4
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
That may be because of the fonts you have set up. It will display junk characters until you set english fonts. You need to do two things:

a) go to menu->preferences->fonts and select english fonts instead of chinese
b) you should additionally add the english layout bu going to panel menu->preferences->keyboard
Click on the Layouts tab at the top and add English layout.

This should set things right.
 
Old 06-28-2005, 03:55 AM   #5
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
My distro redhat 9.
I went to Preference->Fonts Preferences,it have foure bars with " Application fonts","Desktop fonts","Terminal fonts",etc,but no English fonts;

I went to Preference->Keyboard Preferences,but there are no Layout tab(there are keyborad and sound tab in the panel).
 
Old 06-28-2005, 04:05 AM   #6
backpacker
Member
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 68

Original Poster
Rep: Reputation: 15
And "Terminal fant:monospace "->Pick a font(Family,Style,Size),there is no English font opation.
 
Old 06-28-2005, 04:07 AM   #7
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
Quote:
Originally posted by backpacker
My distro redhat 9.
I went to Preference->Fonts Preferences,it have foure bars with " Application fonts","Desktop fonts","Terminal fonts",etc,but no English fonts;
In the terminal fonts dropdown, select some english font like monospace or times etc. Allow me to explain, it won't say English font, but listed would be some fonts like monospace or times etc, choose any of these.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change default language Slackware 10.2 RockmanExe Slackware 8 11-11-2005 01:50 PM
Changing the default language... njschroe Suse/Novell 5 04-24-2005 01:44 PM
How to use another language as default? anindyanuri Fedora 6 03-19-2005 01:15 PM
openoffice default language-French?? mostwanted Linux - Software 2 11-17-2004 04:17 PM
how to change the default language of the system icoming Linux - General 8 06-01-2004 01:06 PM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration