LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How can I re-set up default language for my system? (http://www.linuxquestions.org/questions/linux-newbie-8/how-can-i-re-set-up-default-language-for-my-system-337918/)

backpacker 06-28-2005 01:55 AM

How can I re-set up default language for my system?
 
I set up Chinese as default language as system language when first installation.Now I want change to English.How to do that.Thanks

LinuxLala 06-28-2005 02:44 AM

If you have a graphical login, then when it asks for username and password, at the bottom you will get the option of changing the language. Choose english and it should work.

backpacker 06-28-2005 03:07 AM

Thank you very much.But I want shell's returned message is also English.Now my shell returned message are somethings neither in English nor Chinese ,nor any kind of language.

LinuxLala 06-28-2005 03:11 AM

That may be because of the fonts you have set up. It will display junk characters until you set english fonts. You need to do two things:

a) go to menu->preferences->fonts and select english fonts instead of chinese
b) you should additionally add the english layout bu going to panel menu->preferences->keyboard
Click on the Layouts tab at the top and add English layout.

This should set things right.

backpacker 06-28-2005 03:55 AM

My distro redhat 9.
I went to Preference->Fonts Preferences,it have foure bars with " Application fonts","Desktop fonts","Terminal fonts",etc,but no English fonts;

I went to Preference->Keyboard Preferences,but there are no Layout tab(there are keyborad and sound tab in the panel).

backpacker 06-28-2005 04:05 AM

And "Terminal fant:monospace "->Pick a font(Family,Style,Size),there is no English font opation.

LinuxLala 06-28-2005 04:07 AM

Quote:

Originally posted by backpacker
My distro redhat 9.
I went to Preference->Fonts Preferences,it have foure bars with " Application fonts","Desktop fonts","Terminal fonts",etc,but no English fonts;

In the terminal fonts dropdown, select some english font like monospace or times etc. Allow me to explain, it won't say English font, but listed would be some fonts like monospace or times etc, choose any of these.


All times are GMT -5. The time now is 12:12 AM.