LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how can i install vlc in rhel 5 (http://www.linuxquestions.org/questions/linux-newbie-8/how-can-i-install-vlc-in-rhel-5-a-786249/)

srini406 02-01-2010 02:05 PM

how can i install vlc in rhel 5
 
hi all

i am using rhel5 in my pc. i dont have internet connection.
how can i install vlc in my pc. share your answer please?

thanks,
srini.

acid_kewpie 02-01-2010 02:06 PM

obtain the RPM's in whatever way you can, transfer them to the machine, and then install them using the rpm command.

srini406 02-01-2010 09:42 PM

which rpms shall i download
 
ok........

but which rpms shall i download for vlc installation in rhel5.

acid_kewpie 02-02-2010 01:23 AM

well the vlc ones themselves you can find easily: http://www.google.co.uk/search?q=vlc+el5 as for their dependencies, I couldn't say, as I don't know what it requires.

Note that el5 is NOT designed for media, it's a pretty bad choice if that's why you picked it, and you'll prbably have quite a few dependencies to get through.

kingston 02-02-2010 02:26 AM

vlc will work...u can use xine also in rhel 5 which give better performance than vlc and will play most of the formats...

here is the link which vlc and its lib rpms ....if u have patience u can go for this.

http://www.megaupload.com/?d=WQ2D7HKT

srini406 02-04-2010 07:41 AM

thanks kingston
 
how can i install xine for rhel 5.

acid_kewpie 02-04-2010 01:48 PM

There are no special instructions on how to achieve this. As with the significant majority of software, it's a case of obtaining the RPM's and installing them, and their dependencies.

++nick++ 02-04-2010 04:46 PM

Srini you got a lot to do without internet , if you cannot find out what rpm's you need , first download VLC rpm alone and try installing it using rpm command which will echo almost all the dependencies , then collect them , create yum repository and use yum command to install VLC in EL5 . you might as well run into troubles as RPM you would have collected as dependancy will have few more RPM s to be collected as its own dependency RPM.. Finally build yum repo using createrepo command (which can be installed from EL5 installation CD).

acid_kewpie 02-04-2010 05:39 PM

Hmm, ok http://dag.wieers.com/rpm/packages/xine/ contains the xine rpm's but as it says on the page there, you should update your yum repositories to automatically reference Dag's repository as well as at and others to get yum to install them all automatically.

again though, redhat EL is NOT for media, maybe you would be better off with a more user orientated distro?

kingston 02-05-2010 12:46 AM

yes as nick told...download the rpms from that megaupload link. Then create a respository, try to install through yum which will be easier.
And i agree with "acid" that REDHAT EL 5 is not built for media applications. But still we can do.
Srini - if u want to use linux as a Desktop OS, u better choose Ubuntu or Fedora.

These are all rpms required for xine:

rpm -ivh libdvdcss-1.2.8-2.network.i386.rpm
rpm -ivh libdvdcss-1.2.8-2.network.src.rpm
rpm -ivh libxine1-1.1.2cvs-051226.k7.rpm
rpm -ivh xine-ui-0.99.4cvs-051003.i586.rpm
rpm -ivh xine-ui-0.99.4cvs-051003.src.rpm
w32codec-0.52-1.i386.rpm

U can play avi, mkv, wmv and flv ( i hope so ) and vob format files.


All times are GMT -5. The time now is 12:46 PM.