LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2010, 11:28 AM   #1
knersa
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
How can I get the @ in Linux from a mac keyboard?


I have installed Linux mint on a partition on a 24" iMac. I find it very interesting, but I cant find out how to get the @ on it when emailing etc. I have gone a way round it by copying it on a textpage, and then pasting it in the mail, but that is quite awkward. Be thankful for a solution.
Knut
 
Old 04-01-2010, 11:40 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Why doesn't shift+2 work?
 
Old 04-01-2010, 11:43 AM   #3
LouRobytes
Member
 
Registered: Mar 2010
Location: Nova Scotia, Canada
Distribution: Ubuntu & Fedora
Posts: 189

Rep: Reputation: 44
You may not have a US-configured keyboard.

Cheers, Lou

EDIT: In Gnome you configure your keyboard layout via System->Preferences->Keyboard. Don't know about KDM.

Last edited by LouRobytes; 04-01-2010 at 11:50 AM. Reason: Added info
 
Old 04-01-2010, 12:49 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
You can get any key to do just about anything with xmodmap

Example: I hate "Caps lock" so I make it work the same way as "Shift" with these commands:
xmodmap -e "remove Lock = Caps_Lock"
xmodmap -e "add Shift = Caps_Lock"


Just do a search on xmodmap, there are lots of HOWTOs on the web.
 
Old 04-01-2010, 03:58 PM   #5
TuxSurfer
Member
 
Registered: May 2004
Location: NC USA
Distribution: Fedora 23 - Cinnamon Spin
Posts: 270

Rep: Reputation: 32
Quote:
Originally Posted by LouRobytes View Post
You may not have a US-configured keyboard.

Cheers, Lou

EDIT: In Gnome you configure your keyboard layout via System->Preferences->Keyboard. Don't know about KDM.
Also make sure you choose the Mac layout option.
 
Old 04-01-2010, 05:52 PM   #6
knersa
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Thanx

Thanx for these tips. I will try them out tomorrow. It is a norwegian layout on the mac keyboard though, so I am not shure, but some of it ought to help.
 
Old 04-01-2010, 06:29 PM   #7
TuxSurfer
Member
 
Registered: May 2004
Location: NC USA
Distribution: Fedora 23 - Cinnamon Spin
Posts: 270

Rep: Reputation: 32
For Norwegian try the alt key to the right of the spacebar + 2. See if this helps.
 
Old 04-02-2010, 06:47 AM   #8
knersa
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Smile Worked

Quote:
Originally Posted by TuxSurfer View Post
Also make sure you choose the Mac layout option.
Yes. It was just to choose the right keyboard in prefs. Thank you all.
 
Old 04-02-2010, 08:21 AM   #9
TuxSurfer
Member
 
Registered: May 2004
Location: NC USA
Distribution: Fedora 23 - Cinnamon Spin
Posts: 270

Rep: Reputation: 32
Glad you got it working and welcome to LQ!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mac OS X keyboard question HURD-64 Other *NIX 3 07-19-2008 08:57 AM
Kensington Slim Type Keyboard Mac under Linux tphman Linux - Hardware 0 11-07-2005 12:33 PM
Theoretical Mac keyboard & KVM rose_bud4201 Linux - Hardware 1 06-01-2005 11:59 AM
swapping " and @ keys on mac keyboard alcibiades Linux - Newbie 3 04-23-2005 09:03 AM
mac keyboard bucovaina78 Linux - Hardware 0 11-30-2004 03:38 PM


All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration