LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-17-2007, 04:28 AM   #1
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Rep: Reputation: 0
how can i get into a modem?


hello,

I'm trying to enter a netgear modem which it's default ip acces is 192.168.0.1

i've changed my ip address to 192.168.0.2 with
ifconfig eth0 192.168.0.2

and i try to ping the modem
with ping 192.168.0.2
and it says: destination host unreachable

if i try to entere the modem with the username
ssh admin@192.168.0.1
i says:
ssh: connect to host 192.168.0.1 port 22: No route to host

I lookin around to try to solve the problem .. but i don't find any good answer.

If anybody could help me, i would be greatful.

avico
 
Old 09-17-2007, 04:39 AM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Not sure I understand fully.. Are you trying to 'get into' some sort of internal configuration menu in the modem, sort of like one would do with a router?

192.168.0.1 is normally the 'default gateway' but not in my experience an I.P. address for a piece of hardware. FOr excample, to get into my router, I always just used my web browser, and entered 192.168.0.254 (or whatever it is) into the navigation bar, and instantly the routers login page appeaed. Is this what you are trying to do?

Also, changing your ethernet adapters IP address using ifconfig is not changing the modem IP address, only the address of the NIC (network interface) so I suspect that whatever address you should be using to access the modem is hard-coded, and is something other than 192.168.0.1.

Maybe I've totally misunderstood the issue, but can you give us the full model name & number of the modem, and any further information about it?
 
Old 09-17-2007, 04:46 AM   #3
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
ok,
i have a netgear dm111p, and i'm trying to access the modem, see what is inside. the final purpose is to be able to send an application and make it work inside.

i'm not sure what other information you need..
 
Old 09-17-2007, 04:54 AM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Hmm interesting. OK, according to the manual, you should be able to use a web browser to get into the modem, and it IS 192.168.0.1.

Providing your onboard NIC is configured and working properly, open a browser and enter

http://192.168.0.1

into the location bar. This should then ask you for the name and password. No fancy ssh or whatever should be needed.

Does it work? If not, make sure your NIC is configured properly.
 
Old 09-17-2007, 04:59 AM   #5
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
i've already tried that...
and it does not work..

the thing is i'haven't installed the modem, i didn't think it was necessary for what i'm intrested right now. Could that be the problem?

how do i configure mi NIC properly?
 
Old 09-17-2007, 05:13 AM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
I'm not sure what 'installing' the modem would entail, but my guess would be that it would merely need to be plugged in & turned on, maybe even RESET using the reset button & procedure documented in the manual. As for 'installation' it appears from the manual that any installation that you would do would apply more to Windows than Linux. It looks like you can basically plug it in and access it thru the browser as we discussed.

Now, it seems like your ethernet connection (NIC) is not configured properly. The manual indicated that the modem will give your computer an IP using the DHCP method, so you need to configure your ethernet adapter to use DHCP to aquire an IP address.

What Linux are you using (or what OS if not Linux?) and what kernel?
What type of onboard ethernet device do you have?
Have you enabled the kernel driver necessary to use your ethernet device?
Does your OS have a network configuration area? Does it work, and tell you that the ethernet device is 'enabled'?

Let's start there..

Last edited by GrapefruiTgirl; 09-17-2007 at 05:14 AM.
 
Old 09-17-2007, 05:25 AM   #7
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
well i'm not sure to understand every question but i will start telling you what i can.

i'm using a debian distribution for amd64
linux version: 2.6.18-5-amd64

eth0: RealTek RTL8139
 
Old 09-17-2007, 05:38 AM   #8
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK, well let's see here.. First, I'll tell you that I am not using a Debian distro, so I can't be specific on what files you will be dealing with, if any, or where on your system they will be located. However, chances are, they are in the /etc folder somewhere.

In the root console, type 'ifconfig' by itself, and tell me if it shows your ethernet adapter (probably eth0) and if it is up and running. If not try typing ifconfig eth0_up. Does it work?

So, for the Realtek adapter: It is (perfectly?) supported by the kernel. I have a Realtek 8211 adapter, and the driver I use is called r8169 or r8139, and is in the kernel. Now, whether it's built into YOUR current kernel, I don't know.
In the root console, type 'lsmod' and see if you see a similarly named driver listed there. If so, great. If not, type 'modprobe r8169' or 'modprobe r8139' and let us know how that goes. Any errors? If there's no feedback, then it worked. The module should be inserted now.

OK, as I mentioned, I'm not totally sure how to go about configuring your Debian system, so you will need to do some research on your own to learn how and where to set up your ethernet adapter for DHCP and enable it if necessary (if it isnt already enabled by this point). Check your system menu for 'Internet Adapters' or 'Internet Connections' and go from there. Also, check any documentation for your Linux to learn what files are involved and where they are located.

Keep me posted, I'll help where I can.

If you cannot locate the driver for your device, it may not me compiled into your kernel (or as a module) though if you're running a stock kernel, I would think it would be, but who knows.. If it isn't, you'll hafta recompile the kernel to enable the driver for the Realtek device. Let's get to that later, if necessary.

EDIT: I get the impression from your post that the eth0 device IS active, or atleast is seen by the system. If so, it's a matter of configuring it for DHCP, so that it can get an IP from the modem and communicate with it. Again, check your documentation for something like 'Configuring DHCP' or similar.

Last edited by GrapefruiTgirl; 09-17-2007 at 05:41 AM.
 
Old 09-17-2007, 07:08 AM   #9
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
yes the eth0 is up and running
i typed modprobe r8169
and there was no feedback...
the ismod didn't work, doesn't find that command

and i think the dhcp adapter is enabled i did it my self in the
network administration tool menu (i'm doing a bit of direct translation here, my system is in french)
it says that the eth0 interface is active
it has a dhcp configuration...
 
Old 09-17-2007, 07:20 AM   #10
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
OK, 'lsmod' is with an L, not an 'I', as in 'LSMOD'

Anyhow, as the eth0 is up and active, we don't need to look at lsmod anyhow, because obviously the adapter's driver is already installed.

So, since DHCP is configured, and eth0 is up, it would appear that something very simple is preventing the modem from communicating.
What I would try (and this may not help, but I don't have much more to offer) would be to reset the modem using the procedure in the manual, and then disable the eth0 and re-enable it, by doing one of two methods:

1:

ifconfig eth0_down
ifconfig eth0_up

or , method 2, if your debian system uses rc init scripts and has a file such as /etc/rc.d/rc.inet1, would be to navigate to the folder /etc/rc.d and type:

./rc.inet1 restart

and then try to log into the modem again using the browser.

If this doesn't help, I'm sorry but with my limited knowledge of the Debian methods of doing things, I would more than likely lead you astray than help, if I suggest more stuff to try.
If you think I *can* help further, please feel free to post again. Meanwhile, I hope another user pops in with a new idea for you, or points to something obvious that we/I missed.

Bonne chance
 
Old 09-17-2007, 07:23 AM   #11
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
well thank you very much anyway
i'll try what you have just suggested

thanks :-D

avico
 
Old 09-17-2007, 07:29 AM   #12
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
http://forums.whirlpool.net.au/forum...fm/774821.html

Here's another thread on another forum, where a user appears to have had similar problems. They set up a gateway address and/or IP address for the eth0, as issued by the modem, and it fixed the problem.

Again, good luck
 
Old 09-17-2007, 07:30 AM   #13
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
ok..
intresting

trying to do
ifconfig eth0_down
it says that the perpheral is not found
 
Old 09-17-2007, 07:38 AM   #14
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
That's interesting.. I've never seen that message, but then, I'm using internal PCI modems, if that makes any difference.

As an afterthought, are you using the correct LAN cable, and have you had the modem work with any other OS, like Winblows or another Linux?

I think it's just a config issue with the eth0 device, but still, thought it would be worth mentioning the cable, just incase.
 
Old 09-17-2007, 07:41 AM   #15
avico83
LQ Newbie
 
Registered: Aug 2007
Posts: 9

Original Poster
Rep: Reputation: 0
i'm using the ethernet cable that came in the box with the modem...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
difficulties in modem instalation Agere systems PCI soft modem mcstanoye SUSE / openSUSE 2 02-01-2007 10:48 AM
installing z55i phone as usb modem or bluetooth modem in fedora manoharan Linux - Hardware 1 10-17-2006 06:42 PM
modem driver for Internal 56Kbps V.92 Data/Fax/Voice Modem sumathi Linux - Hardware 1 08-05-2005 04:12 AM
SUSE 9.2 detect my [B]ADSL USB-Ethernet Modem-Router [/B] as a [B]Dial up modem[/B]. myprecius Linux - Hardware 0 06-27-2005 09:21 AM
USR 56k ext modem in RH9/Gnome - finds wrong modem . . . . emuub Linux - Networking 1 10-22-2003 02:01 PM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration