LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2009, 10:39 PM   #1
guserx
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
Question How can I disable the nf_conntrack until after I boot?


I have installed Mepis 8 and have tried many things to get past a hitch in the boot script. To install the distro to my hard drive I had to remove my pci wireless adapter because it would hang at the nf_conntrack script. After installation I went to network manager and unchecked the "start at boot" box for the network and went to /etc/default/mepis-network script and inserted no in the script at the point of NDIS=(yes or no). I re-installed the card and booted with GRUB cheatcode nonet and/or nondis (thinking ndiswrapper might be in conflict with another module) it stopped again. I then tried using a pocket live cd to boot and tried getting the card to work, no problem, a few commands and it worked, but I didn't know how to save the settings to Mepis (still learning). I tried to re-boot, thinking maybe it got saved, nope, still hangs. I have learned that nf_commtrack is directly related to network usability and would be fine if I could get past it and boot.
Is there a way to initiate nf_commtrack at another time after the boot sequence so the card can be configured?? Or, can I use the other OS and configure the card and save it in the Mepis files?
Here is the puter hardware config:
HP vectra VL400 with a P3 1 GHz processor, 512 MB ram, 30 GB HD, Matrox dual head video card, USB pci card (to add more usb ports), and trying to use the SMC smcwpci-g wireless pci adapter with the Realtek RTL 8185 chipset.
 
Old 03-26-2009, 07:08 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,618

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
guserx:

Just wanted to help, though I am not familiar with mepis.

Is there a way to recompile your kernel omitting nf_commtrack daemon? Check Mepis documentation if this is possible, or maybe there is a way of switching it off at boot time. This is a distro specific issue and usually distro documentations have enough to solve this.

Sometimes disabling some unused bios sponsored devices will solve the problem. I recently came accross an issue with "bluetooth" that hangs the entire process after loading the hal daemon: mint, ubuntu and slackware none went past the obstacle, although "compatibility mode" can hurdle it, but I didn't want to run compatibility mode as normal; switching off some minor devices and drivers in the bios solved the problem.

Hope this gives a little hint.

Goodluck.
 
Old 03-27-2009, 07:31 PM   #3
guserx
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Original Poster
Rep: Reputation: 0
I have figured out the difficulty and repaired it. It seems there are two similar drivers for the wireless card that I have and were in conflict. I "blacklist"ed the driver not directly usable with my card and it booted. I later had trouble with connecting, but fixed that also. The computer operates fine now.

I want to thank you for your response, especially for the e-mail that was sent. I was during this process not receiving a lot of help and was beginning to get discouraged, so I'm very glad that you responded and even sent an e-mail in response.

For those that may run into this problem, the distro had ndiswrapper with the direct driver for the wireless card and it also had a similar (older model) driver. I basically disabled the (older driver) model and let ndiswrapper install the proper driver. This allowed the boot process to continue (this distro checks for network activity at boot).

The connection problem pertained to having an embedded ethernet port along with my added pci wireless card. The drivers were installed for both but the computer couldn't find which one was "active". I again disabled the driver for the ethernet connection and had wireless access.
 
Old 09-03-2009, 01:50 PM   #4
celiapgt
LQ Newbie
 
Registered: Jun 2004
Location: México DF
Distribution: suse, debian
Posts: 4

Rep: Reputation: 0
Thanks guserx for posting your problem and solution. It helped me booting and installing MEPIS to an old machine, very similar in components with yours (even the troublesome wireless card Realtek8185!). Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable x at boot? alabamaman Linux - Newbie 9 09-28-2007 05:44 PM
Increase nf_conntrack value c00kie Linux - Security 2 07-11-2007 03:54 AM
how to disable networking on boot arunvk Linux - Networking 3 03-10-2006 03:44 AM
how to disable appletalk at boot chemdawg Debian 1 10-10-2005 04:21 PM
disable ldconfig at boot? rgiggs Slackware 23 07-04-2004 04:45 PM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration