LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-27-2008, 03:33 PM   #1
Zerimas
Member
 
Registered: Mar 2005
Location: Canada
Distribution: Arch
Posts: 41

Rep: Reputation: 15
How can I adjust my permissions so that I can mount NTFS drives without the terminal?


I am running the current testing version of Debian, with GNOME as my desktop environment. How can I set it up so that I can mount my drives merely by clicking on the "mount" option in the "Computer" screen? Here's a picture so you can tel what I am talking about: http://img.photobucket.com/albums/v4...uterscreen.png Whenever I try to mount it by right-clicking and selecting mount, it tells me that I lack the permission to do so. How can I easily mount and access my Vista drives via this screen? Any help is appreciated.
 
Old 09-27-2008, 08:39 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I am not sure about this, but you might want to add the word user to the mount options listed for this partition in /etc/fstab. If you don't know what I am talking about, please post the contents of /etc/fstab. And be aware the before modifying a config file (such as /etc/fstab) it is always a good idea to back up the existing one to make sure you can always go back to where you were.
 
Old 09-27-2008, 11:43 PM   #3
Zerimas
Member
 
Registered: Mar 2005
Location: Canada
Distribution: Arch
Posts: 41

Original Poster
Rep: Reputation: 15
Here are the contents of my /etc/fstab file

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda7       /               ext3    errors=remount-ro 0       1
/dev/sda6       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
Here is the result of the command fdisk -l
Code:
Disk /dev/sda: 320.0 GB, 320072933376 bytes
16 heads, 63 sectors/track, 620181 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Disk identifier: 0x97646c29

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               3       20320    10240000   1c  Hidden W95 FAT32 (LBA)
/dev/sda2   *       20320      330409   156284928    7  HPFS/NTFS
/dev/sda3          330411      620180   146044080    f  W95 Ext'd (LBA)
/dev/sda5          330411      557766   114586620    7  HPFS/NTFS
/dev/sda6          617833      620180     1183360+  82  Linux swap / Solaris
/dev/sda7          557766      617831    30273201   83  Linux

Partition table entries are not in disk order
My Windows drives are /dev/sda2 and /dev/sda5.
 
Old 09-28-2008, 01:59 AM   #4
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I may have gone a bit further beyond my knowledge than I should have. I was expecting fstab to already have entries for these partitions, but I see it does not.

So what I am suggesting requires that you (as root) create a couple of directories:

Code:
mkdir /mnt/sda2
mkdir /mnt/sda5
and then add these lines to /etc/fstab:

Code:
/dev/sda2       /mnt/sda2       auto    noauto,user       0       0
/dev/sda5       /mnt/sda5       auto    noauto,user       0       0
This should allow any user to mount these partitions from the command line with commands like:

Code:
mount /dev/sda2
So I am hoping it will work in the GUI as well.

I was not sure the specification for the file system (3rd column) so I specified "auto" hoping the OS could figure it out. You might want to try the command line mount command I showed above just to make sure it can. When you've demonstrated it works that way, try it from the GUI.

I am not sure how permissions work for the NTFS file system (accessed from Linux). From what I've just seen while searching for info on this issue, it might work the same as as for FAT file systems. I am familiar with that. It may be necessary to add some more options in to get the access you want.

Another possibility would be to change fstab such that these partitions are automatically mounted at boot time. If you do that, I am pretty sure you will need some more options to allow users other than root to actually access the files.
 
  


Reply

Tags
debian


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount multiple ntfs drives help dzapffe19 Ubuntu 1 01-30-2007 01:48 PM
NTFS mount permissions azoghbi Linux - Newbie 3 10-31-2005 06:40 PM
How To Mount NTFS Drives in Linux 9 KnowledgeSeeker Linux - Software 3 09-23-2004 05:37 PM
Can't mount NTFS drives (yeah...I searched first) mandark Debian 4 04-07-2004 12:39 AM
Can't mount ntfs hard drives? justin9 Linux - Newbie 8 07-15-2003 12:02 AM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration