LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-25-2012, 09:24 AM   #1
Latman
LQ Newbie
 
Registered: Jun 2012
Posts: 15

Rep: Reputation: Disabled
hostid 00000000


Hi,

Just finished building my RHEL 6.1 server and trying to get sybase installed on it.
For some reason it keeps failing and I think it may have something to do with hostid.
When I type in hostid, I get 00000000. I've tried googling and was not able to find a solution to this.
Network seems to be functioning ok and it has the correct IP and MAC address.
Any ideas?
 
Old 06-25-2012, 10:26 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,576
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
One possibility is that the hostid did not initialise correctly during installation. If there is an /etc/hostid file you could try renaming it (so you can put it back if necessary) and running the hostid command which may re-create /etc/hostid.

Alternatively and more safely you could contact RHEL support and ask their advice.
 
Old 06-25-2012, 08:57 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Is this in a VM of some kind?
I've tried hostid on (non-vm) RHEL5 & 6 and received a sane answer both times.
 
Old 06-26-2012, 03:15 AM   #4
Latman
LQ Newbie
 
Registered: Jun 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
Is this in a VM of some kind?
I've tried hostid on (non-vm) RHEL5 & 6 and received a sane answer both times.
Yeap, it is a Hyper-V VM. Not sure if it is normal or not, but have opened a case with RedHat.
I will post back and let you know what they say.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to handle kernel NULL pointer dereference at virtual address 00000000 hallimanju Linux - Software 3 06-18-2010 03:14 AM
BUG: using smp_processor_id() in preemptible [00000000] code: Xorg/3366 shogun1234 Linux - Kernel 1 07-25-2009 05:45 AM
PCI: bios bug #[00000000] wtf? Knight Templar Linux - Laptop and Netbook 2 08-14-2007 07:30 PM
HostId nanlogan2 Linux - Software 1 10-23-2005 10:31 AM
hostid help bruse Linux - Networking 1 03-30-2005 02:53 AM


All times are GMT -5. The time now is 04:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration