LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 05-09-2004, 08:48 AM   #1
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 343

Rep: Reputation: 31
hostap boot problem


System:
Debian 3.0r2
kernel 2.4.25
2 Netgear MA311

I load hostap & hostap_pci in /etc/modules.
In /etc/network/interfaces i have these lines:

Code:
auto wlan0
iface wlan0 inet static
        address 10.19.141.75
        netmask 255.255.255.192
        network 10.19.141.64
        broadcast 10.19.141.127
        gateway 10.19.141.65
        wireless_mode managed
        wireless_essid APessid
When i boot the system wlan0 is still in "master mode" and doesnt connect to the AP

However, if these commands run at the end of the booting
Code:
iwconfig wlan0 mode managed
iwconfig wlan0 essid any
it connnects fine.

I think that hostap is being loaded after the ifs are up.
Is any way to check the boot sequence or to load hostap sooner?

/var/log/messages , /var/log/syslog and /var/log/debug doesnt show any errors!

--- edit ---
Anyone can move it to Wireless Networking?
sorry

Last edited by JJX; 05-09-2004 at 09:29 AM.
 
Old 05-09-2004, 03:14 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php

If you would like a thread moved then please use the "Report this post to a moderator" link beside your post.

The other thread is:
http://www.linuxquestions.org/questi...hreadid=179605
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HostAP problem geden Linux - Wireless Networking 2 06-20-2005 08:45 PM
Fedora Core 1, SMC 2532W-B, HostAP problem gatechguy2003 Linux - Wireless Networking 3 09-21-2004 05:33 AM
wlan-ng to HostAP fsck3r Linux - Wireless Networking 0 07-17-2004 02:19 AM
hostap boot problem JJX Linux - Wireless Networking 3 05-10-2004 04:02 PM
hostap drivers toships Linux - Newbie 0 02-28-2004 08:05 PM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration