LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2013, 02:52 PM   #1
Arun Kurian
LQ Newbie
 
Registered: Oct 2013
Posts: 23

Rep: Reputation: Disabled
Ho to remove epel-release-6-8.noarch


How do I remove epel-release-6-8.noarch from the Cent OS? I just wanted to remove the epel to execute a script. Currently when I execute the script it is saying that package epel-release-6-8.noarch is already installed,so I guess if we remove it.
 
Old 12-21-2013, 02:59 PM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Code:
yum remove epel-release
Maybe the correct way is to check if it's already installed in the script itself and eventually skip the installation step:
Code:
if ! rpm -q --quiet epel-release
then
  <install epel-release>
else
  <do nothing>
fi
 
Old 12-21-2013, 03:04 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,989

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
you can disable the epel repo with the --disablerepo=epel

what did you install from epel ?
if you uninstall the repo without first uninstalling the rpm's you installed from epel you will have problems !

also is "yum-priorities-plugin" installed ?
it REALLY is NEEDED if you install third party software repos

see the centos wiki page
http://wiki.centos.org/AdditionalResources/Repositories
and the page for the plugin
http://wiki.centos.org/PackageManagement/Yum/Priorities


also please post this ?unknown? "script" you are trying to run
 
Old 12-21-2013, 06:40 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If you know that epel is already installed, why don't you disable the test in the script that checks for it? Or will the script not work c orrectly if epel-release is installed? I can't imagine why this would be, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Remove password centos release 4.4 andermar05 Linux - Kernel 1 10-27-2012 01:48 PM
Public key for rpmfusion-nonfree-release-11-1.noarch.rpm is not installed manuleka Linux - Newbie 1 06-10-2009 07:19 AM
Public key for rpmfusion-free-release-11-1.noarch.rpm is not installed toys19 Linux - Software 10 06-03-2009 12:39 PM
fedora-release-7-3.noarch.rpm ??? mickeyboa Fedora 2 12-16-2007 01:23 PM
How to remove glibc-i18n-2.3.2-noarch-1 urbansound Slackware 3 06-10-2004 11:24 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration