LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2002, 10:53 AM   #1
jingoglia
LQ Newbie
 
Registered: Dec 2002
Posts: 1

Rep: Reputation: 0
HLDS problems


I'm trying to run a HL ded server, i have redhat 7.3 running. when i try to ./hlds -game ns +maxplayers 12 +map ns_nancy

i get this error `libhlwon.so: cannot open shared object file: No such file or directory`

if i try and run ./hlds -game ns w/o the max players and map, the server tries to start but craps out with this msg

LoadLibrary failed on /usr/hlds_l/ns/dlls/ns_i386.so: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory
Host_Error: Couldn't get DLL API from /usr/hlds_l/ns/dlls/ns_i386.so!
FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /usr/hlds_l/ns/dlls/ns_i386.so!

BTW i tried both ./hlds and ./hlds_run both do the same thing
Any ideas?
 
Old 01-17-2003, 11:46 AM   #2
tnine9
Member
 
Registered: Jan 2003
Posts: 39

Rep: Reputation: 15
Angry Same problem

I am also having the same problem. I am using Debian. I did not have this problem the first time I installed the dedicated server. However, with my installation on the 2nd machine, it will not work. Both configuration are EXACTLY the same! This leads me to believe that there is a problem with the file that was downloaded, or the installation process. I am currently working to find the solution and I will notify you ASAP when I have done so.
 
Old 01-06-2004, 08:03 PM   #3
kleinishere
LQ Newbie
 
Registered: Jan 2004
Posts: 1

Rep: Reputation: 0
i run mandrake 9.1 and this is how i solved it

as root go to /etc/ld.so.conf
add a line of the address to your hlds_l directory
ex: /home/hlds/hlds_l/
as root run ldconfig, a common binary, just type it in
you should be set to go
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HLDS Problems xgsniper Linux - Games 3 12-06-2005 07:55 PM
HLDS with CS extremebfn Linux - Games 1 09-20-2004 01:13 PM
Problems with steam (hlds) OnionKnight Linux - Software 4 03-28-2004 11:58 AM
hlds problems on redhat Food_slayer Linux - Software 4 08-03-2003 04:46 PM
HLDS binary execute problems on RH 7.3 Steev Linux - Newbie 1 03-13-2003 09:20 AM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration