LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-03-2011, 02:38 PM   #1
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Rep: Reputation: 2
History feature not working on ubuntu 10.10 notebook edition terminal


Hello everyone:


I noticed a few days ago, that history feature is not working on my ubuntu 10.10 notebook edition terminal.
I mean I enter a bunch of commands today and then shut down.
Come back again tomorrow and turn on the machine and open the terminal, but up and down arrows won't bring any old commands that I used today.

I would appreciate some help to enable that feature on my ubuntu 10.10 notebook.



mansour
 
Old 04-03-2011, 02:40 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
If you just type a few commands in a terminal, close it by typing exit (or
pressing Ctrl-D), start a new one ... do you see your commands in the
history? What is your shell?


Cheers,
Tink
 
Old 04-03-2011, 02:58 PM   #3
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
If you just type a few commands in a terminal, close it by typing exit (or
pressing Ctrl-D), start a new one ... do you see your commands in the
history? What is your shell?


Cheers,
Tink

Hello:

I see this result:


mansour@ubuntu-notebook:~$history
1 history
mansour@ubuntu-notebook:~$


it is bash for mansour user, as listed in /etc/passwd file.


mansour
 
Old 04-03-2011, 04:26 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
And what does
env | grep HIST
tell you? What terminal emulation are you using?

Last edited by Tinkster; 04-03-2011 at 04:32 PM.
 
Old 04-03-2011, 04:42 PM   #5
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
And what does
env | grep HIST
tell you? What terminal emulation are you using?



mansour@ubuntu-notebook:~$ env | grep HIST
mansour@ubuntu-notebook:~$

What terminal emulation are you using?
I am not sure what terminal emulation I am using, unless the above command would tell me, which it didn't.




mansour
 
Old 04-03-2011, 04:52 PM   #6
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
And what does
env | grep HIST
tell you? What terminal emulation are you using?
env command tells me my TERM is xterm



mansour
 
Old 04-03-2011, 04:54 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
No, that only pertains to bash, and your bash doesn't have
any history settings, which may have to do with either
a) your terminal, b) your login manager or c) your desktop.



Do you have ~/.bash_{login,profile} and/or ~/.bashrc ?
If so, what's their respective content?


Cheers,
Tink

Last edited by Tinkster; 04-03-2011 at 04:56 PM.
 
Old 04-03-2011, 04:58 PM   #8
2ck
Member
 
Registered: Mar 2010
Location: /home/twock
Distribution: Debian
Posts: 70
Blog Entries: 9

Rep: Reputation: 21
Set the HISTFILE environment variable to ~/.bash_history and read the bash man page under the heading, HISTORY.
 
Old 04-03-2011, 04:59 PM   #9
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
No, that only pertains to bash, and your bash doesn't have
any history settings, which may have to do with either
a) your terminal, b) your login manager or c) your desktop.



Do you have ~/.bash_{login,profile} and/or ~/.bashrc ?
If so, what's their respective content?


Cheers,
Tink


Yes, I have a ~/.bashrc file, but the ~/.bash_{login,profile} is empty.


mansour
 
Old 04-03-2011, 05:14 PM   #10
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
[QUOTE=mansour;4312676]Yes, I have a ~/.bashrc file, but the ~/.bash_{login,profile} is empty.


This is the content of .bashrc file


Code:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi



mansour
 
Old 04-03-2011, 05:17 PM   #11
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
No, that only pertains to bash, and your bash doesn't have
any history settings, which may have to do with either
a) your terminal, b) your login manager or c) your desktop.



Do you have ~/.bash_{login,profile} and/or ~/.bashrc ?
If so, what's their respective content?


Cheers,
Tink


Yes, I have a ~/.bashrc file, but the ~/.bash_{login,profile} is empty.


This is the content of .bashrc file:


# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
else
color_prompt=
fi
fi

if [ "$color_prompt" = yes ]; then
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
;;
*)
;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'

alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands. Use like so:
# sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
. /etc/bash_completion
fi


sorry for the messing up.

mansour

Last edited by mansour; 04-03-2011 at 05:28 PM.
 
Old 04-03-2011, 05:21 PM   #12
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by 2ck View Post
Set the HISTFILE environment variable to ~/.bash_history and read the bash man page under the heading, HISTORY.

How would I "Set the HISTFILE environment variable to ~/.bash_history"?
Please be more specific. what is the command to do that?


mansour
 
Old 04-03-2011, 06:04 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally Posted by mansour View Post
Yes, I have a ~/.bashrc file, but the ~/.bash_{login,profile} is empty.


mansour
Just to make sure:

you do understand that that's two potential files to look at, one
~/.bash_login and/or ~/.bash_profile ? Not one file with a name
w/ curly braces in it.

If you really don't have either of those, create ~/.bash_login
and put something like
Code:
if [ -f ~/.bashrc ]; then
  . ~/bashrc
fi
in it.

You don't want to set ANY values in ~/.bash_history, that's really
just a file in which bash will write back your actual history for
persistent storage.



Cheers,
Tink
 
Old 04-03-2011, 06:15 PM   #14
mansour
Member
 
Registered: Nov 2010
Location: Toronto, Canada
Distribution: Ubuntu 10.04 Lucid Lynx - Ubuntu 10.10 notebook - Debian 5.08 - Win XP
Posts: 172

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by Tinkster View Post
Just to make sure:

you do understand that that's two potential files to look at, one
~/.bash_login and/or ~/.bash_profile ? Not one file with a name
w/ curly braces in it.

If you really don't have either of those, create ~/.bash_login
and put something like
Code:
if [ -f ~/.bashrc ]; then
  . ~/bashrc
fi
in it.

You don't want to set ANY values in ~/.bash_history, that's really
just a file in which bash will write back your actual history for
persistent storage.



Cheers,
Tink

Thank you for clarifying. I actually thought it was one file.
OK, So I created ~/.bash_login like this:

Code:
if [ -f ~/.bashrc ]; then
   ~/.bashrc
fi
Do I need to do chmod xyz bashrc and if yes what should those xyz values be?


mansour

Last edited by mansour; 04-03-2011 at 06:16 PM.
 
Old 04-03-2011, 06:43 PM   #15
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally Posted by mansour View Post
Thank you for clarifying. I actually thought it was one file.
OK, So I created ~/.bash_login like this:
No worries; I sometimes find myself using shell semantics w/o making
sure people know what I'm talking about.

Quote:
Originally Posted by mansour View Post
Code:
if [ -f ~/.bashrc ]; then
   ~/.bashrc
fi
Do I need to do chmod xyz bashrc and if yes what should those xyz values be?


mansour
You shouldn't have to. You will, however, most likely have
to log out and back in to make the change take.


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lupu511 pupsave feature apparently is shutting down my notebook to often Benny7440 Linux - Newbie 2 10-16-2010 02:10 PM
Working at the command line with Ubuntu Server edition. David_R Linux - Server 1 06-30-2010 08:02 AM
LXer: A Brief History of Brown: Ubuntu Feature Timeline LXer Syndicated Linux News 0 03-18-2010 01:00 AM
Implement a Unix Shell with History Feature vipin_jss Linux - Newbie 2 05-07-2009 08:38 PM
soundblaster live 24bit edition not working in ubuntu wormraper Ubuntu 2 08-10-2005 07:01 PM


All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration