LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2014, 01:19 AM   #1
soyiuz
LQ Newbie
 
Registered: Jul 2014
Posts: 1

Rep: Reputation: Disabled
Question hibernate / suspend problems


Problem: Fn-F4 function key not hibernating (resets the internet connection instead)
Symptoms: pm-hibernate and pm-suspend just reset the connection. hibernate works as does s2both
Setup: Lenovo X230, updated Debian testing, 3.14 kernel, i3 wm, lightdm, xfce4-power-manager

On Lenovos, Fn-F4 is a special function key which is supposed to hibernate the machine (moon symbol). Since pm-hibernate is not working, the idea was to change the handler to s2both. I cannot find the script responsible for handling the key press though. Other system keys work as expected (volume, mute, etc).

Things I've tried:

- Catching XF86Sleep or XF86WakeUp in .i3/config (my window manager config file). This file is handling some of the other special buttons like XF86AudioRaiseVolume. Variations on bindsym XF86Sleep exec "hibernate". No effect.
- Switching out the backend for pm by adding SLEEP_MODULE=uswsusp in /etc/pm/config.d/module. No effect.
- Modyfying etc/acpi/sleep_suspend.sh to use hibernate or s2both. No effect.
- Poking around xfce4-power-manager setting gui. Nothing here.

Can someone please explain who is handling the power options here? ACPI? xfce4-power-manager? What is the relationship between these? What happens when I press Fn-F4? Who is handling the key press and how do I change / fix it? What is the best practice for handling suspends / hibernates gracefully?

Any help is appreciated--I am out of ideas after a few hours and still very much learning about Linux / Debian architecture.
 
Old 07-08-2014, 02:07 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,429
Blog Entries: 6

Rep: Reputation: Disabled
Hi & Welcome to Linux Questions.

What distribution you are running?

Is this your Lenovo?
http://www.notebookcheck.net/Lenovo-...w.75317.0.html

I am not the expert with the ACPI stuff but I've dealt with some of the acpi stuff in the past.

***It might be possible to disable the sleep or hibernate in the BIOS but I suggest you wait for a experienced member for that.***

Looking at the XFCE Power Manager on my system I see that the line for suspend and hibernation say's:
"When hibernate button is pressed a drop down menu opens and there are 4 options.
nothing, suspend, hibernate or ask Try setting it to nothing.

The same options are available for the sleep button:-

Advanced Configuration and Power Interface provides a standard for device configuration and power management.
Like the fan on your motherboard for example at start up is part of the ACPI stuff.

XFCE Power Management manages the power sources on the pc and the devices that can be controlled to reduce
power consumption ie LCD brightness level, monitor, sleep and CPU frequency scaling.
It provides the interface which allows applications to prevent automatic sleep actions via the Power Manager.

Hope that helps.
 
Old 07-08-2014, 03:11 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,845

Rep: Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823
ATI video card by any chance ?.
My hibernation has remained broken since 3.14 on F20 - I can get suspend to work by appending "radeon.dpm=0" to the kernel boot parms. I've made it the default for now, and given up on hibernation.
 
Old 07-08-2014, 06:56 AM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
Quote:
Originally Posted by soyiuz View Post
Problem: Fn-F4 function key not hibernating
On Lenovos, Fn-F4 is a special function key which is supposed to hibernate the machine (moon symbol).
Since you are using Debian, the reason is probably F1-4 open a TTY. Looking at my Lenovo, I see the moon symbol you mentioned, but on this machine and my previous Lenovo, those F keys function according to Debian's configuration. F1 opens a standard TTY, F2 logs out of the x-session and into a CLI, etc. My guess is changing the behaviour would require some re-configuration.

I do not have an idea what the suspend problem is. Having a minimal installation, I use pm-suspend all the time, without a problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problems with resume from both suspend and hibernate bebabi34 Slackware 4 11-19-2013 04:20 AM
[SOLVED] Suspend and hibernate linuxbird Slackware 6 12-19-2012 07:53 AM
[SOLVED] Can't suspend or hibernate 0zMe Slackware 5 06-27-2010 02:43 PM
problems with Suspend, hibernate, and switch user marozsas Linux - Hardware 1 03-29-2010 10:55 AM
Suspend / hibernate problems in FC5 cdhgee Fedora 2 04-11-2006 09:32 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration