LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2014, 12:55 AM   #16
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649

The command that you want is:
just to view
Quote:
cat /etc/inittab
or to edit
Quote:
nano /etc/inittab
 
Old 06-12-2014, 02:02 AM   #17
xam200
LQ Newbie
 
Registered: May 2014
Posts: 28

Original Poster
Rep: Reputation: Disabled
Mr Eddy1, thanks for your input. Unfortunately, i just get "Command Not Found" when I use this: cat /etc/inittab or nano /etc/inittab

Steven
 
Old 06-12-2014, 03:09 AM   #18
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by xam200 View Post
Mr Eddy1, thanks for your input. Unfortunately, i just get "Command Not Found" when I use this: cat /etc/inittab or nano /etc/inittab

Steven
Those commands are supposed to be run as root or you can use sudo
Code:
sudocat /etc/inittab
			 				sudo nano /etc/inittab
 
Old 06-12-2014, 11:02 AM   #19
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
"How should I be loading this inside of Terminal window? Thank you!"

You don't have to be root to look at /etc/initab. Open /etc/initab in a text editor.


----------------------------
Steve Stites
 
Old 06-12-2014, 07:00 PM   #20
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,845
Blog Entries: 7

Rep: Reputation: Disabled
If you want to see the /etc/inittab file run this in your termianl.
If you want to change the runlevel wait for our Guru to tell you how to edit that.

Code:
cat /etc/inittab
 
Old 06-12-2014, 08:17 PM   #21
xam200
LQ Newbie
 
Registered: May 2014
Posts: 28

Original Poster
Rep: Reputation: Disabled
Gentlemen, in searching other areas of this forum, I found the following remarks that may explain why I keep getting the "Command Not Found" response.

"Ubuntu no longer uses init as the script for starting the systems, they have replaced it with an event driven system called upstart. So inittab which was the configuration file for init is no longer needed. As for runlevels, that was a concept used by init, so it's not really relevant anymore for Ubuntu."

If Zorin is closely related to Ubuntu, maybe there's another command that I can use?

Steven
 
Old 06-12-2014, 09:59 PM   #22
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,845
Blog Entries: 7

Rep: Reputation: Disabled
Zorin is based on Debian and Ubuntu.

The only command line utility that I am aware of (elevated privileges as "root") for Ubuntu is "sudo"
Debian uses "su"

If you want to know for certain what Zorin OS was built on you can run this command and it will appear in the output what distribution Zorin is really based on.

Code:
cat /etc/os-release
What command plus the argument, are you running that is returning 'command not found'?
 
Old 06-12-2014, 10:16 PM   #23
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , ChromeOS
Posts: 4,921
Blog Entries: 19

Rep: Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138Reputation: 2138
Yeah, above post is a good place to start. Find out what Ubuntu version is going on.

Then I would do a

Code:
cd /etc
Hit enter

then do a a

Code:
ls
just enter and copy and paste back what is in there in code tags in next post.

To be double sure to post all info. I would post also what is in Zorins /etc/sudoers text file also.

Code:
sudo cat /etc/sudoers
type in password at the prompt and hit enter key.

Post back sudoers file contents to show what has access to what like /usr/bin, /usr/local/bin,......

This is a weird thread for rebooting when it should shut down . Sounds almost like a corrupted Iso download and install and bugs are showing up using that kind of reasoning.

Edit: the only other reason I can think of for a reboot issue is a bad bios setting maybe? The reason I mention this is a computer I dug out of the trash pile had a bios setting that would boot after a certain amount of down time after being turned off.

Last edited by rokytnji; 06-12-2014 at 10:27 PM.
 
Old 06-13-2014, 12:57 AM   #24
xam200
LQ Newbie
 
Registered: May 2014
Posts: 28

Original Poster
Rep: Reputation: Disabled
Gentlemen, I apologize if I got us off track. What I'm hoping to do here is to review (and correct, if necessary) the inittab table.

When I enter: sudocat /etc/inittab, I get the following: sudocat: command not found.

If I enter sudo cat /etc/inittab, I get the following: cat: /etc/inittab: No such file or directory.

If I enter cat /etc/inittab I get the following: cat: /etc/inittab: No such file or directory.

Any suggestions? Thank you.
 
Old 06-13-2014, 10:20 AM   #25
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,990

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
There is no inittab file in Ubuntu and since Zorin is a mofification of Ubuntu, I would suggest you look for the file indicated below and change the line below in this file. Replacing N with the number you want. You can google to see what the different runlevels are:

You can edit /etc/init/rc-sysinit.conf
and change the following line:

env DEFAULT_RUNLEVEL=N

Last edited by yancek; 06-13-2014 at 10:22 AM.
 
Old 06-13-2014, 04:18 PM   #26
xam200
LQ Newbie
 
Registered: May 2014
Posts: 28

Original Poster
Rep: Reputation: Disabled
Mr Yancek, after changing this code, how do I update and save it?

Thank you.

Steven
 
Old 06-13-2014, 05:01 PM   #27
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,990

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
I'm not sure what default text editor Zorin uses. You could try: sudo gedit /etc/init/rc-sysinit.conf
You will be prompted for your user password, enter it and hit the Enter key and make the change then click on the Save tab at the top and reboot.
 
Old 06-18-2014, 01:22 PM   #28
BobMontgomery
LQ Newbie
 
Registered: Jun 2014
Posts: 1

Rep: Reputation: Disabled
I have installed Zorin 6 and Zorin 8, (all versions of 8) without any problems on three different computers, and older IBM Thinkpad, a newer HP, and a Dell Optiplex 740. On the laptop I replaced Windows XP. On the others, I did a dual boot with Windows 7 on the HP, and Windows Vista on the Dell. The two running desktop computers had Windows installed first. After that, I simply did a boot up with the Zorin DVD, and chose the install along side the Windows system. After the installation, a menu comes up with both systems listed and I simply pick the one I want. Windows for some games, and Zorin for everything else. I hope it works out for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cent OS server restarts automatically, Not sure why. linuxlover.chaitanya Linux - Newbie 5 05-09-2012 09:26 PM
OC4J instance restarts automatically after 10 seconds. nishith AIX 3 01-03-2010 04:53 AM
System restarts automatically banskt Linux - Hardware 7 06-26-2009 11:24 AM
Shut down automatically sholah Linux - Server 2 06-04-2009 03:41 AM
Can't get the computer to shut off automatically KezzerDrix Mandriva 12 03-30-2005 09:07 AM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration