LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2002, 04:24 AM   #1
fin
LQ Newbie
 
Registered: Dec 2001
Location: MoorLands UK
Distribution: Red Hat 7.3
Posts: 27

Rep: Reputation: 15
Question Help with Wu-ftpd on RH 7.2 please


Hi All,

Please can some help me set up Wu-ftpd on RH 7.2. I have been to their website
and
read the Docs & FAQs. All I can find out is that when it has been install onto
RH 7.2 its not started, you have edit a file in /ect/xinetd.d/ftp, at the top
of this file it says the following:

# default: on
# description: The wu-ftpd FTP server serves FTP connections. It uses # normal, unencrypted usernames and passwords for authentication.
service ftp

If I remove the # from the top line and save the file, will this start the ftpd
server ?

Also if the server starts ok does it make new files to be configured ?

How do I name the server i.e. "ftp.btinternet.com" or on my home lan
ftp.192.168.0.2 (the box IP)

And would the upload folder be in /var/www/html where I can find the default Apache index page ?

I have found a KDE FTPD editor called "Kwuftpd" installed, but the manual its
not very clear how to setup the ftpd for the first time.

Thanks Rich
 
Old 04-16-2002, 10:52 AM   #2
fatgod
Member
 
Registered: Mar 2002
Location: Edinburgh, Scotland
Distribution: Suse 7.2, Gentoo 1.4, Solaris 9
Posts: 661

Rep: Reputation: 30
I've setup wuftpd on suse before so there might be some minor differences... Anyway,
First enter the following into /ect/inetd.conf
  • ftp stream tcp nowait root /usr/sbin/tcpd wu.ftpd-2.6 -a
make sure that the filename is right. then restart inetd and try 'ftp localhost' from a shell. You wont be able to login yet but you should get a connection.
After that you need to config access. the file you need to mod is /ect/ftpaccess. try man ftpaccess for all the config options and info that you'll need.
 
Old 04-16-2002, 11:46 AM   #3
fin
LQ Newbie
 
Registered: Dec 2001
Location: MoorLands UK
Distribution: Red Hat 7.3
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by fatgod
I've setup wuftpd on suse before so there might be some minor differences... Anyway,
First enter the following into /ect/inetd.conf
  • ftp stream tcp nowait root /usr/sbin/tcpd wu.ftpd-2.6 -a
make sure that the filename is right. then restart inetd and try 'ftp localhost' from a shell. You wont be able to login yet but you should get a connection.
After that you need to config access. the file you need to mod is /ect/ftpaccess. try man ftpaccess for all the config options and info that you'll need.
Hi fatgod,

thanks for your reply, I didn't alter that file as you said just went to shell and tried ftp localhost it ask for a user name & password so its running ok. So now I am going to setup user name & password.

Thanks for your help

Rich
 
Old 04-16-2002, 03:29 PM   #4
fin
LQ Newbie
 
Registered: Dec 2001
Location: MoorLands UK
Distribution: Red Hat 7.3
Posts: 27

Original Poster
Rep: Reputation: 15
Question for fatgod

Hi fatgod,

when you installed Wu-ftpd, did you read the doc's/howto's that were installed with Wu-ftpd ? if so can you answer me this ?

The working example here will be as if it were a directory under a Web
tree, /home/web. The Web account will be maintained remotely by FTP.
The remote user is Mortimer. Mortimer's account name is "mort", group
"client".

Ok if this is a howto/example file, in RH 7.2 the tree directory for web is the following: /var/www

is that where the web page are going to up loaded for the user Mortimer ?

if it is, should I change the web directory tree to suit my needs ?

Thanks Rich
 
Old 04-16-2002, 04:52 PM   #5
fatgod
Member
 
Registered: Mar 2002
Location: Edinburgh, Scotland
Distribution: Suse 7.2, Gentoo 1.4, Solaris 9
Posts: 661

Rep: Reputation: 30
Yo fin :)

I'm assuming that the user mort is a user who will be using ftp solely to admin his web pages on the server, yes? I'm not sure where your users http files will be kept, but apache on my sys would keep them in /usr/local/httpd...

So I would create a user 'mort' in the group 'client' on the system and set his entry in /etc/passwd to something like this...
  • mort:x:600:92:Client Webmin:/usr/local/httpd/mort/:/etc/ftponly
Anything like this will do, just setup the user as you normally would and make his home directory /usr/local/httpd/mort and change the /bin/bash entry to /ect/ftponly so he cant get access to the machine by any other means.

and set this line in /etc/ftpaccess
  • guestgroup client

this will chroot the user to /usr/local/httpd/mort (so he is here but will not be able to move to a higher dir. ie he will see / only)

You will need to specify upload permission in the ftpaccess file as well as this is disabled by default (on more recent versions anyway) This is explained as are all the options (you'll want to setup some more options) in the ftpaccess man page.

Luck!
 
Old 04-16-2002, 06:00 PM   #6
defed
LQ Newbie
 
Registered: Mar 2002
Location: Australia
Distribution: RedHat
Posts: 3

Rep: Reputation: 0
Seeing that you are using RH you should check out



http://www.redhat.com/support/resour...up-Tips-4.html



The above site has all the information and links that you need to get up and running.



defed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FTPD default permissions (wu-ftpd) bd1308 Linux - Software 1 10-22-2005 07:01 AM
Disabling Kerberos ftpd for wu-ftpd mortisd Linux - Software 0 08-31-2004 06:37 AM
wu-ftpd jakublgz Linux - Networking 3 04-12-2002 03:33 PM
wu-ftpd hommih Linux - Networking 0 02-06-2002 08:06 PM
P-FTPD or W-FTPD bripage Linux - Networking 1 01-31-2002 11:55 AM


All times are GMT -5. The time now is 01:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration