LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-07-2005, 07:50 PM   #16
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73

The crash happened to me as well, so I ended up compiling the latest version of kaffeine from source. It seems like kaffeine doesn't know which dirve you are using for your dvd. You can configure this by running kaffeine -> settings -> xine engine parameters -> media. There are devices listed there just change the one for the dvd player (dvd.device) to the one you are using e.g. mine is /dev/dvd2.
 
Old 08-07-2005, 07:55 PM   #17
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
Right now it has /dev/dvd listed. How do I know which one I'm using? I haven't done any mounting yet. I know there's a /media/cdrom but when I try to go to /dev/dvd or /dev/cdrom it says that does not exist.
 
Old 08-07-2005, 07:58 PM   #18
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally posted by treble54
Right now it has /dev/dvd listed. How do I know which one I'm using? I haven't done any mounting yet. I know there's a /media/cdrom but when I try to go to /dev/dvd or /dev/cdrom it says that does not exist.
Do the following
Code:
$cat /etc/fstab
Copy and paste the result so that I can take a look at it.
 
Old 08-07-2005, 08:01 PM   #19
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
/dev/sda7 / reiserfs acl,user_xattr 1 1
/dev/sda2 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda3 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda5 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda6 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
 
Old 08-07-2005, 08:09 PM   #20
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Ok, try doing the following as root
Code:
#ln -s /dev/cdrom /dev/dvd
Once thats done, start kaffeine and try playing a dvd.
 
Old 08-07-2005, 08:20 PM   #21
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
Ok, I typed that in a shell, hit enter, and it immidiately brought me to a clean prompt. Nothing was spit out after I hit enter.

I started up Kaffeine and got this Installation wizard with one of the subheadings being:

"DVD Drive...
Can't check DMA mode. Permission denied or no such device: "/dev/dvd"."

Might this be a problem?

I went back and did the command you gave me earlier: cat /etc/fstab. The entire shell screen looks like this:

# ln -s /dev/cdrom /dev/dvd
# cat /etc/fstab
/dev/sda7 / reiserfs acl,user_xattr 1 1
/dev/sda2 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda3 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda5 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda6 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
#
 
Old 08-07-2005, 08:24 PM   #22
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Ok, try changing /dev/dvd to /dev/cdrom in the xine engine settings in kaffeine. If that doesn't solve the problem do "ls -l /dev/cdrom" and post the output.
 
Old 08-07-2005, 08:30 PM   #23
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
Well that did something a little different this time. It actually made the DVD drive spin the DVD finally. Unfortunately, I still got those two stupid errors again that I've mentioned before that were also in the guide given in the second post of this thread. I inputted what you asked into a shell and got this as output:

# ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 Aug 5 19:01 /dev/cdrom -> sr0

Not sure what that means but so far, thanks for putting up with me this entire time! I really appreciate it.
 
Old 08-07-2005, 08:42 PM   #24
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try doing as root, "chmod a+r sr0. If libdvdcss is installed, you really shouldn't be getting the second error. I am off to bed, but post back so that I know if its worked or not.
 
Old 08-07-2005, 08:47 PM   #25
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
Here's what printed out:

# chmod a+r sr0
chmod: cannot access `sr0': No such file or directory
 
Old 08-07-2005, 09:10 PM   #26
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try "chmod a+r /dev/sr0"
 
Old 08-07-2005, 09:12 PM   #27
pbhj
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware 12; Ubuntu 7.10
Posts: 358

Rep: Reputation: 31
Question /dev/sr0

Shouldn't that have been /dev/sr0, ie the first SCSI device (?)

Thus, that's (as root / superuser) "chmod a+r /dev/sr0"

This will change the mode (chmod) to make the device (/dev/sr0) read-able (+r) by all users (a) ... if the device is re-writable you may as well try "a+rw". Also, cdrecord has an option "cdrecord -scanbus" which scans for all CD type devices and returns their locations.

HTH
 
Old 08-07-2005, 09:20 PM   #28
treble54
Member
 
Registered: Apr 2004
Distribution: SuSE 9.3
Posts: 49

Original Poster
Rep: Reputation: 15
And after a long, grueling trek to play a DVD on my linux-bound laptop, we've succeeded! Woo hoo! Thanks a lot guys. I really appreciate it. Now, the next thing on the list is getting the audio to function correctly. It appears I have some audio but the sound is horrible. I'll have to work on that later as I am rather tired myself. Thanks a bunch for all the help you guys have contributed .

-- treble54
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Watching DVDs cuscus1986 Linux - Newbie 16 03-17-2005 10:31 AM
DISCUSSION: Using Logwatch and Watching DVDs jeremy LinuxAnswers Discussion 0 07-27-2004 11:03 PM
Watching DVDs idris1388 Slackware 11 04-05-2004 01:57 PM
Problems watching new DVDs (like The Matrix Reloaded) tuxedo-notebook Linux - Software 4 01-25-2004 12:38 AM
Monochrome output when watching DVDs vasudevadas Linux - General 1 10-11-2003 01:39 PM


All times are GMT -5. The time now is 09:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration