LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2011, 02:32 PM   #1
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Rep: Reputation: Disabled
Help with transferring files with vsFTPd on Debian linux


So I downloaded vsftpd; created users; changed the config file to allow users to write; and I still can't figure out how to transfer files. I put a txt file in the home directory but cannot seem to get it. I also cannot write. Any hints?
 
Old 10-11-2011, 02:37 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Welcome to LQ!!!

1. How you can say that you are unable to write?

2. Do you get any error message?

3. How you are trying to upload to FTP server? I usually upload to FTP using mput.

4. Paste your vsftpd config file.
 
Old 10-11-2011, 03:10 PM   #3
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
I tried adding a file to the directory "put [file extension]" with the Error 550 permission denied.




# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone? vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Disabled by default)
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# If enabled, vsftpd will display directory listings with the time
# in your local time zone. The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
use_localtime=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Oh hai there Tsunami!!!
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories. See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=NO
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# Debian customization
#
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default. These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd/empty
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.rsa_cert_file=/etc/ssl/private/vsftpd.pem

---------- Post added 10-11-11 at 04:11 PM ----------

Sorry about the late reply, I got sidetracked with a different issue.
 
Old 10-11-2011, 03:17 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

That is because you have not enabled write option to your FTP. Your vsftpd config file read as follows:

#write_enable=YES

Write option is commented out. Make it as follows:

write_enable=YES

Restart vsftpd services and then try to write.

I hope this helps.
 
Old 10-11-2011, 03:47 PM   #5
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
Ok, now I have a different error. 553 could not create file.

I typed: put /root/Desktop/filename.txt /home/ftp-docs/newfile.txt
came up with an error
 
Old 10-11-2011, 03:51 PM   #6
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
Did I misunderstand the syntax?
 
Old 10-11-2011, 03:59 PM   #7
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Appears to be selinux issue now.

Do you have selinux running on this system. Type the following command to check:

Code:
sestatus
If yes, then paste the output of the following command:

Code:
getsebool -a | grep ftp
You can try disabling selinux if that is not an issue for you.
 
Old 10-11-2011, 04:08 PM   #8
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
It says sestatus is not installed. I'm running Backtrack 5, whatever is default. I'm new to linux, I don't know what selinux is.
 
Old 10-11-2011, 04:13 PM   #9
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Alright. Tell me exactly how you are trying to upload the file to ftp. Step by step please.

As you said that you are a newbie I would suggest you to use user friendly distro like Linux Mint or Ubuntu. Backtrack 5 is a distro for advanced users.

selinux is security enhanced linux which controls the security on the basis of defined booleans.
 
Old 10-11-2011, 04:21 PM   #10
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
ftp> put /root/Desktop/masterlist.txt /home/ftp-docs/new003.txt
local: /root/Desktop/masterlist.txt remote: /home/ftp-docs/new003.txt
421 Timeout.
ftp> exit
root@bt:~# sestatus
The program 'sestatus' is currently not installed. You can install it by typing:
apt-get install policycoreutils
You will have to enable theUsing: command not found

I am using BackTrack for a class that I'm taking. I started with Ubuntu but was thrust into this OS. This is pasted from my terminal. The error isn't the same but it was the third time I tried it.
 
Old 10-11-2011, 04:29 PM   #11
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Alright. Here are the suggestions:

1. Make sure that the user with which you are logged in to ftp have rights to write to the following location: /home/ftp-docs/

2. Login to ftp.

3. Type the following command lcd /root/Desktop/

4. Then type the following command: cd /home/ftp-docs/

5. Upload the file using the following command: mput masterlist.txt /home/ftp-docs/

Let me know the output/error message if you get any.
 
Old 10-11-2011, 04:33 PM   #12
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
root@bt:~# ftp 192.168.1.152
Connected to 192.168.1.152.
220 (vsFTPd 2.2.2)
Name (192.168.1.152:root): Megan_Ryan
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> lcd /root/Desktop/
Local directory now /root/Desktop
ftp> cd /home/ftp-docs/
250 Directory successfully changed.
ftp> mput masterlist.txt /home/ftp-docs/
mput masterlist.txt?
200 PORT command successful. Consider using PASV.
553 Could not create file.
mput /home/ftp-docs/?
 
Old 10-11-2011, 04:39 PM   #13
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

It appears that Megan_Ryan does not have write permission to /home/ftp-docs. Run the following command and then give it a try:

Code:
chmod -R 777 /home/ftp-docs
and then try to upload the file via ftp.
 
1 members found this post helpful.
Old 10-11-2011, 04:52 PM   #14
B00Mshesaid
Member
 
Registered: Oct 2011
Distribution: Debian
Posts: 31

Original Poster
Rep: Reputation: Disabled
That worked! Thank you so much. I hate to be a pain but, how would you go about retrieving a file from that folder? Would it be:

cd /home/ftp-docs/
mget masterlist.txt

?
 
Old 10-11-2011, 04:58 PM   #15
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Quote:
cd /home/ftp-docs/
lcd /root/Desktop
mget masterlist.txt
Yup, thats the way. I have added lcd /root/Desktop line so that we are aware where it will going to download the file.

Please mark the thread as solved if you think that the issue has been resolved.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transferring Files from Linux to Windows bigmac15 Linux - Newbie 8 06-14-2011 09:23 PM
transferring files to from Windows machine to Linux bbb125 Linux - Newbie 21 08-17-2010 06:51 AM
Transferring files from Linux onto Windows paragkalra Linux - Networking 1 08-08-2008 03:56 AM
Transferring files/folder into Linux from Windows XP environment sheenawee Linux - General 1 01-25-2006 12:19 PM
Transferring Files from linux to windows on floppys? rverlander Linux - General 6 06-23-2002 12:45 AM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration