LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2014, 06:56 AM   #1
snowkitty
Member
 
Registered: Feb 2014
Distribution: kubuntu
Posts: 43

Rep: Reputation: Disabled
Help with setting up: On screen keyboard for login KDE/LightDM.


I'm using KDE4, which uses LightDM for the login screen on Kubuntu. There's no options to enable one from the KDE System Settings. Due to issues with my video card, I sometimes have to restart my x-server. When I do this, my keyboard becomes disabled till I log in (from gnome15 drivers for my logitech keyboard), causing me to have to plug in another nearby keyboard, or reboot and allow auto-login to take me to desktop, since auto-login doesn't work when you restart X.

How can I setup an on screen keyboard to allow me to virtually type in my password?

I'm quite surprised I found no useful results on google for this question as I don't think it's an unusual feature.
 
Old 09-20-2014, 01:23 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Is this a touchscreen?
https://wiki.ubuntu.com/Touchscreen
 
Old 09-20-2014, 08:49 AM   #3
snowkitty
Member
 
Registered: Feb 2014
Distribution: kubuntu
Posts: 43

Original Poster
Rep: Reputation: Disabled
No, it's a desktop system that has the keyboard disabled at login if I restart X as described in first post.
 
Old 09-27-2014, 10:28 PM   #4
milindlokde
Member
 
Registered: Apr 2007
Location: Mumbai, India
Distribution: Fedora, ubuntu
Posts: 121

Rep: Reputation: 21
answered on askubuntu and bugs.launchpad.net

With newer versions of lightdm (1.5.1?) there is a commented out line in thelightdm-gtk-greeter.conf file. The option at login is shown if you insertkeyboard=whatever_to_start.

Example for onboard:

[greeter] keyboard=onboard

see patch:https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/905809
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to run greeter/login script with lightdm Larry James Ubuntu 1 12-27-2013 10:54 AM
Messed up lightdm login screen background rng Linux - General 0 03-12-2013 05:44 PM
LXer: Simple LightDM Manager: Change The LightDM Background Or Logo Using A GUI LXer Syndicated Linux News 0 10-05-2011 06:41 PM
KDE login screen keyboard layout Julkku Linux - Software 0 03-28-2005 06:21 AM
Change Fedora Login Screen to KDE login screen ada601 Linux - Software 2 08-15-2004 06:07 PM


All times are GMT -5. The time now is 05:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration