LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2005, 09:08 AM   #1
GNUROCKS
Member
 
Registered: Jan 2005
Distribution: Fedora Core 3
Posts: 68

Rep: Reputation: 15
Help with resolution


so heres the scoop, I have a inspirion 8500, the native resolution is 1280x800, now, i have edited my /etc/X11/xorg.conf file and added the resolution. But it doesnt show up in my system settings/desktop in gnome or kde. the highest resolution I can get is 1024x768, after that the display says it is changed, but the screen hasnt changed, ive been scratching my head for a while on this one, any ideas? Please help, you guys are great.
 
Old 06-14-2005, 09:20 AM   #2
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
Can you post your xorg.conf file?
 
Old 06-14-2005, 09:46 AM   #3
GNUROCKS
Member
 
Registered: Jan 2005
Distribution: Fedora Core 3
Posts: 68

Original Poster
Rep: Reputation: 15
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x800"
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon Mobility M9"
Option "IgnoreEDID" "true"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 07-06-2005, 04:31 PM   #4
keflavich
LQ Newbie
 
Registered: Aug 2004
Location: Colorado
Distribution: FC5/6, Ubuntu Edgy
Posts: 9

Rep: Reputation: 0
I've had a similar problem, and would love an answer... My xorg.conf file has plenty of resolution modes
Code:
    Subsection "Display"
        Depth       24
        Modes "1280x1024" "1152x864"  "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
but the KDE resizer thing only shows up to 1024x768. Any tips would be greatly appreciated... linux is nearly unusable at this resolution for my purposes.
 
Old 07-06-2005, 09:08 PM   #5
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 86
Quote:
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Have you researched your monitor's manufacturer's website to see if these are the proper horizontal and vertical ranges for your monitor?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 04:16 AM
Text Resolution, Graphic resolution. Change from prompt dlublink SUSE / openSUSE 2 01-28-2005 12:50 PM
[resolution 1600 x 1200] Virtual resolution - help! MaicoMedia Linux - Hardware 2 10-15-2004 04:15 AM
seeking a resolution to my resolution troubles! kinbote Linux - General 3 05-11-2004 04:18 PM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration