LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-12-2004, 11:35 PM   #1
Dickey Peterson
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat 8
Posts: 7

Rep: Reputation: 0
Help with playing audio CD...


I've finally got system sound working. I can now play mp3's with xmms, too. I can't play audio cd's though. I've searched the forum and tried some of the following suggestions with the indeicated results.

1. install rpm xmms-cdread-0.8a-1.i386.rpm using 'rpm -ivh xmms-...' can't find the newly installed rpm in xmms preferences, it isn't there.

2. make myself part of the audio group usermod -g audio 'user'. I get the following message "bash: usermod: command not found"

I read something about changing ownership of the cdrom, but couldn't follw. I read that 'arts' is generally bad, so used OSS mixer. The cd won't play when it auto-plays in the Gnome CD player, either.

Should I install mplayer instead of worry about xmms, or will I just have the same problems. Please be very specific as I'm still really new to Linux

I'm running RH 8.0. Oh, and I can play cd's no problem in win xp.
 
Old 01-13-2004, 12:13 AM   #2
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Rep: Reputation: 15
What exactly happens when "the cd won't play when it auto-plays in the Gnome CD player" - Does it look like its playing, but no sound comes out? or does it give an error message?

Does the CD Audio Player plugin show up in XMMS in Options->Preferences->Audio i/o plugins?

If so, click on "configure" and try changing the play mode from analog to digital extraction.
 
Old 01-13-2004, 04:31 AM   #3
strsst
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware 9.0
Posts: 12

Rep: Reputation: 0
You might try to verify if the path to the CDROM is correct...
I'm running Slackware 9.0 and my cdrom drive was installed on /dev/hdb, not /dev/cdrom. I checked in xmms and found that the Device text box said /dev/cdrom. I changed it to /dev/hdb and it worked like a champ, even downloaded the song titles from cddb just like winamp!
To check it, open xmms.
Go to Options --> Preferences. A dialog box will appear.
Be sure CD Audio... is highlighted and click Configure.
The Device tab should be selected. Check the Device setting. If it isn't set to where your cdrom drive is pointed to, change it. You may also need to change the directory setting, but I didn't. It was correct. It will probably be correct on your system as well.
 
Old 01-13-2004, 04:58 AM   #4
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Two common problems with audio CDs, have no idea if they apply in your case, are:

No wire from back of CDROM drive to sound card - should be a 4 or 2 thread wire.

CD should not be mounted.

 
Old 01-13-2004, 06:44 AM   #5
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 212

Rep: Reputation: 30
I had the same problem to play audio cd's with XMMS under my normal user account, even though I could play them when logged in as root. To solve the problem, make yourself a member of the cd-rom group. I don't know how you would do that with Red Hat - I used the User Manager utility in KDE to do it.

Added on 01-16-2004: I reinstalled Debian (it's a long story...) and once again experienced the silent audio cd problem with my user account, even after adding myself to the audio and cdrom groups. Turns out that I also had to belong to the disk group... Now it works

Last edited by Joe Soap; 01-16-2004 at 02:44 PM.
 
Old 01-13-2004, 09:04 AM   #6
Dickey Peterson
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat 8
Posts: 7

Original Poster
Rep: Reputation: 0
I'll try these...

Thanks for the quick response, great suggestions, I'll give these things a try and post my results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
playing audio cd 5.1 alizta Linux - General 2 10-25-2004 03:20 AM
playing an audio CD malbery Debian 10 08-23-2004 12:53 PM
Playing an Audio CD natesch Linux - Newbie 15 08-31-2003 04:30 PM
Playing an audio CD fredws Linux - General 2 03-18-2003 03:56 PM
Audio CD not playing Relja Linux - General 6 01-22-2003 05:31 AM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration