LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help with installing canon printer (http://www.linuxquestions.org/questions/linux-newbie-8/help-with-installing-canon-printer-882448/)

bexus 05-24-2011 08:56 AM

help with installing canon printer
 
I have a acer aspire one netbook with linux linpus lite. (no cd drive) I am trying to get my printer working with my net book, it is a canon pixma mp270. i have looked all over the web and i am getting very confused what to do, i am new to linux and to be honest new to computers so i am looking for a very kind person to hopefully give me a step by step walk through on how to install it. i have tried installing it but on the printer configuration my model of canon is not registered in the list mp270 and when i try and use it with any other one it just sits at idle status. please help me (

DavidMcCann 05-24-2011 10:37 AM

Linpus is a terrible implementation of Linux, and too old to include the MP270 driver. You can download one from here:
http://gamblis.com/2011/05/17/downlo...ers-for-linux/
Get the RPM version.

bexus 05-24-2011 11:52 AM

hi thanks for getting back to me, i clicked on the link you gave me and the rpm version and it taked me to something called "xarchiver" and i really dont know what to do after this. i really do apologise im not that computer literate. i have never used linux before i just got a really good deal on a little netbook from acer and linpus comes with it. if you could give me maybe step by step of what to do with this xarchiver i would be very greatfull

bexus 05-24-2011 12:12 PM

okay so i clicked on extract but then a message appears saying 2 an error occurred accessing the archive" "do you want to view the command line output"??? is there any other way i can get this printer working?

markush 05-24-2011 01:27 PM

Hello bexus,

as DavidMcCann stated Linpus is not a fullfeatured Linux-distribution.
I'd recommend to take a look at another distribution and consider to install for example Ubuntu, the installation is explained here: http://www.ubuntu.com/download in great detail. Also Mint may be a choice for you: http://www.linuxmint.com/

With on of these distributions it will be no problem to install your printer.

Markus

bexus 05-24-2011 01:31 PM

would ubuntu be the best one? i seem to get the feeling that i am so close to getting it to work as well cause i finally managed to get the netbook to recognise the printer but when i try to print something the printer status is idle

bexus 05-24-2011 01:34 PM

unfortunately this is still not helping me, again trying to download ubuntu it takes me to xarchiver and i am not confident enough to know what to do with any of this

markush 05-24-2011 01:37 PM

Well, Ubuntu is known as a good choice for newbies. The problem is that noone installs Linpus on his computer, Linpus is only available preinstalled on computers (instead of Windows) because it is cheaper than Windows.
I don't know which software Linpus is running for printing, most distributions nowadays use cups. If cups is installed and running, you may open a browser (e.g. firefox) and open the adress
Code:

http://localhost:631
which is the webinterface of cups where you can configure your printer. It is necessary to configure the users who are permitted to print.

Markus

markush 05-24-2011 01:42 PM

How about the computer where you are writing your posts? is it a fedora machine (which says the icon at your posts)? maybe it is possible to download the isofile there and make create a bootable USB-device as explained here: http://www.ubuntu.com/download/ubuntu/download

Markus

DavidMcCann 05-25-2011 05:59 PM

I think the original poster's problem is what to do with the driver when downloaded. I'm not too sure where to look myself, never having needed to install a driver. In Fedora I have some printer stuff in /usr/share/foomatic/db/source/PPD/ but nothing with the name of my actual printer!


All times are GMT -5. The time now is 11:32 PM.