LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2006, 07:45 AM   #1
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Rep: Reputation: 15
help with fstab can't write to second hdd


The 'H" word
Using Fedora Core 5
I have tried and read the fstab to bits!!
I have understood and read a lot I have had no trouble doing it
I have added a second hard ide drive augementing a scsi and a cdrom
in FC3 FC4 previous.. and also mounting a vfat partition....but
I still can't get user write access to this mounted drive.
The whole drive is formatted with a ext3fs
here's my line

/dev/hdc1 /home/name/namexx/ ext3 user,noauto,dev,exec,rw 0 0
no errors on bootup
and as I look in the dir I still see the no write acces to the mounted
folder and the permission is owned by root.
what sort of silliness am I doing ..THANKYOU in advance

albert the dunce
 
Old 07-19-2006, 07:55 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Umm well an option umask=022 that I usually use with usb flash disk/mp3 players makes the mounted filesystem be available for all users read&write..but is it what you want?
 
Old 07-19-2006, 08:53 AM   #3
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 37
Quote:
Originally Posted by albertBeach
/dev/hdc1 /home/name/namexx/ ext3 user,noauto,dev,exec,rw 0 0
Change the above to:
Code:
/dev/hdc1  /home/name/namexx/   ext3   user,noauto,defaults 0 0
I had weird results when my root partition was mounted with the exec option. Try the above and see if it helps.
 
Old 07-20-2006, 02:17 AM   #4
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks a million for your help guys!
b0uncer and Zmyrgel
It works! I tried the 'defaults' option one first
and it worked first time.. I hadn't tried the umask one yet but will do!
cheers again

albertbeach
 
Old 07-20-2006, 03:16 AM   #5
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Original Poster
Rep: Reputation: 15
fstab problems

Need some more help ?
My return posting of success with this problem was premature.
My exitement re using the different fstab lines for
having user write permissions on extra mounted hard drive were short lived.
It seems when I rebooted again still don't have access to write
to mounted drive.
Still no closer to solution.

albertloosingItbeach .
 
Old 07-20-2006, 07:27 AM   #6
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
What do you have in the drive, if nothing? If your fstab file is ok, then have you set the permissions correctly on the filesystem (i.e. if it's ext3, then do you have write access to the root of the filesystem)?

Code:
/dev/hdc1  /home/name/namexx/   ext3   user,noauto,rw,umask=022 0 0
The above fstab line should work as far as I understand. Well I'm not sure about the umask=022 option since I've only used that for flash disks which use fat filesystem..but even without it it should work.
 
Old 07-20-2006, 08:03 AM   #7
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Original Poster
Rep: Reputation: 15
Hi
Thanks b0uncer..
I have pasted what I have and still the same
rayeng@Boolean ~]$ cat /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/hdc1 /home/name/namexx ext3 user,noauto,rw,umask=022 0 0


[rayeng@Boolean namexx]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
automount(pid2242) on /net type autofs (rw,fd=4,pgrp=2242,minproto=2,maxproto=4)
/dev/hdc1 on /home/name/namexx type ext3 (rw)

[rayeng@Boolean namexx]$ ls -l
total 16
drwx------ 2 root root 16384 Jul 18 21:26 lost+found
still no write .. I'll keep searching

albertbeach
 
Old 07-20-2006, 09:34 AM   #8
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 37
Check the mount point which permissions it has.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
write permissions in /etc/fstab for vfat filesystem btb Linux - Newbie 5 10-24-2005 02:37 PM
[SuSE fstab] No write access pEeDy Linux - Newbie 7 10-11-2005 03:58 AM
fstab problems with second ext3 HDD movintocali Fedora 3 10-22-2004 04:37 AM
What should I write in my /etc/fstab chutsu Slackware 3 09-27-2004 09:01 AM
fstab DOS write noir911 *BSD 5 08-06-2004 12:23 PM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration