LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help with error compiling gtk+-2.4.0 (http://www.linuxquestions.org/questions/linux-newbie-8/help-with-error-compiling-gtk-2-4-0-a-171109/)

Metal Martian 04-16-2004 07:22 PM

help with error compiling gtk+-2.4.0
 
OK so I think I've sorted out a mountain of dependecies but when I make gtk+-2.4.0 I get this:

/home/mayhem/gtk+-2.4.0/gdk/.libs/libgdk-x11-2.0.so: undefined reference to `g_unsetenv'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_type_instance_get_private'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_completion_complete_utf8'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_param_spec_get_redirect_target'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_object_class_override_property'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_type_class_add_private'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_object_interface_install_property'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_markup_printf_escaped'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_value_take_string'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_markup_vprintf_escaped'
/usr/local/lib/libpango-1.0.so: undefined reference to `g_unichar_get_mirror_char'
collect2: ld returned 1 exit status
make[4]: *** [gtk-query-immodules-2.0] Error 1
make[4]: Leaving directory `/home/mayhem/gtk+-2.4.0/gtk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/mayhem/gtk+-2.4.0/gtk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/mayhem/gtk+-2.4.0/gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mayhem/gtk+-2.4.0'
make: *** [all] Error 2

Does anyone know what this could mean all these undefined references?

Thanks for any help

MM

ps sorry I guess this should be in the sofware forum

Komakino 04-16-2004 07:28 PM

it looks like you don't have the correct version of glib installed. As you're installing gtk+ 2.4 have you already installed glib 2.4 and atk (1.6 I think?)?

Metal Martian 04-16-2004 07:40 PM

yes I have those installed as the configure script wouldn't run without them

MM

yaumm 05-11-2004 09:04 AM

I have the same problem during the gtk compilation (2.4 and 2.2.3)...

If you have solve it, can you say how ?

thanks for your help...

Yaumm


All times are GMT -5. The time now is 01:17 PM.