LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-23-2009, 04:37 AM   #1
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Rep: Reputation: 0
Help With Display Resolution


Greetings.

I am very new to Linux and am puzzled by a problem I've encountered. I have run several distros of Ubuntu (dual booted with XP) on my Dell laptop without difficulty. I recently acquired a P4 Gateway box that I would like to dual boot with Ubuntu and XP as well. The machine boots to the Ubuntu CD fine, and I select "install". As it begins the installation process, I get an error message: "Cannot Display Video Mode" (I can get to console by pressing Ctrl Alt F1, but have no idea what, if anything, to do once there). If I press F4 prior to selecting "install", and choose "Safe Graphics Mode", the installation proceeds without problems. Once installed, Ubuntu doesn't seem to recognize my graphics chip. The only screen resolution available under "Display" is 800x600, refresh rate of 61 and a big pink box saying: "Unknown Display". I've tried all the fixes I can find and nothing seems to help.

Oddly enough, I booted the machine from my Knoppix 5.1 Live CD and it works like a charm! No errors during boot, and there are several resolutions available under "Display", including 1024x768, which is what I want to use.

Does anyone have any ideas....fixes for this problem....other distros of Linux (Gnome) that might work? I've tried Ubuntu distros, 8.04, 8.10 and 9.04. I'm considering 9.10 RC just for kicks. I'm also considering a cheap nvidia graphics card to see if that solves the problem.

The machine in question is a Gateway e4500d with a 3.0 ghz P4. The video chip is an Integrated Intel Graphics Media Accelerator 950 (82945G/GZ).

Thanks!!
 
Old 10-23-2009, 05:11 AM   #2
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Rep: Reputation: 29
anectine17, as much as I know, Intel graphics should work really well...
If you say that Knoppix works well, that may seem that simply the guys from Ubuntu have forgotten to include your drivers in the kernel image.
Well, if I was you, I would strip off the kernel, and afterwards build one that would be suited especially for your machine.
Try to use this tutorial:
http://www.cromwell-intl.com/unix/linux-kernel.html
 
Old 10-23-2009, 05:45 AM   #3
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for your reply. The problem seems to be a known bug since I've found several references to it on the net. I've tried all the solutions suggested to no avail.

Regarding building a new kernel....I'm very new to Linux and that task is WAY above my current level. Thanks again.
 
Old 10-23-2009, 06:37 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
You might be lucky with the following easy fix:

Run the Knoppix CD and check the contents of /etc/X11/xorg.conf If there's anything useful in there, copy the file to somewhere on your HD (e.g. your home-directory in the Ubuntu installation). Useful means that it does NOT say 'configured video device' in the device section and similar in the monitor and screen section. Those should look similar to the ones below.

Code:
Section "Device"
    Identifier     "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Driver         "nvidia"
EndSection
Code:
Section "Monitor"
    Identifier     "Generic Monitor"
    Option         "DPMS"
EndSection
Code:
Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200" "1680x1050" "1440x900" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection
Next boot Ubuntu (or whichever distro is installed). After login, check if the file /etc/X11/xorg.conf exists. Next open a terminal and issue the following commands (the first one can be skipped if /etc/X11/xorg.conf does not exists)
Code:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo cp yourknoppixfile /etc/X11/xorg.conf
Restart the xserver by pressing <ctrl><alt><backspace> and if that does not work <alt><printscreen>k and check if it fixed the problem.

If it does not work:
Which version do you currently have installed?
Does the file /etc/X11/xorg.conf exists?
What the contents of that file if it exists? In this case we're specifically interested in the sections device, screen and monitor that I posted earlier.
What is the make and model of the monitor.

PS
If the above seems to completely buggers up your system, don't panic.
Boot to single user / recovery mode and either copy the old xorg.conf back ( cp /etc/X11/xorg.conf.old /etc/X11/xorg.conf ) if it existed before or delete the current one ( rm /etc/X11/xorg.conf ) if it did not exist.

Last edited by Wim Sturkenboom; 10-23-2009 at 07:30 AM. Reason: Added PS
 
Old 10-23-2009, 06:47 PM   #5
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the reply. I looked and the Knoppix xorg file does have much more "useful" information than does the Ubuntu xorg file (I installed Ubuntu 9.10 and didn't have the "Cannot Display Video Mode" message on install, but still only have 800x600 resolution). I believe I can copy the Knoppix file to the Ubuntu install (after backing up my Ubuntu file), however I noticed something that may make a difference. Knoppix is using the xorg i810 driver and Ubuntu is using the xorg i740 driver. Is there an easy way to import/download/install the xorg i810 driver to Ubuntu? If so, how? Remember, I'm a NEWBIE so I need pretty detailed instructions. Thanks again!!

Alden
 
Old 10-23-2009, 10:28 PM   #6
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Wim Sturkenboom View Post
You might be lucky with the following easy fix:

Run the Knoppix CD and check the contents of /etc/X11/xorg.conf If there's anything useful in there, copy the file to somewhere on your HD (e.g. your home-directory in the Ubuntu installation). Useful means that it does NOT say 'configured video device' in the device section and similar in the monitor and screen section. Those should look similar to the ones below.

Code:
Section "Device"
    Identifier     "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Driver         "nvidia"
EndSection
Code:
Section "Monitor"
    Identifier     "Generic Monitor"
    Option         "DPMS"
EndSection
Code:
Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200" "1680x1050" "1440x900" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection
Next boot Ubuntu (or whichever distro is installed). After login, check if the file /etc/X11/xorg.conf exists. Next open a terminal and issue the following commands (the first one can be skipped if /etc/X11/xorg.conf does not exists)
Code:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo cp yourknoppixfile /etc/X11/xorg.conf
Restart the xserver by pressing <ctrl><alt><backspace> and if that does not work <alt><printscreen>k and check if it fixed the problem.

If it does not work:
Which version do you currently have installed?
Does the file /etc/X11/xorg.conf exists?
What the contents of that file if it exists? In this case we're specifically interested in the sections device, screen and monitor that I posted earlier.
What is the make and model of the monitor.

PS
If the above seems to completely buggers up your system, don't panic.
Boot to single user / recovery mode and either copy the old xorg.conf back ( cp /etc/X11/xorg.conf.old /etc/X11/xorg.conf ) if it existed before or delete the current one ( rm /etc/X11/xorg.conf ) if it did not exist.
OK, I'm trying to copy the xorg.conf file from Knoppix so I can replace the Ubuntu xorg.conf file with it. Where do I copy it to and how? I've tried copying it to my USB jump drive and I get a message saying that I can't copy to that media as it is read only. I've tried the same thing to other partitions on the C:/ drive with the same result. HELP!!
 
Old 10-23-2009, 11:47 PM   #7
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
OK...I managed to copy the Knoppix xorg.conf file to /etc/X11 in Ubuntu. There was no xorg.conf file in Ubuntu by default. I tried Ctrl-Alt-Backspace to restart the xserver....that didn't work, but Alt-PrntScreen-K did. It completely hosed the Ubuntu install. I can't even get into Recovery Mode. No big deal...I'll just reinstall. I'm not sure what I'm going to reinstall at this point. I may wait until payday and get a cheap nvidia video card and then reinstall Ubuntu 9.04. Are there other Linux distros I might try? I specifically want the Gnome desktop. Thanks again for everyone's help.

Alden
 
Old 10-24-2009, 12:08 AM   #8
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I can't help you with the read-only. Memory stick should work (unless formatted as NTFS), HD might be because of NTFS filesystem.

In Ubuntu, you can edit the xorg.conf to try to solve the issue

Code:
Section "Device"
    Identifier     "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Driver         "nvidia"
EndSection
I have some questions
Does your Ubuntu have /etc/X11/xorg.conf? If so, does it contain a device section as shown above. If so, change or add the driver line that I marked in bold. If one of the above is not true, let me know

The first thing that you can try is to make the driver i810 (replace nvidia in the example) by i810 and restart X.
If that does not work, make it vesa and restart X

You need root permissions to edit the file so you need (gk)sudo in front of the edit command (e.g. gksudo gedit /etc/X11/xorg.conf)


PS
I'm old-school when it comes to the video and therefore only know the hard way. There might be a tool that does this but I don't know that from the head.
 
Old 10-24-2009, 12:39 AM   #9
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Sorry to hear that. The changes to xorg.conf can not influence recovery mode as X is not used in recovery mode (unless Ubuntu has changed). So something went seriously wrong somewhere.

Ubuntu 9.04 is known to have some video issues with the Intel video driver in combination with certain Intel video chips (jerky video) but I thought that it should be solved with the new driver in 9.10 Maybe that driver has another bug that is now giving you troubles (incorrect detection).

I would try 8.04 if you want to give Ubuntu another shot. I'm not sure which distros use Gnome. You can check http://distrowatch.com, for each distro they give the 'specs'
 
Old 10-24-2009, 12:53 AM   #10
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the reply. I tried to get to recovery mode and it locked up. I didn't keep trying because reinstallation isn't a big deal. I've tried Ubuntu 8.04, 8.10, 9.04 and 9.10RC. It's just weird that Knoppix renders the video just fine. I wish I knew how to upgrade the driver in Ubuntu from i740 to i810. Specifically, step by step instructions.

I'm learning Linux but it's a process. I figured out that I had to mount my USB drive and run a chown on it so I could copy the xorg.conf file to it. I also realized that I was having trouble because I wasn't in root....duh.

I'm downloading Opensuse at the moment. I'll see if that works...if not, I'll probably just get an nvidia video card on payday. Thanks again.

Alden
 
Old 10-24-2009, 03:44 AM   #11
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Rep: Reputation: 29
anectine17, the problem is not in the videocard, but in the way the system uses it.
You could try "X -configure" so that it would configure your xorg.conf file. I've forgotten that the new systems use HAL for automatic hardware recognition. So usually, after you configured xorg.conf, you could turn off hardware recognition for X, by inserting in the "ServerLayout" section the line
Code:
 Option "AutoAddDevices" "false"
 
Old 10-24-2009, 01:59 PM   #12
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Problem solved with openSuse installation. It even gave me an option during installation to choose my screen resolution. So far I like this distro....will just have to learn my way around it. Thanks for everyone's input.

Alden
 
Old 11-12-2009, 03:05 AM   #13
anectine17
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
An interesting update on this issue. The problem turned out to be the MONITOR and not the video controller or driver. I was using a Dell E153FPf flat panel monitor and it kept showing as not recognized (with Ubuntu, Fedora, Mint)and only offered a resolution of 800x600. Even with OpenSuse, it was not recognized, but it did offer the proper resolution of 1024x768. In a space-saving move, I let my daughter use the Dell flat panel and I used her HUGE, old CRT monitor. Well, in OpenSuse, I noticed that the monitor was now recognized, so I booted to an Ubuntu 9.10 CD and the CRT monitor was recognized and it offered a ton of resolution and refresh rate options. So I then uninstalled OpenSuse and installed Ubuntu and it works great!! Glad I finally figured it out!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Display resolution badri.india Linux - Newbie 5 01-14-2009 08:06 AM
Display resolution sheine Linux - Software 1 06-28-2007 10:08 AM
display resolution help saiz66 Slackware 10 10-20-2005 11:08 PM
display resolution dhlawrence Linux - General 2 09-16-2005 07:27 PM
display resolution Jenifer Linux - Newbie 4 04-23-2001 10:24 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration