LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-08-2004, 07:27 PM   #1
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Rep: Reputation: 30
help with ./configure of gtk+2.4.9


when i go to type ./configure for gtk+2.4.9, i get this error

lib-2.0 >= 2.4.0' but version of GLib is 2.2.3

configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
mark@user379:~/bin/gtk+-2.4.9>



what do i do?
 
Old 11-08-2004, 09:28 PM   #2
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
First of all, if you are avearge user or joe user not technical one, you should not install big and complicated package like GTK+ by compiling source. Install them by yast or yum or apt-get or whatever tool that can determine dependencies correctly.

If you are technical one, install glib 2.4 ( because your version is 2.2 ).

You can get it here from:
ftp://ftp.gtk.org/pub/gtk/v2.4/

Dont forget to read this:
http://developer.gnome.org/doc/API/2...-building.html
 
Old 11-08-2004, 11:01 PM   #3
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
i have glib-2.4.7 installed...
 
Old 11-09-2004, 07:51 AM   #4
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
Ok, what distro are you using? My guess is you have glib 2.2 installed default then you upgrade your glib to 2.4 version but you install it in non standard prefix. Non standard prefix is /usr/local. Standard prefix is /usr.

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/ur/glib/install/directory
 
Old 11-09-2004, 07:56 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
you need to install the -devel rpms to compile software that uses libraries installed by rpm. Suse 9.1 will install gtk2 by default, so i'd guess that the reason you are trying to install gtk2 from source is that another source application says it can't find *that* either. gtk2-devel-2.4.7.rpm or something should be on your suse cd's.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure can't find gtk+ ELconkestador Linux - Software 6 10-24-2005 07:01 PM
gtk ./configure error invinciblegod Linux - General 7 07-24-2005 02:09 AM
./configure gtk error or3st3s Mandriva 2 08-14-2004 01:21 PM
gtk+-2.2.3 configure error. eye Linux - Software 7 11-20-2003 08:21 AM
can't configure GTK!-gtk-gnutella ogkyusa Linux - Software 2 08-09-2003 04:38 PM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration