LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2005, 04:11 PM   #1
truckman
LQ Newbie
 
Registered: Apr 2005
Posts: 3

Rep: Reputation: 0
Unhappy help with changing rclocal


I finally got my Broadcom wireless card to work on my HP pavilion ze570 laptop after a couple weeks of hacking and tracking! I am using Fedora core 3.

To get everything up and running I have to enter as root the following:

# modprobe ndiswrapper
# dhclient

I added these lines into a script file I called “wireup.” Then I did:
# chmod 755 wireup

I want this to happen at startup, and as far as I can gather, somehow I need to update my rclocal file. Don't know how? Please do not assume I have a clue. Thanks.
 
Old 04-09-2005, 04:16 PM   #2
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
I'm not familiar with the init scripts for FC as I use slack, but somewhere under /etc/rc.d/ there is a file called rc.local. Your best bet would simply be to go to the bottom of that file and add the two lines to that file instead. Use an editor like gedit or kate to edit the lines (as root)
 
Old 04-09-2005, 04:27 PM   #3
truckman
LQ Newbie
 
Registered: Apr 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Tried that, but it came up as a read only buffer and would not let me add anything.
 
Old 04-09-2005, 04:49 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by truckman
Tried that, but it came up as a read only buffer and would not let me add anything.
As root? The file is probably write-protected, but as root you can change that. In a terminal (xterm, konsole etc) go to where the file is:

cd /path/to/the/file
then
chmod u+w rc.local

edit the file then, as above, only:

chmod u-w rc.local


If you can use vi (or gvim?) then open it using:

gvim /path/to/the/file

press i for insert mode and escape to get out of insert mode, then:
:w!q

will force save and quit (if you do it this way you don't need to do all that chmod stuff above)
 
Old 04-10-2005, 05:37 PM   #5
truckman
LQ Newbie
 
Registered: Apr 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry it took so long to try your last suggestion: IT WORKED! Thanks for your help, you saved me a lot of time banging my head against the wall.

Truckman
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 06:10 PM
Changing WM wellington Linux - Software 3 02-09-2005 02:40 PM
changing IP trolsbane Linux - Security 10 12-23-2004 02:05 PM
Changing BG in VC Krao Linux - General 0 09-03-2004 12:13 PM
Changing Hd rilians Linux - General 9 10-16-2003 12:16 PM


All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration