LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2003, 07:03 PM   #16
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45

Hi Damian

Go to Console

type

SU
Then type your Root password

then type

KEDIT /etc/lilo.conf

then scan down to the botom

Definately make sure those 2 duplicate entries are not there - they shouldn't be - they dont refer to anything - the image = lines dont even specify a Boot image so get rid of them.


image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

Make sure they're not there and save your KEDIT file

then as root user again try running

/sbin/lilo
 
Old 07-24-2003, 07:17 PM   #17
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for that. It's late now, so I'll try that tomorrow morning, and post the results then.
 
Old 07-25-2003, 06:16 AM   #18
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I did as you said, and deleted one of the duplicate entries, and saved it, and typed /sbin/lilo.conf, and I got the following message:

ADDED linux
ADDED linux-enterpris
ADDED failsafe
ADDED windows*
FATAL: Kernal doesn't support initial RAM disks

Anyway, I closed Console down and rebooted, and linux was still the default. What went wrong?
 
Old 07-25-2003, 08:34 AM   #19
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Damian

I'd delete both those duplicate entries - taken at face value they dont do anything and shouldn't be there - so delete both of them

Also when you run the map installer you type

/sbin/lilo not /sbin/lilo.conf

try this properly -

Can you post your lilo.conf file or your Expert tab again - I'd like to see exactly what youve deleted at this point and whats left in there.
 
Old 07-25-2003, 12:45 PM   #20
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
It now works :-)

I deleted both duplicate entries, and then typed /sbin/lilo and now everything works fine, with Windows as the default :-)

Since you have been so good at helping me solve this problem, I don't want to push my luck, but I do have 2 other Linux queries at this stage - hope you don't mind me posting them in here:

1. What are failsafe and linux-enterpris, and can they safely be deleted from the list?

2. Sometimes, when I click Logout Damian, it brings up a box with Reboot or Halt options, and sometimes it brings up a box with the dragon in, and 3 options (log out, shut down or reboot, I think). How can I make it so that the dragon box always comes up, and not just sometimes?
 
Old 07-25-2003, 01:21 PM   #21
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Damian

Personaly - I would just leave the entries for Failsafe and Enterprise alone.

Failsafe mode just enables you to go into Graphical,text,maintennance modes, check bootlogs etc - I would suggest you just leave it - Enterprise presumably is a more enhanced kernel/version offered on the Powerpack edition.
Again - just leave it now youve got your computer sorted.

If you really do want to delete these entries just go into your expert tab and delete the whole entry for Failsafe and the whole entry for Enterprise - then just click on apply.

Then go to a Console and

SU
root password

/sbin/lilo

I would just leave them alone for now though.
 
Old 07-25-2003, 01:35 PM   #22
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
OK, thanks :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 06:45 PM
What do these boot options do? jalldridge Linux - Newbie 1 03-23-2005 12:18 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM
What are these two boot options? deanbrown3d Linux - Newbie 6 08-20-2004 10:08 AM
boot options delos Linux - Networking 0 07-10-2004 03:23 AM


All times are GMT -5. The time now is 12:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration