LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2003, 04:44 PM   #1
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Rep: Reputation: 0
Help with Boot Options


I have recently set up Mandrake Linux 9.1 as a dual boot with Windows XP Home, and all is well, except I cant seem to set Windows as the default, so when I boot my PC up, it loads into Linux by default. I dont want this.

For some reason, I couldnt find Linux mentioned in the Windows boot.ini file, so I had a look in Linux and found the Control Center --> System --> Boot Manager section.

I saw Linux was default, so I set windows to default, and clicked Apply. I got an error message saying the Configuration was NOT ok. I thought this was Linux trying to make itself the default, so I ignored it, but Linux remained the default when I booted up. Also, I see to have linux, linux-enterpris, failsafe, windows and floppy listed in the Operating Systems windows, which is a bit weird and confusing.

Anyway, how do I make window the default?

Here is my current configuration file (which is shown in the Expert tab):

Quote:
boot="/dev/hda"
map=/boot/map
keytable=/boot/uk.klt
prompt
nowarn
timeout="100"
message=/boot/message
menu-scheme=wb:bw:wb:bw
default=windows

image="/boot/vmlinuz"
label="linux"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image="/boot/vmlinuz-enterprise"
label="linux-enterpris"
root="/dev/hda5"
initrd="/boot/initrd-enterprise.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image="/boot/vmlinuz"
label="failsafe"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=nomount hdc=ide-scsi acpi=off failsafe"
read-only

other=/dev/hda1
label="windows"
table=/dev/hda

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
And here is the Configuration file error:

Quote:
Configuration NOT ok. LILO said:
LILO version 22.4.1 (test mode), Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2002 John Coffman
Released 27-Jan-2003 and compiled at 11:11:26 on Feb 5 2003.
Reading boot sector from /dev/hda
Using GRAPHIC secondary loader
Calling map_insert_data
Mapping message file /boot/message -> message-graphic
Calling map_insert_file
Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk
Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img
Added linux
Boot image: /boot/vmlinuz-enterprise -> vmlinuz-2.4.21-0.13mdkenterprise
Mapping RAM disk /boot/initrd-enterprise.img -> initrd-2.4.21-0.13mdkenterprise.img
Added linux-enterpris
Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk
Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img
Added failsafe
Boot other: /dev/hda1, on /dev/hda, loader CHAIN
Added windows *
Boot image: /dev/hda1 -> ide/host0/bus0/target0/lun0/part1
Fatal: Kernel doesn't support initial RAM disks
Has anyone got any ideas?


Also, since I'm here, another weird thing I've noticed is that I can access my Windows files from a Linux menu (from the mnt --> windows menu), and open images, etc, but I cant access Linux files from Windows. In fact, Windows has no mention of Linux anywhere.
They are on 2 separate partitions, so it is a bit weird, but its not a major problem like my default booting thing.

Any ideas please?
 
Old 07-24-2003, 04:55 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
One possible problem in saving your Lilo.conf file is the 2 duplicate entries at the bottom.

Delete these 2 entries at the botom and save lilo.conf again

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"



Youve already got :

default=windows

So once your able to save lilo.conf correctly - Windows will be your default boot up OS

remember to become root user at a console after youve saved lilo.conf and type

/sbin/lilo

In general you wont be able to see Linux partitions from Windows but you can see Windows partitions from Linux

Last edited by Skyline; 07-24-2003 at 04:57 PM.
 
Old 07-24-2003, 04:59 PM   #3
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Major advice for Mandrake: Use the Mandrake Control Centre and it's bootloader configurator instead of the KDE one in the KDE Control Centre.

Also remember you can boot off the 1st Mdk install disk and the rescue mode has an option to fix Lilo if you manage to break it.

Only some newer server releases of Windows have linux filesystem support iirc.
 
Old 07-24-2003, 05:11 PM   #4
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I removed the duplicate entry, but still got both the error messages that I quoted in my first post. I didnt do that console thing, because I didnt think there was much point since I got errors, and when I rebooted, linux was still the default.

What else should I try?
 
Old 07-24-2003, 05:17 PM   #5
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Lilo wont be updated until you run lilo, or better lilo -v -v. Just change the default line in /etc/lilo.conf, save the file, and run that command.
Or use the nice Mandrake editor.
 
Old 07-24-2003, 05:22 PM   #6
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
So, you want me to open the Console and type /sbin/lilo -v -v

Is that right (excuse me for being a very slow Linux learner!)?

Btw, whats this Mandrake editor?
 
Old 07-24-2003, 05:27 PM   #7
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Damian

I wouldnt run /sbin/lilo yet as you haven't been able to save lilo.conf correctly yet.

Do you hasve the powerpack edition of Mandrake - which edition have you got.
 
Old 07-24-2003, 05:30 PM   #8
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Yeah, I've got the PowerPack edition. I keep getting the Configuration is NOT ok error whenever I try to click Apply to any changes I make.

It doesnt seem to make much difference, as Linux and Windows both load correctly, but I would like to make Windows the default.

I am also a little confused as to what failsafe and Linux Enterpris are? I had something called Floppy on the list as well, but deleted it, which I'm guessing was the wrong thing to do now!
 
Old 07-24-2003, 05:31 PM   #9
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Well, try posting the contents of /etc/lilo.conf here first, as that's what KDE's editor is trying to alter.

The Mandrake Boot option editor is explained in my post above.
 
Old 07-24-2003, 05:36 PM   #10
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I am going to Start Applications --> Configuration --> Control Center --> System --> Boot Manager (LILO), and changing the things in there.

Do you want me to post the contents of the Expert tab on that, or the contents of another file?
 
Old 07-24-2003, 05:42 PM   #11
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I'd rather the raw file, instead of KDE's possibly munged output. Simply start kwrite or your fav text editor and open /etc/lilo.conf. You may need to use the KDE launcher/Run... entry to start the app as root to access that file, depending on your security settings.

Failsafe is like windows safe mode, only this is actually useful and doesnt break other settings. Floppy was to boot off a floppy drive containing a boot disk. Enterprise is probably a hardened server variation of the kernel to deal with higher load and attacks in the business environment.
 
Old 07-24-2003, 05:46 PM   #12
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi Damian

The Expert tab is your LILO.CONF file - and you've already posted it.

As I said in my first post the default = directive already correctly points to Windows.

The problem youve got is trying to save it correctly first before you run the map installer /sbin/lilo

The last line of the error mesage talks about the kernel not supporting inital ram disks? - strange

Last edited by Skyline; 07-24-2003 at 05:48 PM.
 
Old 07-24-2003, 05:49 PM   #13
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I think this may be KDE's editor's fault, so running /sbin/lilo -v -v will report specifics about any problems when trying to update lilo. It may be the quickest way to solve the problem.
Editing lilo.conf by hand isnt hard, so we can skip kde's editor and just use a text editor.

Edit: scratch that, I think the symlinks for vmlinuz and initrd.img are squiffy, maybe because of multiple kernel source installs or repeated kernel install-uninstall?

Last edited by Proud; 07-24-2003 at 05:53 PM.
 
Old 07-24-2003, 05:55 PM   #14
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I found the etc/lilo.conf file but couldnt open it in anything - KWord wouldnt let me, neither would KJots, and attempting to save it to floppy disk to open in Notepad in Windows didnt work as it said "Cannot read from /etc/lilo.conf".

That RAM error is strange - maybe its because I have 1024Mb of RAM - I know Windows has initial problems working with so much.

Anyway, I am having to post this in Windows, close down, go into Linux, etc, etc, so sorry for a long time between posts. Shall I run that console command and see what happens, or has anyone got any other ideas?

Could someone do it on their own PC and copy and paste me the contents of lilo.conf, or wouldnt that work?
 
Old 07-24-2003, 05:58 PM   #15
DamianY2J
LQ Newbie
 
Registered: Jul 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Well, I did install and then reinstalled over it (well, I thought I did), because the first time I did it, it didnt work at all.

The first time I installed it, i deleted everything in the list except windows and linux, and renamed linux to mandrakelinux, and window to windowsxp.

Then, on bootup, when I selected mandrakelinux, it said "Loading mandrakelinux....." but then didnt do anything, ever. I had to keep restarting the PC. Windows loaded fine though.

Maybe I reinstalled wrong - I do know I got confused at the partition questions it asked me, and just kept clicking Next and accepting their default values - maybe I agreed to a wrong value.

What can I do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
What do these boot options do? jalldridge Linux - Newbie 1 03-23-2005 11:18 AM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
What are these two boot options? deanbrown3d Linux - Newbie 6 08-20-2004 09:08 AM
boot options delos Linux - Networking 0 07-10-2004 02:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration