LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-04-2008, 12:55 PM   #1
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Rep: Reputation: 0
Help With BackTrack Dual Boot with Vista


Hey,

When changing the lilo.conf file I copy the tutorial exactly but when I go to run lilo -v, I get a
"Fatal: First sector of /dev/sda1 doesn't have a recognizable boot."

Hopefully, someone can help me out with this, I'm running on a T61 Lenovo, Vista Ultimate OS, trying to use Backtrack 2.

Lilo.conf File:

lba32
boot = /dev/sda
#compact # faster
promt
timeout = 300
vga = 791

#Linux start
image = /boot/vmlinuz
root = /dev/sda4
label = BT2
read-only

other = /dev/sda1
label = Windows
table = /dev/sda

Now i tried re mounting my /boot/ from a previous post on the forum, and apparently this doesn't help because now I get a
"warning:
/proc/partitions' does not exist, disk scan bypasses
Fatal: creat /boot/map~: No such file or directory"

fdisk shows the partitions in order and correct System

When I use the command 'mount' the output is

tmpfs on / type tmpfs (rw)
proc on / proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,devgid=10,devmode=0666)
/dev/sda4 on /mnt/sda4 type reiserfs (rw,noatime)
/dev/sda2 on /mnt/backtrack/boot type ext2 (rw)

when I try command "chroot /mnt/backtrack/ /bin/bash/"

output is:
chroot: cannot run command '/bin/bash/' : No such file or directory

Any Help would be greatly appreciated
 
Old 03-04-2008, 01:02 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
Did you run /sbin/lilo -A after changing lilo.conf?

It might also help to see the output of fdisk -l, and the contents of /etc/fstab.

Last edited by bigrigdriver; 03-04-2008 at 01:06 PM.
 
Old 03-04-2008, 01:27 PM   #3
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Appreciate Help

First, let me say I greatly appreciate your help and very quick response. My only hope is I can learn Linux to a high enough extent I could help people in my shoes one day. When I run fdisk -l, I get:

cannot open /proc/partitions

when I do nano /etc/fstab, the output is:


/dev/sda4 / auto defaults 1 1 (WHICH IS In the Nano Reader)

I did run lilo -v when I edited lilo.conf the first time. I might also add that when I first tried to edit it and run lilo -v, I did see that linux was added it stated :

Linux added*

But it hung up on the windows part stating the fatal error.

Thank you in advance,

Sean
 
Old 03-04-2008, 03:35 PM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Quote:
Originally Posted by proxyzero View Post
First, let me say I greatly appreciate your help and very quick response. My only hope is I can learn Linux to a high enough extent I could help people in my shoes one day. When I run fdisk -l, I get:

cannot open /proc/partitions

when I do nano /etc/fstab, the output is:


/dev/sda4 / auto defaults 1 1 (WHICH IS In the Nano Reader)

I did run lilo -v when I edited lilo.conf the first time. I might also add that when I first tried to edit it and run lilo -v, I did see that linux was added it stated :

Linux added*

But it hung up on the windows part stating the fatal error.

Thank you in advance,

Sean
If that is all you got in the '/etc/fstab' then you should create a proper one.

Code:
sample excerpt '/etc/fstab';

~#cat /etc/fstab

/dev/hda2        swap             swap        defaults         0   0
/dev/hda3        /                ext3        defaults         1   1
/dev/hda5        /home            ext3        defaults         1   2
/dev/hda8        /usr             ext3        defaults         1   2
#
#12-31-05 12:00 gws old /usr
#/dev/hda6        /usr             ext3        defaults         1   2

/dev/hda6        /archive         ext3        defaults         1   2
/dev/hda7        /tmp             ext3        defaults         1   2
/dev/hda1        /mnt/win98       vfat        defaults         1   0
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0


devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
#09-12-06 23:00 gws
I like to test my lilo.conf;

Code:
~#lilo -v -t -b /dev/your_device     #sda, hda this will only test 
~#lilo -v -b /dev/your_device        #this will write MBR to your_device
The first lilo will test (-t) the lilo and the second will write to the MBR. 'Man lilo' to understand the command.

BTW, do you have your windows partition set as active (boot)?
 
Old 03-04-2008, 08:20 PM   #5
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Question

Thanks onebuck for the reply,

This is going to sound most likely to be very simple, but that code regarding the fstab, I'm not sure how to use that correctly for my partitions? I'm not quite sure what the 0, and 1's mean at the end and I don't want to make another terrible mistake. If there's anyway you could clarify that for me, it would be very helpful.

Thanks
 
Old 03-04-2008, 10:14 PM   #6
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Scratch Last Post

Sorry about the last post, I looked up the fstab info, should have in the first place. My fstab now reads

/dev/sda1 / vfat defaults 1 0
/dev/sda2 /mnt/backtrack/boot ext2 defaults 1 2
/dev/sda3 swap swap defaults 0 0
/dev/sda4 /mnt/backtrack reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

devpts /dev/pts devpts gid=5, mode=791 0 0
proc /proc proc defaults 0 0


now when i test booting up the /dev/sda2, it seems to be working now,

it says *added linux
but when i do this to the windows partition I get an error, I haven't yet run " Lilo -v" I wont want to write to the MBR. Hope this can help someone in figuring out what mistake I have made.

I believe my windows partition is set to active boot, but I don't know how to check this.

Much appreciated

Last edited by proxyzero; 03-04-2008 at 10:15 PM.
 
Old 03-05-2008, 09:20 AM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Quote:
Originally Posted by proxyzero View Post
Sorry about the last post, I looked up the fstab info, should have in the first place. My fstab now reads

/dev/sda1 / vfat defaults 1 0
/dev/sda2 /mnt/backtrack/boot ext2 defaults 1 2
/dev/sda3 swap swap defaults 0 0
/dev/sda4 /mnt/backtrack reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

devpts /dev/pts devpts gid=5, mode=791 0 0
proc /proc proc defaults 0 0


now when i test booting up the /dev/sda2, it seems to be working now,

it says *added linux
but when i do this to the windows partition I get an error, I haven't yet run " Lilo -v" I wont want to write to the MBR. Hope this can help someone in figuring out what mistake I have made.

I believe my windows partition is set to active boot, but I don't know how to check this.

Much appreciated
If you use fdisk, then you can see the partition(s) information.

How are you booting your system? What's the problem with writing to the MBR? The 'lilo -v';

Quote:
excerpt 'man lilo'

-v Increase verbosity. Giving one to five -v options will make lilo
more verbose, or use, -v n (n=1..5) to set verbosity level 'n'.
I would suggest that you look at the 'man lilo' and 'man lilo.conf' to get some good background.

I would suggest that you also look at 'SlackwareŽ Essentials' and 'SlackwareŽ Basics' which are Slackware based but still good guides.

These links and others can be found at 'Slackware-Links' .
 
Old 03-05-2008, 10:27 AM   #8
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Helpful

Thanks for the links, and for the man lilo, didn't know that existed. Those have given me a lot to read, I understand a lot more about lilo now but still not sure where I am making the mistake. My active partition which is flagged is my sda2 which is my linux boot, fdisk still sees all my partitions perfectly. And I did write to the MBR, when I run lilo I get:

Reading Boot sector from /dev/sda
Warning: 'proc/partitions' does not exist, disk scan bypassed
Using MENU secondary loader
calling map_insert_data

Boot image: /boot/vmlinuz
Added Backtrack*

Boot Other: /dev/sda1 on /dev/sda, loader chain
Fatal: First sector of /dev/sda1 doesn't have a valid boot signature




Any Advice??
 
Old 03-06-2008, 11:22 AM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,


Quote:
Originally Posted by proxyzero View Post
Thanks for the links, and for the man lilo, didn't know that existed. Those have given me a lot to read, I understand a lot more about lilo now but still not sure where I am making the mistake. My active partition which is flagged is my sda2 which is my linux boot, fdisk still sees all my partitions perfectly. And I did write to the MBR, when I run lilo I get:

Reading Boot sector from /dev/sda
Warning: 'proc/partitions' does not exist, disk scan bypassed
Using MENU secondary loader
calling map_insert_data

Boot image: /boot/vmlinuz
Added Backtrack*

Boot Other: /dev/sda1 on /dev/sda, loader chain
Fatal: First sector of /dev/sda1 doesn't have a valid boot signature




Any Advice??
Make the active partition on sda1. Re-run your lilo as shown before.
 
Old 03-07-2008, 11:32 AM   #10
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Sda1 Active

Sda1 is active re-ran lilo
same error

Ignoring entry 'boot'
reading boot sector from dev/sda
Warning: 'proc/partitions' does not exist, disk scan bypassed
Using MENU secondary loader
Calling map_insert_data

Boot image: /boot/vmlinuz
Added Backtrack *

Boot other: /dev/sda1, on /dev/sda, Loader CHAIN
Fatal: First sector of /dev/sda1 doesn't have a valid boot signature



Any ideas?
 
Old 03-07-2008, 05:49 PM   #11
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,
Quote:
Originally Posted by proxyzero View Post
Sda1 is active re-ran lilo
same error

Ignoring entry 'boot'
reading boot sector from dev/sda
Warning: 'proc/partitions' does not exist, disk scan bypassed
Using MENU secondary loader
Calling map_insert_data

Boot image: /boot/vmlinuz
Added Backtrack *

Boot other: /dev/sda1, on /dev/sda, Loader CHAIN
Fatal: First sector of /dev/sda1 doesn't have a valid boot signature

Any ideas?
Is your active '/boot' on '/'?
 
Old 03-09-2008, 03:28 PM   #12
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
/Boot

Not sure about that one, sounds like that could be the problem... How do I check if the active is /boot in '/'?? Is that in fstab? or fdisk?

Thanks onebuck for your help
 
Old 03-09-2008, 06:38 PM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,
Quote:
Originally Posted by proxyzero View Post
Not sure about that one, sounds like that could be the problem... How do I check if the active is /boot in '/'?? Is that in fstab? or fdisk?

Thanks onebuck for your help
You could post your '/etc/fstab'. You could also do a 'mount' to what is mounted and where.
 
Old 03-10-2008, 05:48 PM   #14
proxyzero
LQ Newbie
 
Registered: Mar 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Fstab

Hi,

my fstab reads,

/dev/sda1 / vfat defaults 1 0
/dev/sda2 /mnt/backtrack/boot ext2 defaults 1 2
/dev/sda3 swap swap defaults 0 0
/dev/sda4 /mnt/backtrack reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

devpts /dev/pts devpts gid=5, mode=791 0 0
proc /proc proc defaults 0 0


is the problem with the /dev/sda1 and where its reading the boot partition? should it not be '/'?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New install on vista system, want dual boot for vista and fedora. lhelden Linux - Newbie 9 08-21-2008 11:22 AM
Fedora and Vista Dual Boot (vista installed first) firekid1239 Linux - Newbie 10 05-04-2008 10:35 PM
fedora/vista dual boot - partimage: restored vista - vista won't let me log on redmoon zero Linux - General 1 12-31-2007 08:21 PM
Dual Boot Auditor and Backtrack ? lomex Linux - Software 4 04-03-2007 09:33 AM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration