LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-11-2004, 05:58 AM   #16
harnadem
Member
 
Registered: Nov 2003
Location: London, Ontario
Distribution: Ubuntu - Hoary
Posts: 66

Original Poster
Rep: Reputation: 15

Here is the output from /sbin/modprobe -V and /sbin/modprobe.old -V :

[root@localhost michael]# /sbin/modprobe -V
modprobe version 2.4.22
modprobe: Nothing to load ???
Specify at least a module or a wildcard like \*

[root@localhost michael]# /sbin/modprobe.old -V
modprobe version 2.4.22
modprobe: Nothing to load ???
Specify at least a module or a wildcard like \*

One other thought ... I had downloaded modules-init-tools into the /tmp directory and ran the installation file from that point. Should I have downloaded it into a different directory instead?

If so, and if I need to re-run the installation file, is there anything I first need to do, given that I have already attempted to install it once?
 
Old 02-11-2004, 10:05 AM   #17
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
I would try running it again. It doesn't matter where you run it from. Tell it explicitly to install in /sbin by using
./configure --prefix=/
and then
make
make install
 
Old 02-12-2004, 10:39 AM   #18
harnadem
Member
 
Registered: Nov 2003
Location: London, Ontario
Distribution: Ubuntu - Hoary
Posts: 66

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by quatsch
I would try running it again. It doesn't matter where you run it from. Tell it explicitly to install in /sbin by using
./configure --prefix=/
and then
make
make install
Alright, now you'll see why I am a Newbie. Do you mean that I should type in:

./configure --prefix=/

or should I be typing:

./configure --prefix=/sbin

Thank you for your continuing help.
 
Old 02-12-2004, 10:42 AM   #19
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you should type
./configure --prefix=/

the stuff goes into <prefix>/sbin so if you use prefix=/sbin, the stuff would go into /sbin/sbin. Did you do this before? If so, you can probably just copy the stuff from /sbin/sbin into /sbin.
 
Old 02-12-2004, 12:04 PM   #20
harnadem
Member
 
Registered: Nov 2003
Location: London, Ontario
Distribution: Ubuntu - Hoary
Posts: 66

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by quatsch
you should type
./configure --prefix=/

the stuff goes into <prefix>/sbin so if you use prefix=/sbin, the stuff would go into /sbin/sbin. Did you do this before? If so, you can probably just copy the stuff from /sbin/sbin into /sbin.
Here is the output from my attempt to reinstall:

[root@windy module-init-tools-3.0-pre9]# ./configure --prefix=/
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
configure: Adding gcc options: -g -O2 -Wunused -Wall
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands

[root@windy module-init-tools-3.0-pre9]# make
make: Nothing to be done for `all'.

[root@windy module-init-tools-3.0-pre9]# make install
make[1]: Entering directory `/tmp/module-init-tools-3.0-pre9'
/bin/sh ./mkinstalldirs //bin
/bin/sh ./install-with-care lsmod //bin/lsmod
install-with-care lsmod //bin/lsmod
/bin/sh ./mkinstalldirs //sbin
/bin/sh ./install-with-care insmod //sbin/insmod
install-with-care insmod //sbin/insmod
/bin/sh ./install-with-care modprobe //sbin/modprobe
install-with-care modprobe //sbin/modprobe
/bin/sh ./install-with-care rmmod //sbin/rmmod
install-with-care rmmod //sbin/rmmod
/bin/sh ./install-with-care depmod //sbin/depmod
install-with-care depmod //sbin/depmod
/bin/sh ./install-with-care modinfo //sbin/modinfo
install-with-care modinfo //sbin/modinfo
/bin/sh ./install-with-care insmod.static //sbin/insmod.static
install-with-care insmod.static //sbin/insmod.static
/bin/sh ./mkinstalldirs //sbin
/bin/sh ./install-with-care generate-modprobe.conf //sbin/generate-modprobe.conf
install-with-care generate-modprobe.conf //sbin/generate-modprobe.conf
/bin/sh ./mkinstalldirs /usr/share/man/man5
/bin/sh ./install-with-care -m 644 ./modprobe.conf.5 /usr/share/man/man5/modprobe.conf.5
install-with-care -m 644 ./modprobe.conf.5 /usr/share/man/man5/modprobe.conf.5
/bin/sh ./install-with-care -m 644 ./modules.dep.5 /usr/share/man/man5/modules.dep.5
install-with-care -m 644 ./modules.dep.5 /usr/share/man/man5/modules.dep.5
/bin/sh ./mkinstalldirs /usr/share/man/man8
/bin/sh ./install-with-care -m 644 ./depmod.8 /usr/share/man/man8/depmod.8
install-with-care -m 644 ./depmod.8 /usr/share/man/man8/depmod.8
/bin/sh ./install-with-care -m 644 ./insmod.8 /usr/share/man/man8/insmod.8
install-with-care -m 644 ./insmod.8 /usr/share/man/man8/insmod.8
/bin/sh ./install-with-care -m 644 ./lsmod.8 /usr/share/man/man8/lsmod.8
install-with-care -m 644 ./lsmod.8 /usr/share/man/man8/lsmod.8
/bin/sh ./install-with-care -m 644 ./rmmod.8 /usr/share/man/man8/rmmod.8
install-with-care -m 644 ./rmmod.8 /usr/share/man/man8/rmmod.8
/bin/sh ./install-with-care -m 644 ./modprobe.8 /usr/share/man/man8/modprobe.8
install-with-care -m 644 ./modprobe.8 /usr/share/man/man8/modprobe.8
/bin/sh ./install-with-care -m 644 ./modinfo.8 /usr/share/man/man8/modinfo.8
install-with-care -m 644 ./modinfo.8 /usr/share/man/man8/modinfo.8
make[1]: Leaving directory `/tmp/module-init-tools-3.0-pre9'

[root@windy module-init-tools-3.0-pre9]# /sbin/modprobe -V
modprobe version 2.4.22
modprobe: Nothing to load ???
Specify at least a module or a wildcard like \*


Any ideas as to what I am doing wrong?
 
Old 02-12-2004, 06:44 PM   #21
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
do you have directories like
//sbin
(note the double slash). If so, the stuff is probably in there (maybe you did --prefix=// the first time?). If not, I would erase the directory in which you compiled, untar-gzinp the source file again and start again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what does "depmod: *** Unresolved symbols" mean when compiling 2.4.25 kernel? andrewstr Linux - Software 2 03-01-2004 03:01 PM
Configuring kernel: Impact of "Y" or "N" vs. "M" Mark_E_Wallace Linux - Newbie 2 02-22-2004 07:02 PM
kernel 2.6.0 debian "No module symbols loaded - kernel modules not enabled." toovato Linux - General 2 01-07-2004 08:56 PM
"Unresolved symbols" when compiling kernel. Uncreative Slackware 6 05-09-2003 11:44 AM
kernel symbols have no "goo" bbeers Slackware 2 08-06-2002 08:47 AM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration