LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-23-2004, 11:51 PM   #1
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Rep: Reputation: 30
Exclamation Help setting up Samba?


I need help with samba , new to linux trying to learn how to get around.
I have two hard drives, on drive A i have xp pro , on drive B i have redhat 9.0. basically, i want to be able to access my files on xp while using redhat and viceversa. I have samba installed already. I need detailed instructions as am new to linux and still dont know most of the lingo or commands.

also having problems setting up dsl connection. i have been trying for days now, have read several threads, but no success so far.
i have tried these commands
/sbin/ifup eth0
i get this message: user cant control this device
/var/log/message
i get : permission denied
/sbin/ifconfig eth0 up
i get: permission denied
/etc/sysconfig/network-scripts/ifcfg-eth0
i get: bash:/etc/sysconfig/network-scripts/ifcfg-eth0-permission denied
/etc/sysconfig/network
i get: bash:/etc/sysconfig/network-permission denied
/etc/modules.conf
i get: bash permission denied

after playing around , i went to system setting -network confirguration-and i was able to activate eth0. i then tried to go on line , but when i try to go to any website, i go the message" location not found" any help regarding these to problems will be appreciated
 
Old 03-24-2004, 03:19 AM   #2
shubb
Member
 
Registered: Oct 2003
Location: San Francisco
Distribution: Slackware 13.37
Posts: 150

Rep: Reputation: 16
From what you are saying, it sounds like both these drives are in the same computer? If so, then you dont need Samba. Samba is for connecting to a different windows PC. What you need to do is mount the windows drive to a mount point on Linux.

First, you need to verify what file system XP is installed as, Fat32 or NTFS. I think that XP uses NTFS. I believe that currently, linux only supports read-only for NTFS, so you wont be able to write to the XP drive.

Try using this:

Create a directory that you want to mount the XP drive to.

mkdir /mnt/xp

Then mount the drive to the mount point.

mount -t ntfs /dev/hda1 /mnt/xp <-- replace the hda1 with the drive/partition that XP is on.

If the command executes successfully, you should be able to read the XP drive from the /mnt/xp directory. If not, post back any errors you get.

For the Internet problem, can you ping anything on the internet by IP address or by hostname? If you can ping by IP, but not by hostname, then you probably just need to add a DNS server to /etc/resolv.conf

send the output of the following:

ifconfig
cat /etc/resolv.conf

If the resolv.conf does not have anything, then add the following to the file using your ISPs DNS server for x.x.x.x

nameserver x.x.x.x
 
Old 03-24-2004, 03:28 AM   #3
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
for accessing files: samba can be used to access windows shares, so windows must be running and sharing some stuff, wich isn't the case because linux is running however, you can mount your windows partition in linux. create a dir where to mount your windows partition (say 'mkdir /mnt/winxp') and mount it with 'mount /dev/hdxx /mnt/winxp' where 'hdxx' is the device of your windows partition (like hda1 or hdb2) wherever it is. if you don't know wich is your windows partition, run cfdisk to check it, DON'T change anything!! NTFS filesystems are mounted read-only, write support is DANGEROUS! reading works perfect as for a DSL connection, I don't have any experience with that, but you can take a look here: The Linux DSL Howto, have fun!
 
Old 03-24-2004, 04:21 AM   #4
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Rep: Reputation: 97
Well pretty much everyone has all ready told you about the mounting an windows partition from another hardrive in the same PC. THere are some third party utilities and project which provide write support for NTFS I am not sure how relaible they are I have not tried them yet. You can search for Linux NTFS support.

As for the DSL it may be a lack of DNS servers listed, however. most DSL providers use PPPoE make sure you have PPP support in your kernel or as a module, then find a PPPoE program that should solve your problem.

Alex
 
Old 03-24-2004, 05:44 AM   #5
sentinela
LQ Newbie
 
Registered: Mar 2004
Location: Vienna
Distribution: Debian "Squeeze"
Posts: 13

Rep: Reputation: 0
http://linux-ntfs.sourceforge.net/rpm/index.html
check that site.. there is everything u need to mount ur winxp ntfs partition pretty good explained.
 
Old 03-24-2004, 07:13 AM   #6
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
thanks , i will try all the above mentioned commands
 
Old 03-24-2004, 07:59 AM   #7
LinuxBlackBox
Member
 
Registered: Sep 2003
Location: Canada
Distribution: Slackware 9
Posts: 243

Rep: Reputation: 30
When you are issuing these codes to get the network working, do you know which user you are doing it as? You should do it as root, root has the ability to run/change any program on the machine. Your user account cant do that
Type
su root
and enter your password

then try all of those things again
 
Old 03-24-2004, 08:05 AM   #8
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
i tried mkdir/mnt/winxp
i get: bash no such file or directory
i tried mnt/dev/hde1/mnt/winxp
i get: bash no such file or directory
i also tried cfdisk
i get: command not found
I was trying under a username, i will switch to root and see it that makes a difference
 
Old 03-24-2004, 09:07 AM   #9
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Rep: Reputation: 97
YOu actually have to edit your /etc/fstab file it contains your Filesystem information, you need to add an entry that contains the partition that your XP drive is on and you have to list the Filesystem type, it will either be vfat (Fat32) or NTFS once it is in your fstab you create a directory in the root folder of your drive (/) by typing mkdir xp it will create an empty folder. THen after you have created the directory type the mount command.

alex
 
Old 03-24-2004, 11:23 AM   #10
shubb
Member
 
Registered: Oct 2003
Location: San Francisco
Distribution: Slackware 13.37
Posts: 150

Rep: Reputation: 16
snakeo2, the error about file not found when you try to create the /mnt/winxp means that you dont have the /mnt directory. Use the -p option when creating the /mnt/winxp to automatically make all parent directories.
 
Old 03-24-2004, 02:13 PM   #11
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
hey shubb, thanks for the tip
im a newbie, can you tell me the exact command so i can try to see if it works
 
Old 03-24-2004, 02:29 PM   #12
sentinela
LQ Newbie
 
Registered: Mar 2004
Location: Vienna
Distribution: Debian "Squeeze"
Posts: 13

Rep: Reputation: 0
what i see is that u are typing wrong....
it goes
mkdir /thedir/dir and not mkdir/thedir/dir
and
mount /dev/hdax /mnt/whateverdirforxp (x=where ur ntfs is)

im new to linux 2 but maybe is that ur mistake..
 
Old 03-24-2004, 04:56 PM   #13
shubb
Member
 
Registered: Oct 2003
Location: San Francisco
Distribution: Slackware 13.37
Posts: 150

Rep: Reputation: 16
First, check to see if you have the /mnt directory

ls -al /mnt

If it says no such file or directory, then you need to create it.

Create the directory, and the mount directory for xp

mkdir -p /mnt/winxp

Now you should see the mnt directory from /, and you should also see the winxp directory in the mnt directory

Also remember, that when you are creating directories from /, you need to be root.
 
Old 03-24-2004, 09:13 PM   #14
snakeo2
Member
 
Registered: Mar 2004
Location: Miami, Fl
Distribution: Red Hat 9/fedora core3/
Posts: 273

Original Poster
Rep: Reputation: 30
finally, as someone pointed out, i was typing the wrong code. after typing mkdir /mnt/xp, i did not get any errors, i then typed mount -p ntfs/dev/hde1/mnt/xp, did not get any errors either, so i guess it created the directory. i went to check / as root and there is a directory called xp, however there is nothing in it? is there something that im missing? if someone knows what im doing wrong, please let me know.. as far as the internet connection goes, i think im getting close, eth0 is now active. when i type 198.168.0.1 in the url bar, i get a prompt window asking me to input the username and password of the DI-624 router? i dont know what to do next? i tried putting the username and password assigned by ISP, but that didnt work. anyone has any suggestions.....
 
Old 03-24-2004, 10:31 PM   #15
ludeKing
Member
 
Registered: Jul 2003
Location: NSW. Australia
Distribution: Ubuntu, Fedora, Slackware
Posts: 181

Rep: Reputation: 30
You are missing the spaces in your commands!

first up, type this in a console:
"dmesg | grep hd" (note the | is shift and backslash on my keyboard - called a pipe) and see if your xp hard drive is detected, if it says hdd or hda or whatever, that is great! Now, how many partitions on your XP drive? One? great!

Now if the dmesg command returned hdd: FUJITSU blahblah etc then your xp drive is called hdd and if you only have one partition its hdd1. If it said hda: fujitsu blahblah etc, then your Xp drive is called hda.

Now,
as root:

mkdir /mnt/xp (note the space between mkdir and the first /)
then the mount command: mount -t ntfs /dev/hdxx /mnt/xp (note ALL the spaces, and hdxx is what came from the above paragraph)

See how you go.
Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Samba under 5.0.4 Linux31 Ubuntu 2 07-04-2005 12:37 AM
Help setting up Samba... CaptainRegular Linux - Networking 2 04-05-2005 08:03 AM
Setting up Samba kicken Linux - Newbie 3 06-07-2004 07:08 PM
setting up samba true_atlantis Linux - Newbie 1 05-28-2004 07:53 AM
Setting up Samba Spyder_Snyper Linux - Networking 2 01-24-2004 10:23 PM


All times are GMT -5. The time now is 06:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration