LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-16-2002, 12:35 PM   #1
rachelkoncewicz
LQ Newbie
 
Registered: May 2002
Location: Oxford, UK
Distribution: openSuSE 11.1, Ubuntu 9.04
Posts: 12

Rep: Reputation: 0
Question Help! Redhat 7.3 won't play CDs


Hi, I've just got Red Hat 7.3, and I cannot get it to play audio CDs. I've been through the FAQs and have now probably messed my system up totally :-)

I've tried XPlaycd, and the kde and gnome cd players. They say the CD is playing, but there is no sound.

I get system sounds when I log in etc, and everything works fine on Windows. It's also worked fine on some earlier Linux distributions I've tried. Any ideas?
 
Old 05-17-2002, 11:09 PM   #2
justiceisblind
Member
 
Registered: Jan 2002
Location: Stevens Point, WI
Distribution: Mandrake 10.0 (P4 2.8 w/ HT, Radeon 9700 Pro, 80 GB/120GB HDDs)
Posts: 242

Rep: Reputation: 30
did you do the sndconfig?? Try that, that might solve your problems... run it as root from a console.
 
Old 05-18-2002, 11:57 AM   #3
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
Make sure the little audio cable is connected from your cdrom drive to the sound card.
 
Old 05-18-2002, 01:49 PM   #4
rachelkoncewicz
LQ Newbie
 
Registered: May 2002
Location: Oxford, UK
Distribution: openSuSE 11.1, Ubuntu 9.04
Posts: 12

Original Poster
Rep: Reputation: 0
Yeah, I've checked that and done sdnconfig, but still nothing coming out even thoug it says it is playing. It's fine on windows, but I don't want to use Windows, for obvious reasons!
 
Old 05-19-2002, 09:53 AM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
check your soundmixer. make sure you haver your sound all the way up. Both the master vol and the CD vol, heck turn em all up.

Then check the plug from your speakers to the wall outlet, just to be safe.
 
Old 05-19-2002, 09:54 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Oh, soundmixer is in (on mandrake/kde) multimedia-->sound-->sound Mixer
 
Old 05-19-2002, 11:20 AM   #7
justiceisblind
Member
 
Registered: Jan 2002
Location: Stevens Point, WI
Distribution: Mandrake 10.0 (P4 2.8 w/ HT, Radeon 9700 Pro, 80 GB/120GB HDDs)
Posts: 242

Rep: Reputation: 30
Yeah, that's a common problem too, the mixer settings are set way too low sometimes or some channels are muted.
 
Old 05-19-2002, 11:07 PM   #8
rachelkoncewicz
LQ Newbie
 
Registered: May 2002
Location: Oxford, UK
Distribution: openSuSE 11.1, Ubuntu 9.04
Posts: 12

Original Poster
Rep: Reputation: 0
OK, still no luck. I've run sndconfig loads of times with different settings. I can hear Linus Torvalds saying he says Linux as Linux, but still no CDs.
 
Old 05-19-2002, 11:14 PM   #9
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Stupid question but it needs to be asked, is your cabling ok? Is the cable from CD-ROM to souncard intact? Is your drive set to cable select? And if it is then change it to master/slave theme
 
Old 05-19-2002, 11:17 PM   #10
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Nevermind my previous post I abviously need some sleep - your sound works/worked under windows and other linux distros. What is the sound card?
 
Old 05-20-2002, 12:02 AM   #11
Sfin
Member
 
Registered: Apr 2002
Location: Michigan
Distribution: Slackware 8.0
Posts: 197

Rep: Reputation: 30
I know it has been said like 2 times now, but have you checked the sound mixer?

These are two things to check there:

1) Is the green light on top of the CD image, bright. If not then the CD sound is muted. Click on it, and it will unmute the CD sound.

2) Is the little volume control for the CD sound low. If that is the case then take it all the way up.

To get to kmixer either:

K --> multimedia --> Kmix

or

in Console type: Kmix

Though I am using KDE3, so I ain't sure if it is different for KDE2
 
Old 05-20-2002, 12:19 AM   #12
rachelkoncewicz
LQ Newbie
 
Registered: May 2002
Location: Oxford, UK
Distribution: openSuSE 11.1, Ubuntu 9.04
Posts: 12

Original Poster
Rep: Reputation: 0
I think it's CMI8330. At least, that's what I downloaded to make it work on Windows! Anyway, I can play music on the internet, and it's playing radio and stuff fine. I reinstalled everything, and have the default fstab and /dev entries, which don't mean much to me, it has to be said.

Last edited by rachelkoncewicz; 05-20-2002 at 12:31 AM.
 
Old 05-20-2002, 01:51 AM   #13
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Rep: Reputation: 38
This is od becuase it sounds like a Linux related problem but he hears Linus talkin in sndconfig... The ONLY thing i can think of is what these guys are saying.. mixer panel. aumix under K > Multimedia > Sounds > *aumix* er something like that. it HAS to be.


any luck with that?
 
Old 05-20-2002, 11:04 PM   #14
justiceisblind
Member
 
Registered: Jan 2002
Location: Stevens Point, WI
Distribution: Mandrake 10.0 (P4 2.8 w/ HT, Radeon 9700 Pro, 80 GB/120GB HDDs)
Posts: 242

Rep: Reputation: 30
In RH 7.2 it's under K -> Multimedia -> Sound Mixer

And as stated earlier if the green light under the picture of a CD isn't "on" click on it, and then change the settings for the volume, then in file click save settings as default if it's set and everything is working.
 
Old 05-21-2002, 10:33 PM   #15
rachelkoncewicz
LQ Newbie
 
Registered: May 2002
Location: Oxford, UK
Distribution: openSuSE 11.1, Ubuntu 9.04
Posts: 12

Original Poster
Rep: Reputation: 0
Yeah, the little green light is on, and all the volumes ar up as high as they'll go. I still can't hear anything though! The CD player reads the tracks fine, but I can't see what else to do. I guess the default values for everything are right.

There is one thing - when I ran sndconfig, I had to mess about with the random IRQs and things that come up to get it to play Linus, and it said there was something wrong with /dev/audio to start with. I haven't a clue what I changed to get it to work though, or what any of them mean...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can play cds chrismiceli Linux - General 2 08-04-2005 05:47 AM
I can't PLAY CDs oicdn Linux - Software 12 03-24-2004 07:07 AM
I cant play cds justinbm Red Hat 2 10-15-2003 11:09 AM
Can't play cds helloyo Linux - Software 18 10-14-2003 11:32 AM
CD-RW does not want to play music CDs! Dzemo Linux - General 6 01-09-2003 10:23 AM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration