LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2008, 07:03 PM   #16
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15

heres another example
Code:
[nolan@DONTMESSWITHDEX ~]$ su -
Password: 
[root@DONTMESSWITHDEX ~]# yum install totem
Loaded plugins: refresh-packagekit
Options Error: Error parsing '1gpgcheck=1': invalid boolean value
[root@DONTMESSWITHDEX ~]#
 
Old 04-24-2008, 07:06 PM   #17
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
looks like a typo in the repo file you just created - see second line of what you posted.

Does the file say

1gpgcheck=1

rather than


gpgcheck=1

?

What else is wrong in there?

re-edit (type that vi line again), use your arrow keys to put the cursor over the leading "1", hit delete then escape :wq

If you still have problems, post the repo file
 
Old 04-24-2008, 07:16 PM   #18
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
Code:
Loaded plugins: refresh-packagekit
http://dl.atrpms.net/f8.93-i386/atrp...ta/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: atrpms. Please verify its path and try again


that shows up when i do yum install


BTW, i fixed the other error,now this is showing up again

Last edited by Nolanz2; 04-24-2008 at 07:19 PM.
 
Old 04-24-2008, 07:23 PM   #19
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Please follow my posts

post your atrpms.repo
 
Old 04-24-2008, 07:24 PM   #20
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
[atrpms]
name=ATrpms for Fedora Core 8 stable
baseurl=http://apt.atrpms.net/fedora/8/en/i386/at-stable
enabled=1
[atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
gpgcheck=1
 
Old 04-24-2008, 07:35 PM   #21
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I don't know where the first atrpms entry came from.

Either delete the first entry, or delete the whole file and recreate.

If the problem recurs, the error is .93 that you are seeing and can be fixed by changing the baseurl to

http://dl.atrpms.net/f8-i836/atrpms/stable
 
Old 04-24-2008, 07:38 PM   #22
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
that link you just gave showed up as
"Not Found
The requested URL /f8-i836/atrpms/stable was not found on this server.

Apache/2.2.3 (Red Hat) Server at dl.atrpms.net Port 80"

that might be a problem
 
Old 04-24-2008, 07:38 PM   #23
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Slight typos i836 should be i386.

http://dl.atrpms.net/f8-i386/atrpms/stable/
 
Old 04-24-2008, 07:39 PM   #24
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Oops - sorry 'bout that
 
Old 04-24-2008, 08:06 PM   #25
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
ok, we're getting there, now i have this error when trying to install something

http://rpm.livna.org/fedora/8.93/i38...ta/repomd.xml: [Errno 14] HTTP Error 404: Not Found



what are the codes to type in to edit this, and what do i change the baseurl to?
 
Old 04-24-2008, 08:14 PM   #26
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
do the vi bit (vi /etc/yum.......)
move to the period between the 8 and 9
hit delete 4 times
hit i
hit -
hit escape :wq
Done
 
Old 04-24-2008, 08:16 PM   #27
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You may find this useful in the future

http://www.tuxfiles.org/linuxhelp/vimcheat.html

vi commands are used a lot, for example in crontab editing. You only need to remember a few basic commands like i, wqw, etc
 
Old 04-24-2008, 08:33 PM   #28
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
so in /etc/yum.repos.d/livna.repo
i have written

Code:
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
	http://rpm.livna.org/fedora/8i-i386/
	http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
	http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
	ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
	http://rpm.livna.org/fedora/$releasever/$basearch/debug/
	http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
	http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
	ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
	http://rpm.livna.org/fedora/$releasever/SRPMS/
	http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
	http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
	http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
	http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
	ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
//note the info highlighted was the changed info, it was http://rpm.livna.org/fedora/$releasever/$basearch//
i think that was what i was supposed to change, now i get this

Code:
http://rpm.livna.org/fedora/8i-i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
 
Old 04-24-2008, 08:41 PM   #29
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Mixing third party repos is a bad idea. Atrpms is notorious for replacing components with ones that are not compatible with any other repo.
 
Old 04-24-2008, 08:49 PM   #30
Nolanz2
Member
 
Registered: Apr 2008
Location: Columbus Ohio, USA
Distribution: Ubuntu 8.04
Posts: 105

Original Poster
Rep: Reputation: 15
so what should i do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
http://download.fedora.us/fedora/fedora/3/i386/RPMS.os broken! caps_phisto Fedora 3 02-05-2005 05:16 PM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration